35 12
发新话题
引用:
原帖由 重庆哈哈 于 2015-4-3 21:33 发表
楠楠lzn 经典分时 - 3日K线植入分时主图指标公式

第一步:建立一个引用公式(位置放在主、副图都可),名称为:SS
O1:REF(O,1);
C1:REF(C,1);
H1:REF(H,1);
L1:REF(L,1);
O2:REF(O,2);
C2:REF(C,2);
H2: ...    
谢谢你这样清楚的解说,希望楼主也能在发表指标的同时说明一下使用方法,方便大家学习。
发消息 加好友
积分
3905 
理想币
179 个 
彩币
5 个 
共享币
33 个 
注册时间
2014-1-16 

复制

好用版本找到了分时写入五日K线
发消息 加好友
积分
2006 
理想币
1 个 
彩币
50 个 
共享币
922 个 
注册时间
2015-1-28 

复制

回复 楼主 @何守正 的帖子

当前公式 : 分时写入五日K (指标画线公式)  
错误句 :  
详细信息 : 输入字符串请用单引号'!
错误起始位置 : 369 ; 长度: 3
@何守正
发消息 加好友
积分
4012 
理想币
963 个 
彩币
0 个 
共享币
2011 个 
注册时间
2009-2-2 

复制

§83§ §83§ 谢谢
发消息 加好友
积分
199 
理想币
10 个 
彩币
5 个 
共享币
45 个 
注册时间
2015-2-11 

复制

老师能否将5日k线的位置放低一点,否则k线和当天走势重叠了
发消息 加好友
积分
1443 
理想币
13 个 
彩币
5 个 
共享币
67 个 
注册时间
2015-1-9 

复制

指标跟图上的不一样的啊…………
发消息 加好友
积分
2202 
理想币
33 个 
彩币
1 个 
共享币
621 个 
注册时间
2006-1-16 

复制

精品无限.谢谢老师!!!
发消息 加好友
积分
1159 
理想币
32 个 
彩币
5 个 
共享币
4 个 
注册时间
2015-6-14 

复制

东西有创意。。。。。。。。。。。。。。。。。谢谢分享
发消息 加好友
积分
1262 
理想币
1 个 
彩币
0 个 
共享币
452 个 
注册时间
2009-12-12 

复制

回复 楼主 @何守正 的帖子

谢谢了                   111111111
发消息 加好友
积分
47 
理想币
7 个 
彩币
1 个 
共享币
1 个 
注册时间
2015-8-21 

复制

精品无限.谢谢老师!!!
发消息 加好友
积分
70 
理想币
0 个 
彩币
0 个 
共享币
66 个 
注册时间
2017-7-2 

复制

§60§ §60§
发消息 加好友
积分
669 
理想币
0 个 
彩币
5 个 
共享币
3 个 
注册时间
2013-4-16 

复制

谢谢楼主分享!!!
发消息 加好友
积分
15212 
理想币
4953 个 
彩币
0 个 
共享币
9291 个 
注册时间
2011-10-27 

复制

谢谢分享!!!!
发消息 加好友
积分
48 
理想币
22 个 
彩币
0 个 
共享币
41 个 
注册时间
2017-11-11 

复制

回复 楼主 @何守正 的帖子

{分时写入五日K线}
{幅图---名字写分时引用}
O1:REF(O,1);
C1:REF(C,1);
H1:REF(H,1);
L1:REF(L,1);
O2:REF(O,2);
C2:REF(C,2);
H2:REF(H,2);
L2:REF(L,2);
O3:REF(O,3);
C3:REF(C,3);
H3:REF(H,3);
L3:REF(L,3);
O4:REF(O,4);
C4:REF(C,4);
H4:REF(H,4);
L4:REF(L,4);
O5:REF(O,5);
C5:REF(C,5);
H5:REF(H,5);
L5:REF(L,5);
O6:REF(O,6);
C6:REF(C,6);
H6:REF(H,6);
L6:REF(L,6);





{放到分时主图代码最前面}
O5:="分时引用.O5#DAY";
C5:="分时引用.C5#DAY";
H5:="分时引用.H5#DAY";
L5:="分时引用.L5#DAY";
O4:="分时引用.O4#DAY";
C4:="分时引用.C4#DAY";
H4:="分时引用.H4#DAY";
L4:="分时引用.L4#DAY";
O3:="分时引用.O3#DAY";
C3:="分时引用.C3#DAY";
H3:="分时引用.H3#DAY";
L3:="分时引用.L3#DAY";
O2:="分时引用.O2#DAY";
C2:="分时引用.C2#DAY";
H2:="分时引用.H2#DAY";
L2:="分时引用.L2#DAY";
O1:="分时引用.O1#DAY";
C1:="分时引用.C1#DAY";
H1:="分时引用.H1#DAY";
L1:="分时引用.L1#DAY";
O0:=DYNAINFO(4);
C0:=DYNAINFO(7);
H0:=DYNAINFO(5);
L0:=DYNAINFO(6);

HH1:=MAX(H1,H2);
HH2:=MAX(H3,H4);
HH3:=MAX(MAX(H0,H5),MAX(HH1,HH2));
LL1:=MIN(L1,L2);
LL2:=MIN(L3,L4);
LL3:=MIN(MIN(L0,L5),MIN(LL1,LL2));
HL:=999/(HH3-LL3);

C52:=999-((C5-LL3)*HL);
H52:=999-((H5-LL3)*HL);
L52:=999-((L5-LL3)*HL);
O52:=999-((O5-LL3)*HL);
C42:=999-((C4-LL3)*HL);
H42:=999-((H4-LL3)*HL);
L42:=999-((L4-LL3)*HL);
O42:=999-((O4-LL3)*HL);
C32:=999-((C3-LL3)*HL);
H32:=999-((H3-LL3)*HL);
L32:=999-((L3-LL3)*HL);
O32:=999-((O3-LL3)*HL);
C22:=999-((C2-LL3)*HL);
H22:=999-((H2-LL3)*HL);
L22:=999-((L2-LL3)*HL);  
O22:=999-((O2-LL3)*HL);
C12:=999-((C1-LL3)*HL);
H12:=999-((H1-LL3)*HL);
L12:=999-((L1-LL3)*HL);  
O12:=999-((O1-LL3)*HL);
C02:=999-((C0-LL3)*HL);
H02:=999-((H0-LL3)*HL);
L02:=999-((L0-LL3)*HL);
O02:=999-((O0-LL3)*HL);

DRAWRECTREL( 8,H52, 8,L52,RGB(IF(C5>=O5,200,0),IF(C5>=O5,0,200),0));
DRAWRECTREL( 0,C52,16,O52,RGB(IF(C5>=O5,128,0),IF(C5>=O5,0,128),0));
DRAWRECTREL(28,H42,28,L42,RGB(IF(C4>=O4,200,0),IF(C4>=O4,0,200),0));
DRAWRECTREL(20,C42,36,O42,RGB(IF(C4>=O4,128,0),IF(C4>=O4,0,128),0));
DRAWRECTREL(48,H32,48,L32,RGB(IF(C3>=O3,200,0),IF(C3>=O3,0,200),0));
DRAWRECTREL(40,C32,56,O32,RGB(IF(C3>=O3,128,0),IF(C3>=O3,0,128),0));
DRAWRECTREL(68,H22,68,L22,RGB(IF(C2>=O2,200,0),IF(C2>=O2,0,200),0));
DRAWRECTREL(60,C22,76,O22,RGB(IF(C2>=O2,128,0),IF(C2>=O2,0,128),0));
DRAWRECTREL(88,H12,88,L12,RGB(IF(C1>=O1,200,0),IF(C1>=O1,0,200),0));
DRAWRECTREL(80,C12,96,O12,RGB(IF(C1>=O1,128,0),IF(C1>=O1,0,128),0));


DRAWRECTREL(108,H02,108,L02,RGB(IF(C0>=O0,200,0),IF(C0>=O0,0,200),0));
DRAWRECTREL(100,C02,116,O02,RGB(IF(C0>=O0,128,0),IF(C0>=O0,0,128),0));
发消息 加好友
积分
1709 
理想币
109 个 
彩币
0 个 
共享币
1422 个 
注册时间
2016-9-26 

复制

 35 12
发新话题
理想论坛 » 指标公式分享交流区 » 分时写入五日K线,好用版本找到了,完全加密,不限时
指标公式分享交流区:积分规则

快速回复主题

选项

发帖请务遵守本站的相关规则,所有发表(包括转发)政治、色情非法信息者本站将实时提供发贴者个人信息给公安局,追究责任,特此申明!
具体规则请参见 理想论坛会员守则》 《净化论坛环境,打击恶意灌水》。

您需要登录后才可以发帖

[完成后可按 Ctrl+Enter 发布]

理想论坛上的网友发表的帖子纯属个人意见,理想论坛不负任何责任!广告赞助商内容与本站无关!免责声明
理想论坛值班电话[9:30~18:30]: ☎ 400 016 5518-1 ☎ 010-5366 3090 ☎ 186 4906 9487(广告)187 1028 6081(广告)
找回密码 软件区:1006648222 百宝箱: 1006267111 广告: 1006269111 广告: 3145821447
诚信档案编号:CX20150604010215010383 信誉编号:TL852015042710940
工业和信息化部信息备案: 京ICP备15035364号 京ICP证151057号
关闭底部 打开底部 回顶部 到页底 理想论坛微信号:lixiang55188 扫描下载理想选股App