发新话题
公式1:
T1:=OBV>=REF(HHV(OBV,0),1);
VOLUME:=VOL;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
T2:=MAVOL1>MAVOL2;
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
T3:=DIF>DEA AND DIF>REF(DIF,1) AND DEA>REF(DEA,1);
QJJ:=VOL / ((H - L) * 2 - ABS(C - O));
XVL:=IF(C > O,QJJ * (H - L),IF(C < O,QJJ * (H - O + (C - L)),VOL / 2)) + IF(C > O,0 - QJJ * (H - C + (O - L)),IF(C < O,0 - QJJ * (H - L),0 - VOL / 2));
HSL:=XVL / 20 / 1.15;
攻击流量:=HSL * 0.55 + REF(HSL,1) * 0.33 + REF(HSL,2) * 0.22;
GJJ:=EMA(攻击流量,8);
流量基线:=GJJ;
T4:=流量基线>REF(流量基线,1);
比例:=WINNER(CLOSE)*100;
T5:=比例>90;
预警1:T1&&T2&&T3&&T4&&T5;
公式2:
DIF1:=EMA(C,12)-EMA(C,26);
DEA1:=EMA(DIF1,9);
AAA1:=(DIF1-DEA1)*2*60;
AAA上:IF(AAA1>REF(AAA1,1),AAA1,DRAWNULL),STICK,COLORRED,LINETHICK8;
黑马线:15;
主力:AAA1-REF(AAA1,1),NODRAW;
选股:AAA上>15||主力>15;
发消息 加好友
积分
2448 
理想币
1018 个 
彩币
5 个 
共享币
658 个 
注册时间
2013-9-2 

复制

回复 楼主 @股友郑2 的帖子

@股友郑2
T1:=OBV>=REF(HHV(OBV,0),1);
VOLUME:=VOL;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
T2:=MAVOL1>MAVOL2;
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
T3:=DIF>DEA AND DIF>REF(DIF,1) AND DEA>REF(DEA,1);
QJJ:=VOL / ((H - L) * 2 - ABS(C - O));
XVL:=IF(C > O,QJJ * (H - L),IF(C < O,QJJ * (H - O + (C - L)),VOL / 2)) + IF(C > O,0 - QJJ * (H - C + (O - L)),IF(C < O,0 - QJJ * (H - L),0 - VOL / 2));
HSL:=XVL / 20 / 1.15;
攻击流量:=HSL * 0.55 + REF(HSL,1) * 0.33 + REF(HSL,2) * 0.22;
GJJ:=EMA(攻击流量,8);
流量基线:=GJJ;
T4:=流量基线>REF(流量基线,1);
比例:=WINNER(CLOSE)*100;
T5:=比例>90;
X2:=T1 AND T2 AND T3 AND T4 AND T5;

DIF1:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
AAA1:=(DIF1-DEA1)*2*60;
AAA上:=IF(AAA1>REF(AAA1,1),AAA1,DRAWNULL);
主力:=AAA1-REF(AAA1,1);
CROSS(AAA上,15) AND CROSS(主力,15) AND X2;
发消息 加好友
积分
88455 
理想币
63803 个 
彩币
533 个 
共享币
35143 个 
注册时间
2010-1-31 

复制

T1:=OBV>=REF(HHV(OBV,0),1);

VOLUME:=VOL;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
T2:=MAVOL1>MAVOL2;

SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
T3:=DIF>DEA AND DIF>REF(DIF,1) AND DEA>REF(DEA,1);

QJJ:=VOL / ((H - L) * 2 - ABS(C - O));
XVL:=IF(C > O,QJJ * (H - L),IF(C < O,QJJ * (H - O + (C - L)),VOL / 2)) + IF(C > O,0 - QJJ * (H - C + (O - L)),IF(C < O,0 - QJJ * (H - L),0 - VOL / 2));
HSL:=XVL / 20 / 1.15;
攻击流量:=HSL * 0.55 + REF(HSL,1) * 0.33 + REF(HSL,2) * 0.22;
GJJ:=EMA(攻击流量,8);
流量基线:=GJJ;
T4:=流量基线>REF(流量基线,1);

比例:=WINNER(CLOSE)*100;
T5:=比例>90;

X1:=T1 AND T2 AND T3 AND T4 AND T5;               



DIF1:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
{柱状线}
AAA1:=(DIF1-DEA1)*2*60;
AAA上:=IF(AAA1>REF(AAA1,1),AAA1,DRAWNULL);
主力:=AAA1-REF(AAA1,1);
AAA上>15&&AAA上&&主力>15&&主力>REF(主力,1)&&X1;
  • 2018-1-15 09:32 理想币 +10 任刚: 赠人玫瑰之手,经久犹有余香!
  • 2018-1-15 09:32 共享币 +5 任刚: 赠人玫瑰之手,经久犹有余香!
发消息 加好友
积分
49159 
理想币
24281 个 
彩币
260 个 
共享币
6780 个 
注册时间
2005-5-1 

复制

回复 3楼 @老马识途10 的帖子

@老马识途10 老师好,预警不出来,是不是有问题。我的要求是当盘中2个预警条件同时满足时及时预警,请你再看看,是同时满足时。谢谢

[ 本帖最后由 股友郑2 于 2018-1-13 18:02 编辑 ]
发消息 加好友
积分
3918 
理想币
176 个 
彩币
5 个 
共享币
3 个 
注册时间
2014-4-27 

复制

回复 4楼 @注册111 的帖子

@注册111 谢谢你老师,周末愉快!!!!!!!!!
发消息 加好友
积分
3918 
理想币
176 个 
彩币
5 个 
共享币
3 个 
注册时间
2014-4-27 

复制

回复 5楼 @股友郑2 的帖子

@股友郑2
能选出

[ 本帖最后由 老马识途10 于 2018-1-13 18:31 编辑 ]

附件:

111.png (12.83 KB)

2018-1-13 18:29

111.png

1111.png (19.64 KB)

2018-1-13 18:31

1111.png

  • 2018-1-16 16:27 理想币 +2 今曰: 谢谢老马老师无私分享!您辛苦了!
发消息 加好友
积分
88455 
理想币
63803 个 
彩币
533 个 
共享币
35143 个 
注册时间
2010-1-31 

复制

回复 7楼 @老马识途10 的帖子

@老马识途10 谢谢你老师,不是的。4楼做的是我需要的。再次谢谢你。
发消息 加好友
积分
3918 
理想币
176 个 
彩币
5 个 
共享币
3 个 
注册时间
2014-4-27 

复制

谢谢分享
发消息 加好友
积分
5863 
理想币
475 个 
彩币
10 个 
共享币
1750 个 
注册时间
2012-5-30 

复制

回复 7楼 @老马识途10 的帖子

@老马识途10

公式1:
OBV>=REF(HHV(OBV,0),1);                        预警条件:盘中出现提示信号时。


公式2:
DIF1:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
{柱状线}
AAA1:=(DIF1-DEA1)*2*60;
AAA上:IF(AAA1>REF(AAA1,1),AAA1,DRAWNULL),STICK,COLORRED,LINETHICK8;
AAA下:IF(AAA1<REF(AAA1,1),AAA1,DRAWNULL),STICK,COLORGREEN,LINETHICK8;
黑马线:15;
主力:AAA1-REF(AAA1,1),COLORRED;
DRAWICON(CROSS(主力,黑马线),黑马线,1);
中轴线:0;
关注线:7;
MM:=主力>30 AND 主力<70 AND AAA上>0 ;
DRAWTEXT(MM,(主力)*(0.928),'暴涨'),COLORFF00FF;
MM1:=主力>15 AND 主力<30 AND AAA上>0;
DRAWTEXT(MM1,(主力)*(0.928),'涨'),COLORYELLOW;
MM2:=主力>80 AND AAA上>0 ;
DRAWTEXT(MM2,(主力)*(0.928),'翻翻涨'),COLORRED;
MM3:=CROSS(主力,2) AND CROSS(AAA上,0.5) AND 主力>AAA上 AND 主力<15;
DRAWTEXT(MM3,(主力)*(0.928),'近期可能涨停'),COLORFFFF00;        预警条件:盘中AAA上大于15且上涨时,及盘中主力大于15且上涨时。

                     
                       盘中预警要求:盘中以上2个预警条件同时满足时,及时预警。谢谢!!!!!!!
发消息 加好友
积分
3918 
理想币
176 个 
彩币
5 个 
共享币
3 个 
注册时间
2014-4-27 

复制

发新话题
理想论坛 » 指标编写互助答疑区 » 请老师编写通达信盘中预警公式,谢谢!!
指标编写互助答疑区:积分规则

快速回复主题

选项

发帖请务遵守本站的相关规则,所有发表(包括转发)政治、色情非法信息者本站将实时提供发贴者个人信息给公安局,追究责任,特此申明!
具体规则请参见 理想论坛会员守则》 《净化论坛环境,打击恶意灌水》。

您需要登录后才可以发帖

[完成后可按 Ctrl+Enter 发布]

理想论坛上的网友发表的帖子纯属个人意见,理想论坛不负任何责任!广告赞助商内容与本站无关!免责声明
理想论坛值班电话[9:30~18:30]: ☎ 400 016 5518-1 ☎ 010-5366 3090 ☎ 186 4906 9487(广告)187 1028 6081(广告)
找回密码 软件区:1006648222 百宝箱: 1006267111 广告: 1006269111 广告: 3145821447
诚信档案编号:CX20150604010215010383 信誉编号:TL852015042710940
工业和信息化部信息备案: 京ICP备15035364号 京ICP证151057号
关闭底部 打开底部 回顶部 到页底 理想论坛微信号:lixiang55188 扫描下载理想选股App
关闭
关闭
关闭
关闭