发新话题
X:=COUNT(C>REF(C,1) AND V>REF(V,1),3)=3;
CROSS(BACKSET(X,3),0.5);

{公式好像应该这么写,但这也是不能预警的}

因为使用了未来函数backset,是在满足3天条件成立以后才画上的三个红箭头,所以这个红箭头是不能预警的

这三个红箭头是同时出现的,是在满足最后一个红箭头之后,今年我的网络环境太差了,理想的服务器总是上不了,总见不到服务器响应,就一句话要发好几次

[ 本帖最后由 冯立祥 于 2018-1-13 23:18 编辑 ]
  • 2018-1-15 10:45 理想币 +10 任刚: 赠人玫瑰之手,经久犹有余香!
  • 2018-1-15 10:45 共享币 +5 任刚: 赠人玫瑰之手,经久犹有余香!
  • 2018-1-13 23:01 理想币 +2 理想255b4e: 老师晚上好..祝老师身体健康 生活愉快..股票天天涨停板
发消息 加好友
积分
23155 
理想币
16660 个 
彩币
1190 个 
共享币
8297 个 
注册时间
2016-7-17 

复制

回复 2楼 @冯立祥 的帖子

@冯立祥 老师晚上好..又2天没看见您了 这个指标就是您的指标 我看很好  我就这个预警  又麻烦您了  才选了下..可能是没有符合条件的 1只也没出现 ..那我也留着它
发消息 加好友
积分
1908 
理想币
15 个 
彩币
180 个 
共享币
119 个 
注册时间
2017-11-18 

复制

X:=COUNT(C>REF(C,1) AND V>REF(V,1),3)=3;
BACKSET(X,3);
这个有未来的。是选不出股的。
这样能预警
X:COUNT(C>REF(C,1) AND V>REF(V,1),3)=3;
  • 2018-1-15 10:45 理想币 +10 任刚: 赠人玫瑰之手,经久犹有余香!
  • 2018-1-15 10:45 共享币 +5 任刚: 赠人玫瑰之手,经久犹有余香!
  • 2018-1-13 23:12 理想币 +2 理想255b4e: 衷心的 谢谢老师..这回有预警了 祝 好人一生平安
发消息 加好友
积分
49058 
理想币
24188 个 
彩币
260 个 
共享币
6741 个 
注册时间
2005-5-1 

复制

回复 4楼 @注册111 的帖子

@注册111衷心的 谢谢老师..这回有预警了 祝 好人一生平安
发消息 加好友
积分
1908 
理想币
15 个 
彩币
180 个 
共享币
119 个 
注册时间
2017-11-18 

复制

这三个红箭头是同时出现的,是在满足最后一个红箭头之后,今年我的网络环境太差了,理想的服务器总是上不了,总见不到服务器响应
发消息 加好友
积分
23155 
理想币
16660 个 
彩币
1190 个 
共享币
8297 个 
注册时间
2016-7-17 

复制

回复 2楼 @冯立祥 的帖子

@冯立祥 哦 是这样啊 ..那我留着备用  在参考别的指标..没事..老师这两天挺忙吧..我没看见您来
  • 2018-1-13 23:27 理想币 +2 冯立祥: 我电脑总连不上理想服务器,其他网站没问题
发消息 加好友
积分
1908 
理想币
15 个 
彩币
180 个 
共享币
119 个 
注册时间
2017-11-18 

复制

这三个红箭头是同时出现的,是在满足最后一个红箭头之后,今年我的网络环境太差了,理想的服务器总是上不了,总见不到服务器响应,就一句话要发好几次
发消息 加好友
积分
23155 
理想币
16660 个 
彩币
1190 个 
共享币
8297 个 
注册时间
2016-7-17 

复制

回复 2楼 @冯立祥 的帖子

@冯立祥 那可能是您的电脑卡吧  我就这一个论坛...1上就上去 哈
发消息 加好友
积分
1908 
理想币
15 个 
彩币
180 个 
共享币
119 个 
注册时间
2017-11-18 

复制

回复 4楼 @注册111 的帖子

@注册111 VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:IF(VAR1D>0.015,VAR1F,0)/45,COLORMAGENTA;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:POW(VAR11,3)*0.1+POW(VAR11,1),COLORRED;
0,COLORYELLOW;



做一个紫色线出现时的选股公式可以吗老师
发消息 加好友
积分
650 
理想币
42 个 
彩币
5 个 
共享币
183 个 
注册时间
2015-6-10 

复制

回复 2楼 @冯立祥 的帖子

@冯立祥 VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:IF(VAR1D>0.015,VAR1F,0)/45,COLORMAGENTA;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:POW(VAR11,3)*0.1+POW(VAR11,1),COLORRED;
0,COLORYELLOW;



做一个紫色线出现时的选股公式可以吗老师
发消息 加好友
积分
650 
理想币
42 个 
彩币
5 个 
共享币
183 个 
注册时间
2015-6-10 

复制

回复 11楼 @士123我 的帖子

@士123我
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:=POW(VAR11,3)*0.1+POW(VAR11,1);
CROSS(主力资金,0);
发消息 加好友
积分
49058 
理想币
24188 个 
彩币
260 个 
共享币
6741 个 
注册时间
2005-5-1 

复制

引用:
原帖由 士123我 于 2018-1-14 10:17 发表
冯立祥 VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3* ...    
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:=IF(VAR1D>0.015,VAR1F,0)/45;
选股:CROSS(拉升资金>0,0.5);
发消息 加好友
积分
23155 
理想币
16660 个 
彩币
1190 个 
共享币
8297 个 
注册时间
2016-7-17 

复制

回复 13楼 @冯立祥 的帖子

@冯立祥 DRAWGBK(C>0, RGB(50,60,250),RGB(17,21,89),0,'11',0);
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,COLORGREEN;
支撑:=L1+P1*0.5/8,COLORRED;
中线:=(支撑+阻力)/2,COLORWHITE,POINTDOT;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:EMA(V11,3),LINETHICK2,COLORLIMAGENTA;
V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;
准备买入:STICKLINE(趋势线<11,趋势线,11,5,0),COLORYELLOW;
AA:=(趋势线<11) AND FILTER((趋势线<=11),15) AND C<中线;
BB0:=REF(趋势线,1)<11 AND CROSS(趋势线,11) AND C<中线;
BB1:=REF(趋势线,1)<11 AND REF(趋势线,1)>6 AND CROSS(趋势线,11);
BB2:=REF(趋势线,1)<6 AND REF(趋势线,1)>3 AND CROSS(趋势线,6);
BB3:=REF(趋势线,1)<3 AND REF(趋势线,1)>1 AND CROSS(趋势线,3);
BB4:=REF(趋势线,1)<1 AND REF(趋势线,1)>0 AND CROSS(趋势线,1);
BB5:=REF(趋势线,1)<0 AND CROSS(趋势线,0);
BB:=BB1=1 OR BB2=1 OR BB3=1 OR BB4=1 OR BB5=1;
下单买入:STICKLINE(BB=1 AND C<中线,11,50,5,0),COLORRED;
DRAWICON(BB=1 AND C<中线,55,1);
DRAWTEXT(BB0,60,'★买'),COLORRED;
DRAWTEXT(AA,16,'准备买入'),COLORYELLOW;
准备卖出:STICKLINE(趋势线>89,趋势线,89,5,0),COLORWHITE;
CC:=(趋势线>89) AND FILTER((趋势线>89),15) AND C>中线;
DD0:=REF(趋势线,1)>89 AND CROSS(89,趋势线) AND C>中线;
DD1:=REF(趋势线,1)>89 AND REF(趋势线,1)<94 AND CROSS(89,趋势线);
DD2:=REF(趋势线,1)>94 AND REF(趋势线,1)<97 AND CROSS(94,趋势线);
DD3:=REF(趋势线,1)>97 AND REF(趋势线,1)>99 AND CROSS(97,趋势线);
DD4:=REF(趋势线,1)>99 AND REF(趋势线,1)<100 AND CROSS(99,趋势线);
DD5:=REF(趋势线,1)>100 AND CROSS(100,趋势线);
DD:=DD1=1 OR DD2=1 OR DD3=1 OR DD4=1 OR DD5=1;
下单卖出:STICKLINE(DD=1 AND C>中线,89,50,5,0),COLORGREEN;
DRAWICON(DD=1 AND C>中线,45,2);
DRAWTEXT(DD0,40,'★卖'),COLORGREEN;
DRAWTEXT (CC,84,'准备卖出'),COLORWHITE;
冠军1号QQ:=474131998;
顶:89,COLORGREEN;
底:11,COLORRED;
中:50,POINTDOT,COLORWHITE;
DRAWTEXT(ISLASTBAR,顶,'顶'),COLORGREEN;
DRAWTEXT(ISLASTBAR,底,'底'),COLORRED;
DRAWTEXT(ISLASTBAR,中,'中'),COLORWHITE;




跟这个红柱买入合并一下把可以吗老师
发消息 加好友
积分
650 
理想币
42 个 
彩币
5 个 
共享币
183 个 
注册时间
2015-6-10 

复制

回复 13楼 @冯立祥 的帖子

@冯立祥 H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,COLORGREEN;
支撑:=L1+P1*0.5/8,COLORRED;
中线:=(支撑+阻力)/2;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:=EMA(V11,3),LINETHICK2,COLORLIMAGENTA;
V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;
AA:=(趋势线<11) AND FILTER((趋势线<=11),15) AND C<中线;
BB0:=REF(趋势线,1)<11 AND CROSS(趋势线,11) AND C<中线;
BB1:=REF(趋势线,1)<11 AND REF(趋势线,1)>6 AND CROSS(趋势线,11);
BB2:=REF(趋势线,1)<6 AND REF(趋势线,1)>3 AND CROSS(趋势线,6);
BB3:=REF(趋势线,1)<3 AND REF(趋势线,1)>1 AND CROSS(趋势线,3);
BB4:=REF(趋势线,1)<1 AND REF(趋势线,1)>0 AND CROSS(趋势线,1);
BB5:=REF(趋势线,1)<0 AND CROSS(趋势线,0);
BB:=BB1=1 OR BB2=1 OR BB3=1 OR BB4=1 OR BB5=1;
下单买入:=STICKLINE(BB=1 AND C<中线,11,50,5,0),COLORRED;
A:=BB=1 AND C<中线;
XG:下单买入 AND A;
这两个合并一下老师
发消息 加好友
积分
650 
理想币
42 个 
彩币
5 个 
共享币
183 个 
注册时间
2015-6-10 

复制

引用:
原帖由 士123我 于 2018-1-14 16:20 发表
冯立祥 H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,COLORGREEN;
支撑:=L1+P1*0.5/8,COLORRED;
中线:=(支撑+阻力)/2;
V11:=3*SMA((C-LLV(L,55))/(HHV( ...    
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:=IF(VAR1D>0.015,VAR1F,0)/45;
选股:=CROSS(拉升资金>0,0.5);

H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8;
支撑:=L1+P1*0.5/8;
中线:=(支撑+阻力)/2;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:=EMA(V11,3);
V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;
AA:=(趋势线<11) AND FILTER((趋势线<=11),15) AND C<中线;
BB0:=REF(趋势线,1)<11 AND CROSS(趋势线,11) AND C<中线;
BB1:=REF(趋势线,1)<11 AND REF(趋势线,1)>6 AND CROSS(趋势线,11);
BB2:=REF(趋势线,1)<6 AND REF(趋势线,1)>3 AND CROSS(趋势线,6);
BB3:=REF(趋势线,1)<3 AND REF(趋势线,1)>1 AND CROSS(趋势线,3);
BB4:=REF(趋势线,1)<1 AND REF(趋势线,1)>0 AND CROSS(趋势线,1);
BB5:=REF(趋势线,1)<0 AND CROSS(趋势线,0);
BB:=BB1=1 OR BB2=1 OR BB3=1 OR BB4=1 OR BB5=1;

XG:BB=1 AND C<中线 AND 选股;
发消息 加好友
积分
23155 
理想币
16660 个 
彩币
1190 个 
共享币
8297 个 
注册时间
2016-7-17 

复制

发新话题
理想论坛 » 指标编写互助答疑区 » 请老师做个指标预警.谢谢冯立祥老师已解决
指标编写互助答疑区:积分规则

快速回复主题

选项

发帖请务遵守本站的相关规则,所有发表(包括转发)政治、色情非法信息者本站将实时提供发贴者个人信息给公安局,追究责任,特此申明!
具体规则请参见 理想论坛会员守则》 《净化论坛环境,打击恶意灌水》。

您需要登录后才可以发帖

[完成后可按 Ctrl+Enter 发布]

理想论坛上的网友发表的帖子纯属个人意见,理想论坛不负任何责任!广告赞助商内容与本站无关!免责声明
理想论坛值班电话[9:30~18:30]: ☎ 400 016 5518-1 ☎ 010-5366 3090 ☎ 186 4906 9487(广告)187 1028 6081(广告)
找回密码 软件区:1006648222 百宝箱: 1006267111 广告: 1006269111 广告: 3145821447
诚信档案编号:CX20150604010215010383 信誉编号:TL852015042710940
工业和信息化部信息备案: 京ICP备15035364号 京ICP证151057号
关闭底部 打开底部 回顶部 到页底 理想论坛微信号:lixiang55188 扫描下载理想选股App
关闭
关闭