发新话题
支持源码 谢谢楼主分享。
发消息 加好友
积分
6315 
理想币
35 个 
彩币
385 个 
共享币
1076 个 
注册时间
2012-3-1 

复制

选股代码:
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
老二:=IF(BIAS2<=-10,1,0);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,150);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
爆发:=MACD<0 AND MACD>REF(MACD ,1) AND REF(MACD ,1)<REF(MACD ,2)AND REF(MACD ,2)<REF(MACD ,3)AND REF(MACD ,3)<REF(MACD ,4);
VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(VAR2+2*VAR3+3*VAR4)/6;
VAR6:=MA(VAR5,3);
大底:=VAR6<=-10;
VAR11:=CLOSE/MA(CLOSE,20)*100<80;
VAR12:=CLOSE/MA(CLOSE,40)*100<78;
VAR13:=CLOSE/MA(CLOSE,60)*100<72;
VAR14:=HIGH>LOW*1.051;
VAR15:=VAR14 AND COUNT(VAR14,5)>1;
中底:=VAR15 AND (VAR11 OR VAR12 OR VAR13);
趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
BB:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-20 AND 趋势线>-25) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-20,趋势线),1) AND CROSS(趋势线,-20));
XG:=BB;
操盘:=EMA((CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
跟风:=EMA((CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);
见到曙光:=CROSS(操盘,跟风) AND 操盘 <0 AND 跟风 <0;
WW:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
MM:=DMA(CLOSE,WW);
通道4:=(1-7/100)*MM;
VAR84:=EXPMA(CLOSE,9);
LDN:=EXPMA(VAR84*0.86,5);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
TTRR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:=DMP*100/TTRR;
MDI:=DMM*100/TTRR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);
买底:=C<=通道4 AND C<=LDN AND CCI<-100 AND ADX>=60 AND MDI >= PDI AND CLOSE>OPEN;
VAR82:=LLV(LOW,10);
VAR83:=HHV(HIGH,25);
能量:=EMA((CLOSE-VAR82)/(VAR83-VAR82)*4,4);
关注:=0.5;
红色箭头:=FILTER(CROSS(能量,关注),20);
XXG:=买底 OR 红色箭头;
A:=SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,4,1);
B:=SMA((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100,4,1);
MB:=SMA((B-50)*2,3,1)+SMA((A-50)*2,3,1)/2;
狗头金:=MB<-90;
综合: 狗头金 AND COUNT(XG,5) AND COUNT(中底,3) AND NOT(COUNT(XXG,1)) AND NOT(COUNT(见到曙光,3)) AND COUNT(老二,3) AND 大底 AND 爆发;
发消息 加好友
积分
3287 
理想币
53 个 
彩币
5 个 
共享币
253 个 
注册时间
2015-1-1 

复制

谢谢楼主分享。
发消息 加好友
积分
16899 
理想币
1575 个 
彩币
1 个 
共享币
9685 个 
注册时间
2006-12-13 

复制

支持源码分享.....
发消息 加好友
积分
16079 
理想币
1009 个 
彩币
0 个 
共享币
739 个 
注册时间
2005-4-4 

复制

谢谢你的无私分享。
发消息 加好友
积分
21939 
理想币
1327 个 
彩币
0 个 
共享币
7468 个 
注册时间
2007-7-15 

复制

谢谢楼主,非常有用
发消息 加好友
积分
97 
理想币
35 个 
彩币
0 个 
共享币
0 个 
注册时间
2018-5-23 

复制

支持源码  好评!
发消息 加好友
积分
15889 
理想币
2826 个 
彩币
100 个 
共享币
3026 个 
注册时间
2007-9-1 

复制

谢谢楼主分享
发消息 加好友
积分
3716 
理想币
1068 个 
彩币
5 个 
共享币
1394 个 
注册时间
2013-6-4 

复制

谢谢楼主分享源码!
发消息 加好友
积分
1946 
理想币
114 个 
彩币
0 个 
共享币
369 个 
注册时间
2011-6-23 

复制

感谢楼主分享

感谢楼主分享
发消息 加好友
积分
786 
理想币
9 个 
彩币
0 个 
共享币
147 个 
注册时间
2018-2-9 

复制

引用:
原帖由 老鼠KK 于 2018-6-14 07:08 发表
检测日期:2017年6月4日——2018年6月4日,胜率89%,信号出现总513次。我
从网上淘来的指标,经过不断组合、优化得到的,来之不易,但的确不是我的原创,最多是“引进、学习、消化、吸收、再创新”。

胜率89%,5 ...    
刚选出的请老师看看

附件:

2345截图20180613143205.png (8.92 KB)

2018-6-14 10:42

2345截图20180613143205.png

发消息 加好友
积分
29790 
理想币
3047 个 
彩币
0 个 
共享币
5652 个 
注册时间
2007-12-8 

复制

谢谢分享
发消息 加好友
积分
1769 
理想币
52 个 
彩币
1 个 
共享币
161 个 
注册时间
2016-8-6 

复制

回复 8楼 @三产木 的帖子

@三产木
点评,居然也能上图?指点一下,我不会啊
发消息 加好友
积分
940 
理想币
89 个 
彩币
0 个 
共享币
274 个 
注册时间
2017-12-10 

复制

回复 15楼 @石一峰 的帖子

@石一峰
好的,谢谢提醒
  • 2018-6-14 14:18 理想币 +10 石一峰: 感谢楼主的理解和支持!
发消息 加好友
积分
940 
理想币
89 个 
彩币
0 个 
共享币
274 个 
注册时间
2017-12-10 

复制

引用:
原帖由 老鼠KK 于 2018-6-14 07:08 发表
检测日期:2017年6月4日——2018年6月4日,胜率89%,信号出现总513次。我
从网上淘来的指标,经过不断组合、优化得到的,来之不易,但的确不是我的原创,最多是“引进、学习、消化、吸收、再创新”。

胜率89%,5 ...    
帮楼主简化一下,并配图(副图和选股通用):
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
老二:=IF(BIAS2<=-10,1,0);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,150);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
爆发:=MACD<0 AND MACD>REF(MACD ,1) AND REF(MACD ,1)<REF(MACD ,2)AND REF(MACD ,2)<REF(MACD ,3)AND REF(MACD ,3)<REF(MACD ,4);
VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(VAR2+2*VAR3+3*VAR4)/6;
VAR6:=MA(VAR5,3);
大底:=VAR6<=-10;
VAR11:=CLOSE/MA(CLOSE,20)*100<80;
VAR12:=CLOSE/MA(CLOSE,40)*100<78;
VAR13:=CLOSE/MA(CLOSE,60)*100<72;
VAR14:=HIGH>LOW*1.051;
VAR15:=VAR14 AND COUNT(VAR14,5)>1;
中底:=VAR15 AND (VAR11 OR VAR12 OR VAR13);
趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
BB:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-20 AND 趋势线>-25) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-20,趋势线),1) AND CROSS(趋势线,-20));
XG:=BB;
操盘:=EMA((CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
跟风:=EMA((CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);
见到曙光:=CROSS(操盘,跟风) AND 操盘 <0 AND 跟风 <0;
WW:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
MM:=DMA(CLOSE,WW);
通道4:=(1-7/100)*MM;
VAR84:=EXPMA(CLOSE,9);
LDN:=EXPMA(VAR84*0.86,5);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
TTRR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:=DMP*100/TTRR;
MDI:=DMM*100/TTRR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);
买底:=C<=通道4 AND C<=LDN AND CCI<-100 AND ADX>=60 AND MDI >= PDI AND CLOSE>OPEN;
VAR82:=LLV(LOW,10);
VAR83:=HHV(HIGH,25);
能量:=EMA((CLOSE-VAR82)/(VAR83-VAR82)*4,4);
关注:=0.5;
红色箭头:=FILTER(CROSS(能量,关注),20);
XXG:=买底 OR 红色箭头;
A:=SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,4,1);
B:=SMA((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100,4,1);
MB:=SMA((B-50)*2,3,1)+SMA((A-50)*2,3,1)/2;
狗头金:=MB<-90;
综合: 狗头金 AND COUNT(XG,5) AND COUNT(中底,3) AND NOT(COUNT(XXG,1)) AND NOT(COUNT(见到曙光,3)) AND COUNT(老二,3) AND 大底 AND 爆发;

选股:


[ 本帖最后由 常怡_28 于 2018-6-14 11:41 编辑 ]
发消息 加好友
积分
7119 
理想币
793 个 
彩币
0 个 
共享币
9401 个 
注册时间
2015-10-15 

复制

谢谢楼主分享
发消息 加好友
积分
3785 
理想币
44 个 
彩币
0 个 
共享币
51 个 
注册时间
2017-7-31 

复制

引用:
原帖由 @常怡_28 于 2018-6-14 11:25 发表

帮楼主简化一下,并配图:
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
老二:=IF(BIAS2    
能否麻烦老师搞个选股公式?谢谢
发消息 加好友
积分
13439 
理想币
342 个 
彩币
0 个 
共享币
1216 个 
注册时间
2011-6-27 

复制

谢谢楼主分享
发消息 加好友
积分
3096 
理想币
63 个 
彩币
5 个 
共享币
1727 个 
注册时间
2015-2-26 

复制

谢谢楼主分享。
发消息 加好友
积分
366 
理想币
44 个 
彩币
0 个 
共享币
74 个 
注册时间
2018-6-5 

复制

后一页【ctrl+“→”】 【ctrl+“←”】前一页 还有8页内容,点此下一页
发新话题
理想论坛 » 指标公式分享交流区 » 八卦太极89%(源码 副图/选股 通达信 贴图),不是我的原创
指标公式分享交流区:积分规则

快速回复主题

选项

发帖请务遵守本站的相关规则,所有发表(包括转发)政治、色情非法信息者本站将实时提供发贴者个人信息给公安局,追究责任,特此申明!
具体规则请参见 理想论坛会员守则》 《净化论坛环境,打击恶意灌水》。

您需要登录后才可以发帖

[完成后可按 Ctrl+Enter 发布]

理想论坛上的网友发表的帖子纯属个人意见,理想论坛不负任何责任!广告赞助商内容与本站无关!免责声明
理想论坛值班电话[9:30~18:30]: ☎ 400 016 5518-1 ☎ 010-5366 3090 ☎ 186 4906 9487(广告)187 1028 6081(广告)
找回密码 软件区:1006648222 百宝箱: 1006267111 广告: 1006269111 广告: 3145821447
诚信档案编号:CX20150604010215010383 信誉编号:TL852015042710940
工业和信息化部信息备案: 京ICP备15035364号 京ICP证151057号
关闭底部 打开底部 回顶部 到页底 理想论坛微信号:lixiang55188 扫描下载理想选股App
关闭
关闭