发新话题
沙盘推演,信号飘移严重
发消息 加好友
积分
2575 
理想币
245 个 
彩币
1 个 
共享币
3181 个 
注册时间
2012-4-5 

复制

编了个选股公式,请老师们优化指正。

DIF12:=(EMA(CLOSE,12)-EMA(CLOSE,26))/((EMA(CLOSE,12)+EMA(CLOSE,26))/2)*1000;
DEA12:=EMA(DIF12,9);
KDIF12:=3*(DIF12-DEA12);
KDEA12:=SMA(KDIF12,5,2);

微分DIF:=KDIF12*5;
微分DEA:=KDEA12*5;
MACD2:=2*(微分DIF-微分DEA);
MAMACD:=MA(MACD2,3),,;



微分DIF2:=KDIF12*5;
微分DEA2:=KDEA12*5;
NOTEXT强:=IF(微分DIF2<MA(微分DIF2,2),微分DIF2,DRAWNULL);
NOTEXT弱:=IF(微分DEA2<MAX(微分DEA2,REF(微分DEA2,1)),微分DEA2,DRAWNULL);

N1:=6; N2:=12; N3:=24;

YLC:=周月RSI引用.LC#MONTH;
YY11:=周月RSI引用.YN11#MONTH;
YY12:=周月RSI引用.YN12#MONTH;

ZLC:=周月RSI引用.LC#WEEK;
ZY11:=周月RSI引用.YN11#WEEK;
ZY12:=周月RSI引用.YN12#WEEK;

YRSI1:=((MAX(C-YLC,0)+YY11*(N1-1))/N1)/((ABS(C-YLC)+YY12*(N1-1))/N1)*100;
ZRSI1:=((MAX(C-ZLC,0)+YY11*(N1-1))/N1)/((ABS(C-ZLC)+ZY12*(N1-1))/N1)*100;

月RI1:=YRSI1,COLORWHITE;
周RI1:=ZRSI1,COLORWHITE;

零:=0;
N:=50;
沧海行周J:="KDJ.J#WEEK" ;
沧海行周D:="KDJ.D#WEEK" ;
沧海行周MA:=50*"MACD.MACD#WEEK" ;

零点:=(CONST(LLV(沧海行周MA,90))+CONST(HHV(沧海行周MA,90)))/2;
DI:=月RI1;
F分:=CONST(LLV(DI,90));
F百:=CONST(HHV(DI,90))-F分;
点:=CONST(LLV(沧海行周MA,90));
基:=CONST(HHV(沧海行周MA,90))-点;
F比:=(DI-F分)/F百;
XFX:=F比*基+点;

周零点:=(CONST(LLV(沧海行周MA,90))+CONST(HHV(沧海行周MA,90)))/2;
周DI:=周RI1;{月RSI1叠加}
周F分:=CONST(LLV(周DI,90));
周F百:=CONST(HHV(周DI,90))-周F分;
周点:=CONST(LLV(沧海行周MA,90));
周基:=CONST(HHV(沧海行周MA,90))-周点;
周F比:=(周DI-周F分)/周F百;
周XFX:=周F比*周基+周点;
周涨跌提醒:=周XFX*2;

月涨跌提醒:=XFX*4;


XG:=IF(月涨跌提醒-REF(月涨跌提醒,1)>100,1,0);
GS:(月涨跌提醒>0  AND  CROSS(微分DIF,微分DEA)) OR XG=1;
发消息 加好友
积分
7162 
理想币
18 个 
彩币
0 个 
共享币
81 个 
注册时间
2007-1-10 

复制

看起来还行,看看实战如何
发消息 加好友
积分
350 
理想币
8 个 
彩币
0 个 
共享币
116 个 
注册时间
2018-6-6 

复制

回复 楼主 @高惠全 的帖子

@高惠全 谢谢啊
发消息 加好友
积分
3258 
理想币
208 个 
彩币
20 个 
共享币
128 个 
注册时间
2007-2-23 

复制

回复陈涛as
发消息 加好友
积分
5874 
理想币
639 个 
彩币
0 个 
共享币
1581 个 
注册时间
2011-11-29 

复制

谢谢楼主分享,学习了!
发消息 加好友
积分
701 
理想币
6 个 
彩币
0 个 
共享币
170 个 
注册时间
2017-1-14 

复制

@高惠全 感觉月提醒>周提醒比较好。对吗?
发消息 加好友
积分
7162 
理想币
18 个 
彩币
0 个 
共享币
81 个 
注册时间
2007-1-10 

复制

发消息 加好友
积分
5874 
理想币
639 个 
彩币
0 个 
共享币
1581 个 
注册时间
2011-11-29 

复制

回复 103楼 @陈涛as 的帖子

公式不错,今天选出31只票,关键是复盘的好票也进去了,最好再优化,月提醒与周提醒同时起爆成功率票更好,供参考。
@陈涛as
发消息 加好友
积分
11854 
理想币
4875 个 
彩币
5 个 
共享币
5046 个 
注册时间
2014-11-1 

复制

在这声明,102楼的评论有误,虽然在沙盘推演时,指标的数值在变化,但指标的形态却一直保持,所以据此判断信号还是准确的,看来楼主对未来函数的应用已到出神入化的地步,同时向楼主表示歉意
发消息 加好友
积分
2575 
理想币
245 个 
彩币
1 个 
共享币
3181 个 
注册时间
2012-4-5 

复制

回复郭武

回复郭武
我愿意接受不同的观点,不然,我们每个人到论坛来又为的是什么呢,
通过不同的观点,我可以得到重点,告诉我应该更重视什么,就已经
是很大的收获了。
另外,我想说,用数值来做操作,是机构或操盘手玩弄散户的手法,
所以,我更重视“势”,所谓一根直尺创天下,就有此意,谢谢大家的批评指教.
发消息 加好友
积分
5874 
理想币
639 个 
彩币
0 个 
共享币
1581 个 
注册时间
2011-11-29 

复制

谢谢分享!

谢谢分享!
发消息 加好友
积分
604 
理想币
102 个 
彩币
5 个 
共享币
77 个 
注册时间
2014-6-14 

复制

感谢分享,下载看看
发消息 加好友
积分
3355 
理想币
81 个 
彩币
0 个 
共享币
476 个 
注册时间
2017-10-15 

复制

谢谢分享
发消息 加好友
积分
理想币
0 个 
彩币
0 个 
共享币
33 个 
注册时间
2018-6-28 

复制

回复 9楼 @高惠全 的帖子

@高惠全 这张图修改参数了吗?
发消息 加好友
积分
16949 
理想币
1996 个 
彩币
20 个 
共享币
28 个 
注册时间
2008-6-7 

复制

楼主快出选股公式啊
发消息 加好友
积分
352 
理想币
0 个 
彩币
0 个 
共享币
6 个 
注册时间
2018-4-5 

复制

回复海中沙鱼

月RSI1叠加:XFX*4,LINETHICK1,COLORRED,LINETHICK3;
中*4或*5,都可以,可以修改,是为了线平坦时显示清楚,看得清时不用修改,道理没变,自己明白就可以。
对于选股,还是看趋势好,画一条线,看有没有突破,这样保险,比用公式好,虽然麻烦,
但对于突破趋势线大幅度向上的就可关注,此时是我个人的真实想法,不想误导大家,
大盘大跌,小心小心驶得万年船.
发消息 加好友
积分
5874 
理想币
639 个 
彩币
0 个 
共享币
1581 个 
注册时间
2011-11-29 

复制

没有错
如果股票不好,图也不会好,红色穿的高,才好,图就看的清了,会提前发现行情,
发消息 加好友
积分
18222 
理想币
9750 个 
彩币
5 个 
共享币
105 个 
注册时间
2015-2-5 

复制

回复理想0ae142

月RSI1叠加:XFX*4,LINETHICK1,COLORRED,LINETHICK3;
中*4或*5,都可以,可以修改,是为了线平坦时显示清楚,看得清时不用修改,道理没变,自己明白就可以。
对于选股,还是看趋势好,画一条线,看有没有突破,这样保险,比用公式好,虽然麻烦,
但对于突破趋势线大幅度向上的就可关注,此时是我个人的真实想法,不想误导大家,
大盘大跌,小心小心驶得万年船.
发消息 加好友
积分
5874 
理想币
639 个 
彩币
0 个 
共享币
1581 个 
注册时间
2011-11-29 

复制

后一页【ctrl+“→”】 【ctrl+“←”】前一页 还有8页内容,点此下一页
发新话题
理想论坛 » 指标公式分享交流区 » 涨跌超前提醒(指标 副图 通达信 贴图)
指标公式分享交流区:积分规则

快速回复主题

选项

发帖请务遵守本站的相关规则,所有发表(包括转发)政治、色情非法信息者本站将实时提供发贴者个人信息给公安局,追究责任,特此申明!
具体规则请参见 理想论坛会员守则》 《净化论坛环境,打击恶意灌水》。

您需要登录后才可以发帖

[完成后可按 Ctrl+Enter 发布]

理想论坛上的网友发表的帖子纯属个人意见,理想论坛不负任何责任!广告赞助商内容与本站无关!免责声明
理想论坛值班电话[9:30~18:30]: ☎ 400 016 5518-1 ☎ 010-5366 3090 ☎ 186 4906 9487(广告)187 1028 6081(广告)
找回密码 软件区:1006648222 百宝箱: 1006267111 广告: 1006269111 广告: 3145821447
诚信档案编号:CX20150604010215010383 信誉编号:TL852015042710940
工业和信息化部信息备案: 京ICP备15035364号 京ICP证151057号
关闭底部 打开底部 回顶部 到页底 理想论坛微信号:lixiang55188 扫描下载理想选股App
关闭
关闭