发新话题
引用:
原帖由 @川仔老头 于 2018-7-12 16:56 发表
条件是对MACD指标的DIF值的判定:
假设MACD第一次上0轴,之后DIF出现最高值后转折向下这个转折点为A,之后DIF下0轴一段时间之后第二次上0轴,DIF持续向上,当DIF值等于A点值时的点为B,想要在B点对应的日K线(前后一日 ...    
根据文字要求,

所画示意图为什么不是下图青色画的所示的样子,

发消息 加好友
积分
27078 
理想币
2796 个 
彩币
23110 个 
共享币
12642 个 
注册时间
2007-8-2 

复制

@听雪寻股 多谢老师关注,因为是要取水上的最高值,但凡dif下了水了就要重新计算一次,所以您画的图的是完全正确的!
发消息 加好友
积分
329 
理想币
88 个 
彩币
0 个 
共享币
99 个 
注册时间
2017-10-25 

复制

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
JZX:=DIF>0 AND MACD>0 AND REF(DIF,1)=HHV(DIF,3);
T:=BARSLAST(JZX);
XG:=COUNT(DIF<0,T)>=1 AND CROSS(DIF,REF(DIF,T+1));
Q1:=REF(XG,1);
QQ1:=BACKSET(Q1,3);
QQQ1:=IF(QQ1=1,H,0);
QQQQ1:=BARSLAST(H=HHV(QQQ1,3));
DRAWLINE(QQQQ1=0,H,REF(QQQQ1=0,1),REF(H,1),1),COLORYELLOW,DOTLINE;

阿宝和益阳龙二位老师的结合体,二者对条件的写法有妙不可言的特点,值得学习
发消息 加好友
积分
8843 
理想币
2331 个 
彩币
384 个 
共享币
4130 个 
注册时间
2009-12-19 

复制

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
JZX:=DIF>0 AND MACD>0 AND REF(DIF,1)=HHV(DIF,3);
T:=BARSLAST(JZX);
XG:=COUNT(DIF<0,T)>=1 AND CROSS(DIF,REF(DIF,T+1));
Q1:=REF(XG,1);
QQ1:=BACKSET(Q1,3);
QQQ1:=IF(QQ1=1,H,0);
QQQQ1:=BARSLAST(H=HHV(QQQ1,3));
DRAWLINE(QQQQ1=0,H,REF(QQQQ1=0,1),REF(H,1),1),COLORYELLOW,DOTLINE;
发消息 加好友
积分
8843 
理想币
2331 个 
彩币
384 个 
共享币
4130 个 
注册时间
2009-12-19 

复制

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
JZX:=DIF>0 AND MACD>0 AND REF(DIF,1)=HHV(DIF,3);
T:=BARSLAST(JZX);
XG:=COUNT(DIF<0,T)>=1 AND CROSS(DIF,REF(DIF,T+1));
Q1:=REF(XG,1);
QQ1:=BACKSET(Q1,3);
QQQ1:=IF(QQ1=1,H,0);
QQQQ1:=BARSLAST(H=HHV(QQQ1,3));
DRAWLINE(QQQQ1=0,H,REF(QQQQ1=0,1),REF(H,1),1),COLORYELLOW,DOTLINE;
发消息 加好友
积分
8843 
理想币
2331 个 
彩币
384 个 
共享币
4130 个 
注册时间
2009-12-19 

复制

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
JZX:=DIF>0 AND MACD>0 AND REF(DIF,1)=HHV(DIF,3);
T:=BARSLAST(JZX);
XG:=COUNT(DIF<0,T)>=1 AND CROSS(DIF,REF(DIF,T+1));
Q1:=REF(XG,1);
QQ1:=BACKSET(Q1,3);
QQQ1:=IF(QQ1=1,H,0);
QQQQ1:=BARSLAST(H=HHV(QQQ1,3));
DRAWLINE(QQQQ1=0,H,REF(QQQQ1=0,1),REF(H,1),1),COLORYELLOW,DOTLINE;

怎么就提交不了
发消息 加好友
积分
8843 
理想币
2331 个 
彩币
384 个 
共享币
4130 个 
注册时间
2009-12-19 

复制

@甲铭 多谢大哥再次发,最近几日在忙没上论坛,你发的这个还是一样会遗漏信号
发消息 加好友
积分
329 
理想币
88 个 
彩币
0 个 
共享币
99 个 
注册时间
2017-10-25 

复制

发新话题
理想论坛 » 指标编写互助答疑区 » macd的dif过峰高点定位取值画线
指标编写互助答疑区:积分规则

快速回复主题

选项

发帖请务遵守本站的相关规则,所有发表(包括转发)政治、色情非法信息者本站将实时提供发贴者个人信息给公安局,追究责任,特此申明!
具体规则请参见 理想论坛会员守则》 《净化论坛环境,打击恶意灌水》。

您需要登录后才可以发帖

[完成后可按 Ctrl+Enter 发布]

理想论坛上的网友发表的帖子纯属个人意见,理想论坛不负任何责任!广告赞助商内容与本站无关!免责声明
理想论坛值班电话[9:30~18:30]: ☎ 400 016 5518-1 ☎ 010-5366 3090 ☎ 186 4906 9487(广告)187 1028 6081(广告)
找回密码 软件区:1006648222 百宝箱: 1006267111 广告: 1006269111 广告: 3145821447
诚信档案编号:CX20150604010215010383 信誉编号:TL852015042710940
工业和信息化部信息备案: 京ICP备15035364号 京ICP证151057号
关闭底部 打开底部 回顶部 到页底 理想论坛微信号:lixiang55188 扫描下载理想选股App
关闭
关闭