根据小松班长的一招鲜系列的DMI捕捉爆涨股公式

[通达信]
设置
274178 305 青哇王子 Lv.3 发表于 · 2009-9-20 15:18 显示全部楼层 正序浏览 |
跳转到指定楼层
学习了小松班长的黑马秘籍------一招鲜系列
所要运用的捕捉爆涨股公式



DMI捕捉爆涨股
一三买入法
DMI穿一阳三线选股
CCI背离抄底
平台起飞
山谷停板
拨云见日
BIAS绝密买点
南天一柱
顶天立地

M1:MA(CLOSE,13),COLORYELLOW,LINETHICK2;
M2:MA(CLOSE,34),LINETHICK2,COLORWHITE;
M3:MA(CLOSE,55),COLORGREEN,LINETHICK2;

A:MA(C,5)COLORBLUE,LINETHICK3;
B:=A<REF(A,1);
IF(B-1,A,DRAWNULL)COLORRED,LINETHICK3;
DRAWTEXT(LAST(C<O,3,0) AND LAST(VOL<REF(VOL,1),3,0),L*0.975,'三阴\N缩量\N一阳');
DRAWTEXT(CROSS("DMI.PDI","DMI.MDI") AND CROSS("DMI.PDI","DMI.ADX") AND CROSS("DMI.PDI","DMI.ADXR") AND C>REF(C,1)*1.05 AND VOL>REF(VOL,1),L*0.975,'DMI\N捉暴涨');
DRAWTEXT(LAST(MA(C,5)<MA(C,10),5,0) AND "CCI.CCI">REF("CCI.CCI",1) AND CROSS("CCI.CCI",-100),L*0.975,'CCI\N背离底');
DRAWTEXT(LAST((H-L)/REF(C,1)<0.1,5,0) AND VOL>REF(VOL,1)*2 AND C>REF(C,1)*1.05,L*0.975,'一二一\N平台起');
DRAWTEXT(LAST(MA(C,5)<MA(C,10),5,0) AND C>REF(C,1)*1.098,L*0.975,'山谷\N停板');
DRAWTEXT((LAST(C<O,6,3) AND LAST(C>O,2,0)) OR (LAST(C<O,6,3) AND C>O AND REF(C,1)<REF(O,1) AND REF(C,2)>REF(O,2)),L*0.975,'拨云\N见日');
DRAWTEXT(CROSS((CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100,(CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*100) AND MA(C,40)>REF(MA(C,40),1),L*0.98,'BIAS\N绝密买点');
DRAWTEXT(C<O AND VOL>REF(VOL,1)*1.5 AND LAST(VOL<REF(VOL,1),5,1),L*0.975,'南天\N一柱');
DRAWTEXT((C>O AND V>REF(V,1)*2.5 AND CROSS(C,MA(C,5))) OR (C>O AND V>REF(V,1)*10),L*0.975,'顶天\N立地');



这是通达信选股公式:

第一个:

1.炒股一招鲜系列之  ——“一三买入法”。
公式分析:三根阴线量递减,然后出线了一根阳线
三连阴:LAST(c<o,3,0);
三缩量:LAST(VOL<ref(VOL,1),3,0);
选股:ref(三连阴,1)>0 and ref(三缩量,1)>0 and O<C
这个我通达信没装上选股公式请高手帮忙


第二个:
1.炒股一招鲜系列之二——DMI捕捉爆涨股
公式分析:PDI上穿三线,并且涨幅大于5%,并且成交量大于昨日
CROSS("DMI.PDI","DMI.MDI") and CROSS("DMI.PDI","DMI.ADX") and CROSS("DMI.PDI","DMI.ADXR") and C>REF(C,1)*1.05 and VOL>REF(VOL,1)

2.炒股一招鲜系列之二——DMI穿一阳三线选股
n:2,14,90
m:2,6,60


TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/TR;
MDI:=DMM*100/TR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=EXPMEMA(ADX,M);
买点:(CROSS(PDI, MDI)AND CROSS(PDI, ADX)AND CROSS(PDI, ADXR))AND CLOSE>OPEN
AND C/REF(C,1)>0.5 AND VOL>MA(VOL,5)*1.5,COLORRED,LINETHICK3;



第三个:
3.炒股一招鲜系列之三——CCI背离抄底
公式分析:近5日 5日均线一直在10均线下方,并且CCI一直变大,CCI上穿-100
1:   CCI背离抄底
LAST(MA(C,5)<MA(C,10),5,0) AND "CCI.CCI">REF("CCI.CCI",1) AND CROSS("CCI.CCI",-100);

2:   CCI背离抄底加限制
LAST(MA(C,5)<MA(C,10),5,0) AND "CCI.CCI">REF("CCI.CCI",1) AND CROSS("CCI.CCI",-100);
AND MA(C,60)>REF( MA(C,60),1);


第四个:
.炒股一招鲜系列之四——“一二一”抓平台起飞
公式分析:近5日K线最高价和最低价格波动在10%以内,成交量是昨日2倍,收盘涨5%

last((H-L)/ref(C,1)<0.1,5,0) and VOL>REF(VOL,1)*2 and C>ref(C,1)*1.05



第五个:

炒股一招鲜系列之五——“山谷停板“抄大底
公式分析:近5日 5日均线一直在10均线下方,突然涨停
LAST(MA(C,5)<MA(C,10),5,0) and C>ref(C,1)*1.098



第六个:
炒股一招鲜之六—— “ 拨云见日”买入绝技
公式分析:三根阴线后出现三根阳线,或者三根阴线后出现阳阴阳的组合

A:=(C-REF(C,1))/REF(C,1)*100;
A1:=REF(A,1);
A2:=REF(A1,1);
A3:=REF(A2,1);
A4:=REF(A3,1);
B:=CLOSE>=HIGH;
A4<0 AND A3<0 AND A2<0 AND A1<-4 AND B AND A>=5;



第七个:
.炒股一招鲜系列之七——BIAS绝密买点
公式分析:不会!谁会说一说
P1:=5;
P2:=11;
BIAS1:=(CLOSE-MA(CLOSE,P1))/MA(CLOSE,P1)*100;
BIAS2:=(CLOSE-MA(CLOSE,P2))/MA(CLOSE,P2)*100;
CROSS(BIAS1,BIAS2) AND BIAS1>REF(BIAS1,1) AND MA(C,40)>REF(MA(C,40),1);



第八个:
炒股一招鲜系之八——成交量之“南天一柱”抄底法
公式分析:阴线收盘,成交量是昨日 2.5 倍以上
这个我改了一下条件,效果也不理想
C<O and VOL>REF(VOL,1)*1.5 and LAST(VOL<REF(VOL,1),5,1)



第九个:
炒股一招鲜系之九——成交量之“顶天立地”抄底法
公式分析:阳线收盘成交量是是昨日 2.5 倍以上并且站上MA5,或阳线收盘成交量是是昨日 10 倍以上
a:=C>O and V>REF(V,1)*2.5 and CrOSS(C,MA(C,5));
B:=C>O and V>ref(V,1)*10;
A OR B



觉得好用的就回个帖支持一下哦~


举报

使用道具 扔鸡蛋(0) 回复

三产木
Lv.5
发表于 2017-3-12 19:50 复制 查看全部楼层
非常好,实用,谢谢!!!!!!

举报

使用道具 扔鸡蛋(0) 回复

速度好快
Lv.3
发表于 2016-6-7 12:38 复制 查看全部楼层
谢谢王子!!!!!

举报

使用道具 扔鸡蛋(0) 回复

一般可以
Lv.1
发表于 2014-8-12 21:34 复制 查看全部楼层
叙利亚T-72M1巷战后破败不堪

举报

使用道具 扔鸡蛋(0) 回复

东湖风
Lv.0
发表于 2014-7-19 17:51 复制 查看全部楼层
@青哇王子 几好的指标

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

花脸猫307
Lv.4
发表于 2014-4-29 15:25 复制 查看全部楼层
没有未来的好选股 ,我顶一下,谢谢

举报

使用道具 扔鸡蛋(0) 回复

笑少年轻
Lv.1
发表于 2014-4-23 22:18 复制 查看全部楼层
太谢谢小松班长啦!

举报

使用道具 扔鸡蛋(0) 回复

星期二二
Lv.3
发表于 2013-3-14 23:41 复制 查看全部楼层
怎么今天才看到。。。。。。

举报

使用道具 扔鸡蛋(0) 回复

欧阳闲
Lv.3
发表于 2013-3-9 11:43 复制 查看全部楼层
原帖由 @青哇王子 于 2009-9-20 19:26 发表 " onmouseover="img_onmouseoverfunc(this)" lazyloadthumb="1" border="0" alt="" />


n:2,90,14
m:2,60,6


TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
D ...

当前公式 : DMI一阳三线 (条件选股公式)  
错误句 :


TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N)
详细信息 : 变量 TR 与函数名重复!
错误起始位置 : 6 ; 长度: 2

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

张6484
Lv.4
发表于 2013-2-20 20:55 复制 查看全部楼层
没有未来的好选股 ,我顶一下,谢谢

举报

使用道具 扔鸡蛋(0) 回复

雪鸥
Lv.2
发表于 2013-2-17 00:17 复制 查看全部楼层
顶一下,谢谢!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

小散户1001
Lv.1
发表于 2013-2-16 15:37 复制 查看全部楼层
谢谢谢谢谢谢

举报

使用道具 扔鸡蛋(0) 回复

东邪508
Lv.0
发表于 2012-12-20 12:54 复制 查看全部楼层
原帖由 宽心1 于 2012-3-15 15:19 发表
错误句 :
TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N)
详细信息 : 变量 TR 与函数名重复!
错误起始位置 : 2 ; 长度: 2

把TR改为TR1就行了!!

举报

使用道具 扔鸡蛋(0) 回复

山高月小1
Lv.4
发表于 2012-12-1 01:43 复制 查看全部楼层
谢谢!!!!!!!!!!!!!!!!

举报

使用道具 扔鸡蛋(0) 回复

宽心1
Lv.3
发表于 2012-3-15 15:19 复制 查看全部楼层
错误句 :
TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N)
详细信息 : 变量 TR 与函数名重复!
错误起始位置 : 2 ; 长度: 2

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

快乐益笑
Lv.3
发表于 2012-3-12 20:25 复制 查看全部楼层
没有未来的好选股 ,我顶一下,谢谢

举报

使用道具 扔鸡蛋(0) 回复

学习zjp
Lv.3
发表于 2012-3-12 20:08 复制 查看全部楼层

举报

使用道具 扔鸡蛋(0) 回复

潇潇0899
Lv.2
发表于 2012-1-3 10:21 复制 查看全部楼层
我参数改了  公式里面的参数也删了 为啥还是通不过   还请高手指教   谢谢

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

小城2
Lv.5
发表于 2011-12-10 16:49 复制 查看全部楼层
喜欢楼主的风格。更喜欢楼主的帖子!

举报

使用道具 扔鸡蛋(0) 回复

刘进67222
Lv.2
发表于 2011-12-10 14:44 复制 查看全部楼层
没有未来的好选股 ,我顶一下,谢谢

举报

使用道具 扔鸡蛋(0) 回复

欢心鼓舞88
Lv.2
发表于 2011-12-8 21:04 复制 查看全部楼层
CROSS("DMI.PDI","DMI.MDI") and CROSS("DMI.PDI","DMI.ADX") and CROSS("DMI.PDI","DMI.ADXR") and C>REF(C,1)*1.05 and VOL>REF(VOL,1)

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

怡乐
Lv.4
发表于 2011-11-23 22:23 复制 查看全部楼层
真不错啊,谢谢!!!

举报

使用道具 扔鸡蛋(0) 回复

驰誉900
Lv.3
发表于 2011-11-20 10:43 复制 查看全部楼层
AND MA(C,60)>REF( MA(C,60),1)
详细信息 : 某个操作数没有相应的操作符匹配!
错误起始位置 : 101 ; 长度: 3通不过啊

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

稻草猫2011
Lv.2
发表于 2011-11-14 23:02 复制 查看全部楼层
当前公式 : DMI穿一阳三 (指标画线公式)  
错误句 : TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N)
详细信息 : 变量 TR 与函数名重复!
错误起始位置 : 0 ; 长度: 2



我的也是一样

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

行者9305
Lv.2
发表于 2011-11-13 23:57 复制 查看全部楼层
入学太晚,补课太多啊!

举报

使用道具 扔鸡蛋(0) 回复

红太狼1985
Lv.3
发表于 2011-10-28 21:31 复制 查看全部楼层
§83§ 太好; 看

举报

使用道具 扔鸡蛋(0) 回复

古道行者
Lv.3
发表于 2011-10-18 23:38 复制 查看全部楼层
,喜欢楼主的风格。更喜欢楼主的帖子。继续!

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

阿斯2009
Lv.4
发表于 2011-10-9 07:30 复制 查看全部楼层
不错的。我来顶一下。

举报

使用道具 扔鸡蛋(0) 回复

李建虢
Lv.4
发表于 2011-10-9 06:07 复制 查看全部楼层
喜欢楼主的风格。更喜欢楼主的帖子。继续!

举报

使用道具 扔鸡蛋(0) 回复

李全傲
Lv.2
发表于 2011-10-3 14:56 复制 查看全部楼层
没有未来的好选股 ,我顶一下,谢谢

举报

使用道具 扔鸡蛋(0) 回复

小犀牛角
Lv.3
发表于 2011-9-16 22:25 复制 查看全部楼层
有没有关于大智慧版本的公式啊?

举报

使用道具 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表