手机版 理想小程序
理想小程序
RSS 论坛APP
返回列表

有劳大侠将此主图指标改为大智慧主图指标

2万 6
设置
2283783 Lv.4

专栏

复制 显示全部楼层 倒序浏览 |
跳转到指定楼层

大智慧,NULL软件数据教程_技术交流论坛股票软件指标公式技术理想股票技术论坛

下面的主图指标很好,有劳大侠将此主图指标改为大智慧主图指标截图如下:源码如下:DRAWGBK(C>0,RGB(150,50,175),RGB(0,25,100),0,' ',0);布林轨:(MA(C,3)+MA( ...软件数据教程_技术交流论坛股票软件指标公式技术

下面的主图指标很好,有劳大侠将此主图指标改为大智慧主图指标
截图如下:
有劳大侠将此主图指标改为大智慧主图指标

源码如下:
DRAWGBK(C>0,RGB(150,50,175),RGB(0,25,100),0,' ',0);
布林轨:(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4,COLORRED,LINETHICK2;
MA3:=MA(CLOSE,20),COLORMAGENTA,LINETHICK2;
DRAWBAND(布林轨,RGB(250,125,50),MA3,RGB(0,150,250));
MA1:MA(CLOSE,5),COLORWHITE;
MA2:MA(CLOSE,10),COLORYELLOW;
IF(布林轨<MA3 OR C<布林轨,布林轨,DRAWNULL),COLORBLUE,LINETHICK2;
涨势线:IF(布林轨>MA3,MA3,DRAWNULL),COLORMAGENTA,LINETHICK3;
跌势线:IF(布林轨<=MA3,MA3,DRAWNULL),COLORLIBLUE,LINETHICK1;
MA4:MA(CLOSE,60),COLORGREEN;
HLCO:=(C+H+L+O)/4;
MAHC:=MA((CLOSE*2+H)/3,5),COLOR0000FF;
MAHO:=MA((O*2+H)/3,5),COLOR00FF00;
MALC:=MA((C+L*2)/3,5),COLORFFFFFF;
MALO:=MA((O+L*2)/3,5),COLOR00FFFF;
CO:=O+(C-O)/2;
DRAWKLINE(H,O,L,C);
STICKLINE("DMI.PDI">"DMI.MDI",C,O,2.9,0),COLOR000099;
STICKLINE("DMI.PDI">"DMI.MDI",C,O,1.5,0),COLOR0000CC;
STICKLINE("DMI.PDI">"DMI.MDI",C,O,0.1,0),COLOR9966FF;
STICKLINE(MAHC>=MAHO,C,O,2.9,0),COLOR000099;
STICKLINE(MAHC>=MAHO,C,O,1.5,0),COLOR0000CC;
STICKLINE(MAHC>=MAHO,C,O,0.1,0),COLOR9966FF;
STICKLINE(MAHC<MAHO AND "DMI.PDI"<"DMI.MDI",C,O,2.9,0),COLOR999900;
STICKLINE(MAHC<MAHO AND "DMI.PDI"<"DMI.MDI",C,O,1.5,0),COLORCCCC00;
STICKLINE(MAHC<MAHO AND "DMI.PDI"<"DMI.MDI",C,O,0.1,0),COLORFFFF66;
STICKLINE(MAHC>=MAHO AND C<MAHO,CO,MAX(O,C),2.8,0),COLORMAGENTA;
{STICKLINE(LC>MAHC,CO,MAX(C,O),2.8,0),COLORRED;
STICKLINE(LC<MAHC,CO,MIN(C,O),2.8,0),COLORCYAN;}
STICKLINE(CROSS(MAHC,MAHO),C,O,2.8,0),COLORYELLOW;
STICKLINE(MAHC<MAHO AND (CROSS(C,MALO) OR CROSS(HLCO,MALO)),CO,MIN(C,O),2.8,0),COLORWHITE;
STICKLINE(CROSS(MAHO,MAHC) AND C<O AND "DMI.PDI"<"DMI.MDI",C,O,2.8,0),COLORFF3300;
{STICKLINE(REF(C,1)<LC AND C>=LC AND CROSS(C,MAX(MAHC,MAHO)),CO,MIN(C,O),2.8,0),COLORYELLOW;}
{STICKLINE(REF(C,1)<LC AND C>=LC AND CROSS(C,MAHC) AND MAHC>MAHO,C,O,2.8,0),COLORYELLOW;}
TAR1:=REF(OPEN,1);
TAR2:=SMA(MAX(OPEN-TAR1,0),6,1)/SMA(ABS(OPEN-TAR1),6,1)*100;
TAR3:=REF(CLOSE,1);
TAR4:=SMA(MAX(CLOSE-TAR3,0),6,1)/SMA(ABS(CLOSE-TAR3),6,1)*100;
TAR5:=REF(HIGH,1);
TAR6:=SMA(MAX(HIGH-TAR5,0),6,1)/SMA(ABS(HIGH-TAR5),6,1)*100;
TAR7:=REF(LOW,1);
TAR8:=SMA(MAX(LOW-TAR7,0),6,1)/SMA(ABS(LOW-TAR7),6,1)*100;
TAR9:=(MIN(OPEN,CLOSE)-LOW)/LOW*100>VOL/CAPITAL*0.001 ;
TAR10:=(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,13))*100;
TAR11:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
TAR12:=EMA(TAR11,8)*10<-26;
TAR13:=IF(TAR9 AND MA(TAR10,5)<50 AND TAR12,30,0);
开盘值:=TAR2,COLORGREEN,NODRAW;
收盘值:=TAR4,COLORRED,NODRAW;
最高值:=TAR6,COLORMAGENTA,NODRAW;
最低值:=TAR8,COLORCYAN,NODRAW;
T小值:=MIN(MIN(MIN(开盘值,收盘值),最高值),最低值),NODRAW;
T大值:=MAX(MAX(MAX(开盘值,收盘值),最高值),最低值),NODRAW;
DRAWICON((LLV(T小值,5)<=20 OR LLV(T大值,5)<=30) AND CROSS(MAHC,MAHO),H,9);
倍量攻击:=V>REF(V,1)*2 AND (C>=O OR C>REF(C,1)),COLORRED,NODRAW;
STICKLINE(倍量攻击,C,O,0.5,0),COLOR0088FF;
N:=14; M:=6;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
MACCI1:=MA(CCI,3);
MACCI2:=EMA(CCI,3);
MACCI3:=SMA(CCI,5,1);
平安线:=(((MACCI3-LLV(MACCI3,21))/(HHV(MACCI3,21)-LLV(MACCI3,21)))*100-50)+50,COLORCYAN,LINETHICK3;
DDI:=IF(CCI>100,120,IF(CCI<-100,-120,CCI))/2+50,COLORYELLOW,LINETHICK2;

角线:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);
角线MA:=MA(角线,5);
ANA:=PLOYLINE(CROSS(角线,角线MA),角线MA),COLORRED;
ANB:=PLOYLINE(CROSS(角线MA,角线),角线MA),COLORFF00FF ;
角买点:=CROSS(角线,角线MA) AND ((ANB>REF(ANB,1) AND ANB>ANA AND 角线MA<=0) OR ((角线MA<=-45 OR CROSS(角线MA,-45)) AND (ANB<-60 OR LLV("KDJ.J",3)<=-49) AND ANB>0)),COLORGREEN;
角起涨:=COUNT(CROSS(角线,角线MA),ANA<REF(ANA,5) AND ANB>REF(ANB,5));
角卖点:=(CROSS(角线MA,角线) AND (ANB>REF(ANB,1) OR ANA<REF(ANA,1)) AND ANB>ANA{AND ANB>0} AND 角线MA>0)*1;
角始跌:=COUNT(CROSS(角线MA,角线),ANA<REF(ANA,5) AND ANB>REF(ANB,5));
DRAWTEXT(倍量攻击,L,'VOL');
DRAWTEXT(CROSS(MAHO,MAHC) AND C<O AND "DMI.PDI"<"DMI.MDI",H,'空仓'),COLORFFFF00;
DRAWTEXT(角买点,L,'角买'),COLORMAGENTA;
DRAWTEXT(角卖点 AND (平安线<50 OR DDI<50),H,'角卖'),COLORGREEN;

超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
大宗进:=(超B)+(大B),NODRAW;
大宗出:=(超S)+(大S),NODRAW;
非大宗进:=(中B)+(小B),NODRAW;
非大宗出:=(中S)+(小S),NODRAW;
大宗进限制:=IF((超B+大B)=0,0,大宗进);
大宗出限制:=IF((超S+大S)=0,0,大宗出);
非大宗进限制:=IF(中B+小B=0,0,非大宗进);
非大宗出限制:=IF(中S+小S=0,0,非大宗出);
主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;
散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;
净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;
大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;
大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);
大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;
大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);
总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;
总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;
成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;
机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;
大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;
大单强度限制:=IF(大单强度=0,-100,大单强度);
大单强度比:=IF(大单强度>=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;
超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;
超单强度限制:=IF(超单强度=0,-100,超单强度);
超单强度比:=IF(超单强度>0,(超单强度限制+100)/2,IF(超单强度<0,100-ABS((超单强度限制-100)/2),0)),NODRAW;

DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
DRAWRECTREL(0,CONST(950-(ABS(大宗进)*250/DAZHIV))-20,30,950,IF(CONST(大宗进>0),RGB(250,125,0),RGB(25,150,250)));
DRAWRECTREL(32,CONST(950-(ABS(大宗出)*250/DAZHIV))-20,62,950,IF(CONST(大宗出>0),RGB(25,150,250),RGB(250,125,0)));
DRAWRECTREL(102,CONST(950-(ABS(非大宗进)*250/DAZHIV))-20,132,950,IF(CONST(非大宗进>0),RGB(250,125,0),RGB(25,150,250)));
DRAWRECTREL(134,CONST(950-(ABS(非大宗出)*250/DAZHIV))-20,164,950,IF(CONST(非大宗出>0),RGB(25,150,250),RGB(250,125,0)));
DRAWRECTREL(204,CONST(950-(ABS(净流入)*250/DAZHIV))-20,234,950,IF(CONST(净流入>0),RGB(200,0,0),RGB(0,125,50)));
DRAWTEXT_FIX(1,0.00,0.95,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA;
DRAWTEXT_FIX(1,0.10,0.95,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN;
DRAWTEXT_FIX(1,0.20,0.95,0,STRCAT(STRCAT('净流入 ',CON2STR(净流入,0)),'万')),COLORYELLOW;

主买A:=ACTINVOL,COLORRED,NODRAW;
主卖A:=ACTOUTVOL,COLORGREEN,NODRAW;
主买:=主买A*100/(主买A+主卖A),NODRAW,COLORRED;
主卖:=主卖A*100/(主买A+主卖A),NODRAW,COLORGREEN;

大单买比:=LARGEINTRDVOL*100/(LARGEINTRDVOL+LARGEOUTTRDVOL);
大单卖比:=LARGEOUTTRDVOL*100/(LARGEINTRDVOL+LARGEOUTTRDVOL);
主力净买量:=(LARGEINTRDVOL-LARGEOUTTRDVOL),COLORYELLOW,NODRAW;
主动买卖差:=(ACTINVOL-ACTOUTVOL),COLORMAGENTA,NODRAW;
主力资金差:=((L2_AMO(0,0)+L2_AMO(1,0)-L2_AMO(0,1)-L2_AMO(1,1)))/10000,COLORCYAN,NODRAW;
主力买力度:=LARGEINTRDVOL*100/VOL;
主力卖力度:=LARGEOUTTRDVOL*100/VOL;
主买力度比:=主力买力度/(主力买力度+主力卖力度)*100,NODRAW;
主卖力度比:=主力卖力度/(主力买力度+主力卖力度)*100,NODRAW;
力度比限制:=IF((LARGEINTRDVOL+LARGEOUTTRDVOL)=0,0,大单买比);
JGV:=(L2_VOL(0,0) - L2_VOL(0,1))*VOL/100000000,COLORRED;
DHV:=(L2_VOL(1,0) - L2_VOL(1,1))*VOL/100000000,COLORFF00FF;
ZHV:=(L2_VOL(2,0) - L2_VOL(2,1))*VOL/100000000,COLOR00FFFF;
SHV:=(L2_VOL(3,0) - L2_VOL(3,1))*VOL/100000000,COLORFFFFFF;
NOTEXT大量动向:=MA((JGV+DHV),5),COLORYELLOW;
超级大量:=JGV,COLOR0000FF,NODRAW;
机构大量:=DHV,COLORMAGENTA,NODRAW;
大量博弈:=(JGV+DHV),COLORYELLOW,NODRAW;
小量博弈:=(ZHV+SHV),COLORWHITE,NODRAW;
大量资金比:=大量博弈/(ABS(JGV)+ABS(DHV)+ABS(ZHV)+ABS(SHV))*100,COLORYELLOW,NODRAW;
大量资金比限制:=IF(大量资金比=0,-100,大量资金比);
大量强度比:=IF(大量资金比>0,(大量资金比限制+100)/2,IF(大量资金比<0,100-ABS((大量资金比限制-100)/2),0)),COLORGREEN,NODRAW;
小量资金比:=小量博弈/(ABS(JGV)+ABS(DHV)+ABS(ZHV)+ABS(SHV))*100,COLORYELLOW,NODRAW;
小量强度比:=IF(小量资金比>=0,(小量资金比+100)/2,100-ABS((小量资金比-100)/2)),COLORCYAN,NODRAW;

MVR:=REF(MA(V,5),1);
FVR:=REF(V,1);
PVR:=(MVR+FVR)/2;
量能比:=V/(V+PVR)*100/FROMOPEN*240;

{量能饱和度}
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
【量能饱和】:=IF(SAT>1,1,SAT)*100,COLORYELLOW,NODRAW;
{活跃度}
LC:=REF(CLOSE,1);
RSI5:=(SMA(MAX(CLOSE-LC,0),3,1))/(SMA(ABS(CLOSE-LC),3,1))*100;
WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;
活跃度:=(RSI5-WR10),COLORFFFF00,LINETHICK1,NODRAW;
活跃度比:=IF(活跃度>=0,(活跃度+100)/2,100-ABS((活跃度-100)/2));

DRAWRECTREL(80,0,240,40,RGB(0,75,200));
DRAWRECTREL(80,0,160,40,RGB(0,250,50));
DRAWRECTREL(80,0,80+CONST(力度比限制*160/100),40,RGB(200,0,50));
DRAWTEXT_FIX(1,0.00,0.00,0,STRCAT(STRCAT('买卖力度比 ',CON2STR(大单买比,2)),'%买')),COLORYELLOW;
{DRAWTEXT_FIX(1,0.33,0.00,0,STRCAT(STRCAT('',CON2STR(大单卖比,2)),'%卖')),COLORGREEN;}
DRAWRECTREL(80,50,240,90,RGB(0,100,0));
DRAWRECTREL(80,50,160,90,RGB(0,250,50));
DRAWRECTREL(80,50,80+CONST(大量强度比*160/100),90,RGB(230,130,0));
DRAWTEXT_FIX(1,0.00,0.05,0,STRCAT(STRCAT('大量强度比 ',CON2STR(大量强度比,2)),'%买')),COLORYELLOW;
DRAWRECTREL(80,100,240,140,RGB(0,75,200));
DRAWRECTREL(80,100,160,140,RGB(0,250,50));
DRAWRECTREL(80,100,80+CONST(主买*160/100),140,RGB(230,130,0));
DRAWTEXT_FIX(1,0.00,0.10,0,STRCAT(STRCAT('主动买卖比 ',CON2STR(主买,2)),' %')),COLORYELLOW;
{DRAWTEXT_FIX(1,0.33,0.10,0,STRCAT(STRCAT('',CON2STR(主卖,2)),'%卖')),COLORGREEN;}
DRAWRECTREL(80,150,240,190,RGB(0,100,0));
DRAWRECTREL(80,150,160,190,RGB(0,250,50));
DRAWRECTREL(80,150,80+CONST(机构参与度*160/100),190,RGB(200,0,50));
DRAWTEXT_FIX(1,0.00,0.15,0,STRCAT(STRCAT('机构参与度 ',CON2STR(机构参与度,2)),' %')),COLORYELLOW;

DRAWRECTREL(330,0,490,40,RGB(0,100,0));
DRAWRECTREL(330,0,410,40,RGB(0,250,50));
DRAWRECTREL(330,0,330+CONST(大单流入限制*160/100),40,RGB(200,0,50));
DRAWTEXT_FIX(1,0.25,0.00,0,STRCAT(STRCAT('大单流入比 ',CON2STR(大单流入限制,2)),' %买')),COLORYELLOW;
{DRAWTEXT_FIX(1,0.83,0.01,0,STRCAT(STRCAT('',CON2STR(大单流出限制,2)),' %卖')),COLORGREEN;}
DRAWRECTREL(330,50,490,90,RGB(0,200,250));
DRAWRECTREL(330,50,410,90,RGB(0,250,50));
DRAWRECTREL(330,50,330+CONST(大单强度比*160/100),90,RGB(230,130,0));
DRAWTEXT_FIX(1,0.25,0.05,0,STRCAT(STRCAT('大单强度比 ',CON2STR(大单强度比,2)),' %买')),COLORYELLOW;
DRAWRECTREL(330,100,490,140,RGB(0,100,0));
DRAWRECTREL(330,100,410,140,RGB(0,250,50));
DRAWRECTREL(330,100,330+CONST(总流入比*160/100),140,RGB(230,130,0));
DRAWTEXT_FIX(1,0.25,0.10,0,STRCAT(STRCAT('资金流入比 ',CON2STR(总流入比,2)),' %')),COLORYELLOW;
{DRAWTEXT_FIX(1,0.83,0.10,0,STRCAT(STRCAT('',CON2STR(总流出比,2)),' %卖')),COLORGREEN;}
DRAWRECTREL(330,150,490,190,RGB(0,200,250));
DRAWRECTREL(330,150,410,190,RGB(0,250,50));
DRAWRECTREL(330,150,330+CONST(量能比*160/100),190,RGB(200,0,50));
DRAWTEXT_FIX(1,0.25,0.15,0,STRCAT(STRCAT('资金量能比 ',CON2STR(量能比,2)),' %')),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.50,0.00,0,'白K关注,黄K买入;红K持股,青K持币;紫K观望(减仓),蓝K出局。'),COLORCYAN;

DRAWRECTREL(580,100,740,140,RGB(0,100,0));
DRAWRECTREL(580,100,660,140,RGB(0,200,50));
DRAWRECTREL(580,100,580+CONST(活跃度比*160/100),140,RGB(150,10,250));
DRAWTEXT_FIX(1,0.50,0.10,0,STRCAT(STRCAT('活跃度 ',CON2STR(活跃度比,2)),' %')),COLORYELLOW;
DRAWRECTREL(580,150,740,190,RGB(0,50,150));
DRAWRECTREL(580,150,740,190,RGB(0,200,50));
DRAWRECTREL(580,150,580+CONST(【量能饱和】*160/100),190,RGB(150,10,0));
DRAWTEXT_FIX(1,0.50,0.15,0,STRCAT(STRCAT('饱和度 ',CON2STR(【量能饱和】,2)),' %')),COLORYELLOW;
901.middle
2451901
Lv.3

专栏

发表于 2013-7-6 15:09 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
569.middle
533569
Lv.3

专栏

发表于 2013-7-6 19:15 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
669.middle
2251669
Lv.4

专栏

发表于 2013-7-6 22:16 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
404.middle
2236404
Lv.3

专栏

发表于 2013-7-7 08:36 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
198.middle
1576198
Lv.2

专栏

发表于 2013-7-7 19:00 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
593.middle
1776593
Lv.2

专栏

发表于 2013-7-27 14:48 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
3楼
4楼
5楼
6楼
7楼
131943xjzjpcd6s1hvja2p
160828rrwbe8b2ijeeae8w
站长推荐 /1

最新主题

回顶部 到页底