返回列表

编写选股公式,生成突破前高的预警指标公式

[通达信]
3743154 Lv.3

专栏

查看:2792 评论:2 复制 设置 显示全部楼层 倒序浏览 |
跳转到指定楼层
设置
请老师在突破前高时(白线)做个预警谢谢了


DG     1.00     2.00    1.20
YLX     0.00    1.00     0.00
ZCX    0.00     1.00    0.00
N        1.00     100.00      12.00

板块:= STRCAT('                            1 ',STRCAT(STRCAT(STRCAT(' ',DYBLOCK),STRCAT(' ',HYBLOCK)),STRCAT(' ',GNBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,板块),COLORMAGENTA;
板块2:=  STRCAT('                            2 ',STRCAT(STRCAT(STRCAT(' ',FGBLOCK),STRCAT('',ZDBLOCK)),STRCAT(' ',ZSBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.09,0,板块2),COLORMAGENTA;MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;

日收盘:=C#DAY;
日最高:=H#DAY;
日最低:=L#DAY;
涨停:=IF(REF(日收盘,1)*1.095-日收盘<0.01 ,1,0) AND 日收盘=日最高 ;
CE3:=REF(日收盘,1);
跌停:=IF((CE3-日收盘)*100/CE3>=(10-0.01*100/CE3),1,0) AND 日收盘=日最低;
STICKLINE(涨停,H,L,0,0),COLORFF00FF;
STICKLINE(涨停,C,O,3.5,1),COLORFF00FF;



MA5:MA(CLOSE,5),LINETHICK1,COLORWHITE;
MA10:MA(CLOSE,10),LINETHICK1,COLORYELLOW,NODRAW;
MA20:MA(CLOSE,20),LINETHICK1,COLORFF00FF,LINETHICK2;
MA60:MA(CLOSE,60),LINETHICK1,DOTLINE,COLORGREEN,NODRAW;
MA120:MA(CLOSE,120),LINETHICK1,DOTLINE,COLORGRAY;
MA240:MA(CLOSE,240),LINETHICK1,DOTLINE,COLORBLUE,NODRAW;

A1:=REF(C,N)=HHV(C,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); HD:=FILTER(C1,N);
A2:=REF(C,N)=LLV(C,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); LD:=FILTER(C2,N);

UU:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);VV:=UU>REF(UU,1);

前期高位:=REF(C,BARSLAST(HD));
前期低位:=REF(C,BARSLAST(LD));
STICKLINE(H AND YLX=1,前期高位,前期高位,5,0),COLORYELLOW;
STICKLINE(L AND ZCX=1,前期低位,前期低位,5,0),COLORGRAY;

STICKLINE(CROSS(C,REF(前期高位,1)) AND (VOL>=REF(V,1)*2 OR VOL>=REF(V,2)*2),H,L,0,0),COLOR33FFDD;
STICKLINE(CROSS(C,REF(前期高位,1)) AND (VOL>=REF(V,1)*2 OR VOL>=REF(V,2)*2),C,O,3,0),COLOR33CFDD;
STICKLINE(CROSS(C,REF(前期高位,1)) AND (VOL>=REF(V,1)*2 OR VOL>=REF(V,2)*2),C,O,2.5,0),COLOR33DFDD;
STICKLINE(CROSS(C,REF(前期高位,1)) AND (VOL>=REF(V,1)*2 OR VOL>=REF(V,2)*2),C,O,2,0),COLOR33EFDD;
STICKLINE(CROSS(C,REF(前期高位,1)) AND (VOL>=REF(V,1)*2 OR VOL>=REF(V,2)*2),C,O,1,0),COLOR33FFDD;

前高:REF(C,BARSLAST(VV)),COLORWHITE,LINETHICK2;
顶高:REF(C,BARSLAST(VV))*DG,COLORGRAY,LINETHICK2;

PTZQ:=BARSLAST(VV);
PTZF:=(HHV(H,PTZQ)-LLV(L,PTZQ))/LLV(L,PTZQ)*100;

DRAWTEXT_FIX(1,0.01,0.04,0,STRCAT(STRCAT('平台周期 ',CON2STR(PTZQ,0)),' 天')),COLORRED;
DRAWTEXT_FIX(1,0.01,0.08,0,STRCAT(STRCAT('平台振幅 ',CON2STR(PTZF,0)),' %')),COLORYELLOW;


V1:=O>REF(C,1);
V2:=VOL>REF(VOL,1);
V3:=CLOSE>OPEN;
V4:=REF(C,1)>=REF(O,1) *1.07 OR REF(C,1)>=REF(C,2) *1.07;
V5:=REF(VOL,1)>REF(VOL,2);
短线跳高:=V1 AND V2 AND V3 AND V4 AND V5;
DRAWTEXT(短线跳高,L*0.95,'短线跳高'),COLORYELLOW;
964.middle
706964 Lv.3

专栏

发表于:2020-6-4 09:09 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
主题打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!
查看全部打赏
154.middle
3743154 Lv.3

专栏

发表于:2020-6-4 09:44 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
3楼
广告
广告
站长推荐 /2

最新主题