facelist

您需要登录后才可以留言 登录 |


灿烂的夏花 2021-2-28 18:46
感谢北沙老师前几天不厌其烦的给我改主图指标,让我感到理想论坛很温馨。今天我用办公室的笔记本安装公式没有出现重叠和显示不全的现象。再次谢谢老师!
前牛蛙 2021-2-26 23:00
历史出现不好写,以最后一个交日易为准,最近5个交易日可以写。
历史出现的是为了更好地观察和验证,能写当然最好,不好写就写 以最后一个交日易为准及最近5个交易日的吧,毕竟这是最终目的。
前牛蛙 2021-2-26 15:04
北沙老师你好:
5天内,1、两根K线实体下边、2、或者最低价之间、3、或者后K线实体下边与前K线最低价之间,4、或者后K线最低价与前K线实体下边,它们差值绝对值小于等于0.05元时,在前后K线下边横线源码怎么写?虽然用图标也可表示,但图标会造成主图眼花缭乱感觉,用横线既简洁,又能标示始终两点关系。可是这根短横线源码却不知道怎么画?图例在我的话题66楼回复上传了。
前牛蛙 2021-2-25 22:59
北沙: 这个热点板块还真不知道怎么编写,不知道它的原理。
可能需要横线指标,横线指标没重来没做过。
横线指标是啥意思?
前牛蛙 2021-2-25 16:04
北沙老师元宵节快乐。请教:能不能在主图显示当日前五热点板块和涨幅最后五名板块?并且如果当前个股属于其中某板块则将该板块用不同颜色凸显出来?
前牛蛙 2021-2-24 16:10
谢谢老师
山顶晾膘 2021-2-24 16:10
北沙: DRAWTEXT_FIX(CODELIKE('002625'),0,0,0,'特定低价');
谢谢 北沙老师 新人没有物质感谢 只能是口头感谢
山顶晾膘 2021-2-24 16:00
特定的某一只股票分时显示文字 其它股票分时不显示
北沙老师 这是否能做到 谢谢
前牛蛙 2021-2-24 15:47
北沙老师你好。之前你帮我写的统计阳线公式源码,要求当白色高天数字出现后,屏蔽白色高天数起点之后的黄色数字,现在看来不屏蔽反而更有用,怎么修改源码不屏蔽白色高天数起点后至新高的黄色数字?附上你最后写的源码:

BOLL:MA(CLOSE,20);
UB:BOLL+2*STD(CLOSE,20);
LB:BOLL-2*STD(CLOSE,20);
涨停:=IF(NAMELIKE('ST') OR NAMELIKE('*ST'),C=ZTPRICE(REF(C,1),0.05),
IF(CODELIKE('688') OR (CODELIKE('300') AND DATE>=1200824),C=ZTPRICE(REF(C,1),0.2),
C=ZTPRICE(REF(C,1),0.1)));
突破UB:=CROSS(BARSLASTCOUNT(涨停)=1 AND CROSS(C>UB,0.5) OR SUM(C>UB,2)=2,0.5);
白色高天数:=BARSLAST(H<BOLL AND BARSNEXT(突破UB)=REFX(BARSLAST(H<BOLL),BARSNEXT(突破UB)));
DRAWNUMBER(C>=O AND MOD(SUM(C>=O,白色高天数+1),2)=0 AND SUM(SUM(H<HHV(H,白色高天数),3)=3,白色高天数)=0,
H*1.04,SUM(C>=O,白色高天数+1)),COLORWHITE;
DT:=BARSLAST(L>LB AND REF(L<LB,1));
DRAWNUMBER(C>=O AND MOD(SUM(C>=O,DT+1),2)=1 AND SUM(H<UB AND REF(H>UB,1),DT+1)=0,L*0.97,SUM(C>=O,DT+1)),COLORGREEN;
GT:=BARSLAST(H<UB AND REF(H>UB,1));
DRAWNUMBER(IF(SUM(H<UB AND REF(H>UB,1),DT+1)=0 OR SUM(DOWNNDAY(H,3),白色高天数)=0,0,C>=O AND MOD(SUM(C>=O,GT+1),2)=0 AND SUM(C>=O AND L<LB,GT)=0),H*1.04,SUM(C>=O,GT+1)),COLORYELLOW;
起来炒股 2021-2-20 19:27
测试失败!
参数名称含有字母,数字和汉字之外的字符,或者第一个符号为数字,不符合命名标准,请重新命名!!
起来炒股 2021-2-20 19:18
老师你 好麻烦你看看这个公式我怎么通功不过.
{公式名称: 筹码突破
参数数量: 1
参数1: 成交量显示, 最小: 0, 最大: 1, 缺省: 1
公式类型: 技术指标公式-其他类型
画线方法: 主图叠加
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:
请设置计算参数:
成交量显示: Param#0 (0.00--1.00)
用法注释:
筹码突破主图
公式源码:}
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
X_1:=COST(90);
X_2:=COST(70);
X_3:=COST(50);
X_4:=COST(30);
X_5:=COST(2);
X_6:=INTPART(COST(2)*100)/100;
X_7:=INTPART(COST(0.01)*100)/100;
筹码牛熊:EMA((X_1+X_2+X_3+X_4+X_5)/5,3),COLORYELLOW,LINETHICK3;
X_8:=COST(90)>REF(COST(90),1) AND COST(70)>REF(COST(70),1) AND COST(50)>REF(COST(50),1) AND COST(30)>REF(COST(30),1);
X_9:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>6 AND X_8 AND CLOSE>COST(90) AND LOW<COST(90) AND (LOW-筹码牛熊)/筹码牛熊*100<5;
STICKLINE(X_9,OPEN,CLOSE,2.4,0),COLORYELLOW;
DRAWICON(X_9,LOW*0.97,26);
X_10:=FILTER((CLOSE-COST(2))/COST(2)*100<3 AND CLOSE>X_6 AND X_6>=REF(X_6,1),3);
DRAWICON(X_10,LOW*0.97,38);
X_11:=BARSLAST(X_10);
X_12:=BARSLAST(X_7<REF(X_7,1) AND REF(X_7,1)>=REF(X_7,2));
DRAWICON(X_7<REF(X_7,1) AND REF(X_7,1)>=REF(X_7,2) AND REF(X_11,1)<REF(X_12,1),HIGH*1.01,39);
STICKLINE(X_10,OPEN,CLOSE,2,0),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=1 AND CLOSE>0,筹码牛熊,(CLOSE-筹码牛熊)/筹码牛熊*100),COLORWHITE;
X_13:=48;
X_14:=48;
X_15:=CONST(LLV(LOW,X_13))*0.85;
X_16:=VOL/(EMA(VOL,250)/EMA(CLOSE,250)*X_14);
X_17:=CLOSE/X_16;
X_18:=HIGH/X_16;
X_19:=LOW/X_16;
X_20:=OPEN/X_16;
X_21:=X_16/((X_18-X_19)*2-ABS(X_17-X_20));
X_22:=IF(X_17>X_20,X_21*(X_18-X_19),IF(X_17<X_20,X_21*(X_18-X_20+(X_17-X_19)),X_16/2));
X_23:=IF(X_17>X_20,0-X_21*(X_18-X_17+(X_20-X_19)),IF(X_17<X_20,0-X_21*(X_18-X_19),0-X_16/2));
STICKLINE(CLOSE>OPEN AND 成交量显示=1,X_16+X_15,X_22+X_15,0.5,0),COLOR7777FF;
STICKLINE(CLOSE>OPEN AND 成交量显示=1,X_15,X_22+X_15,0.5,0),COLOR7777FF;
STICKLINE(CLOSE<OPEN AND 成交量显示=1,X_16+X_15,X_22+X_15,0.5,0),COLOR00DD33;
STICKLINE(CLOSE<OPEN AND 成交量显示=1,X_15,X_22+X_15,0.5,0),COLOR00DD33;
起来炒股 2021-2-20 19:09
在吗老师
前牛蛙 2021-2-20 14:56
北沙老师:M为变量,取值范围在30至60周期之间,源码该怎么写?
灿烂的夏花 2021-2-20 14:39
ZTCS:=COUNT(涨停,BARSLAST(涨停+1));
ZTCS90:=COUNT(涨停,90);
DRAWNUMBER(涨停,HIGH*1.04,ZTCS90),COLORYELLOW;
GZT1:=STRCAT(' 共涨停: ',CON2STR(ZTCS,0));
GZT2:=STRCAT(GZT1,'次');
SSTS1:=STRCAT(' 上市: ',CON2STR(FINANCE(42),0));
SSTS2:=STRCAT(SSTS1,'天');
NTZZT1:=STRCAT(' 距今:',CON2STR(CONST(BARSLAST(涨停)),0));
NTZZT2:=STRCAT(NTZZT1,'天有涨停');
ZTTJ1:=STRCAT(SSTS2,GZT2);
ZTTJ2:=STRCAT(ZTTJ1,NTZZT2);
ZTTJ:=STRCAT('涨停统计:',ZTTJ2);
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,ZTTJ),COLORYELLOW;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(涨停)),REF(HIGH,BARSLAST(涨停)),0.1,0),COLORDDDD00;
STICKLINE(CLOSE,REF(LOW,BARSLAST(涨停)),REF(LOW,BARSLAST(涨停)),0.1,0),COLOR00DDDD;
ZT:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1));
STICKLINE(ZT,O,C,2,0),COLORYELLOW;
STICKLINE(ZT,L,H,0.1,0),COLORYELLOW;
不知道是不是这个?涨停都是10%的时候的源码
前牛蛙 2021-2-20 14:30
谢谢老师
前牛蛙 2021-2-19 16:01
图例1:12月3日至12月10日登海种业,1月8日至1月20日中核钛白。
前牛蛙 2021-2-19 15:53
北沙老师,留言板不懂怎么发图例。两次回踩:应该是20日内在中轨BOLL或60日均线附近出现两个低点,后低点高于前低点(以最低价算)。分别跌破中轨或60日线,和不跌破中轨或60日均线两种情况吧。
前牛蛙 2021-2-19 14:11
北沙老师你好,新年回来依始又要麻烦你帮忙按下面要求写源码:25天内最低价两次踩布林中轨,而且后次最低价高于前次最低价,并用图标标示。
福蛮多 2021-2-17 19:50
老师您好,请帮忙写一个通达信根据股东名称 条件选股公式,麻烦您了,非常感谢!
新扎韭菜 2020-12-31 16:49
考虑效率,我就把这公式发在这里,因为我刚刚证实了它有未来函数,会改变信号的颜色和性质。请你帮忙看看实际的未来函数出现在哪里,把这缺陷修复过来
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
MAC3:=MA(C,3);
SHORT:=12;LONG:=26;MID:=9;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;
DEA:EMA(DIF,MID)COLORFF9900 ;
MACD:=(DIF-DEA)*2;
STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;
{持币:STICKLINE((SAR(10,2,20)>=H),MACD,0,1.5,0),COLORGREEN;
持股:STICKLINE((SAR(10,2,20)<=L),0,MACD,1.5,0),COLORYELLOW;}
吸:=XLPL.NOTEXT吸,COLORLIRED,CIRCLEDOT,LINETHICK3;
拉:=XLPL.NOTEXT拉,COLORRED,CIRCLEDOT,LINETHICK3;
派:=XLPL.NOTEXT派,COLORGREEN,CIRCLEDOT,LINETHICK3;
落:=XLPL.NOTEXT落,COLORWHITE,CIRCLEDOT,LINETHICK3;
STICKLINE(吸,0,MACD,1,0),COLORLIRED;
STICKLINE(拉,0,MACD,1,0),COLORRED;
STICKLINE(派,0,MACD,1,0),COLORGREEN;
STICKLINE(落,0,MACD,1,0),COLORWHITE;
入1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK1;
入2:IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLOR00FF00,LINETHICK1;
12下一页
回顶部 到页底
返回顶部