请老师帮改成预警指标

[改 写] 3710 3
设置
3958834 Lv.2

专栏

发表于 2022-5-8 22:11 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
下方这个是代码。我需要顶底大于100时在盘中条件预警弹出提醒,请问老师应该怎么写,或者我这个是一个附图,叫幅图1.怎么调用幅图1写成条件预警公式
  1. VAR1:=1;

  2. VAR2:=1/WINNER(CLOSE);

  3. VAR3:=MA(CLOSE,13);

  4. VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);

  5. VAR5:=LLV(LOW,75);

  6. VAR6:=HHV(HIGH,75);

  7. VAR7:=(VAR6-VAR5)/100;

  8. VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);

  9. VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);

  10. VARA:=3*VAR8-2*SMA(VAR8,15,1);

  11. VARB:=3*VAR9-2*SMA(VAR9,15,1);

  12. VARC:=100-VARB;

  13. 顶底: (100-VARA)*VAR1,COLORRED;

  14. 无敌:= MA(WINNER(CLOSE*0.95)*100,3)*VAR1,COLORYELLOW;

  15. 峰值: (100-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0))*VAR1,COLORLIMAGENTA,LINETHICK1,POINTDOT ;

  16. VARD:=无敌>VAR4;

  17. VARE:=REF(LOW,1)*0.9;

  18. VARF:=LOW*0.9;

  19. VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;

  20. VAR11:=EMA(VAR10,30);

  21. VAR12:=CLOSE-REF(CLOSE,1);

  22. VAR13:=MAX(VAR12,0);

  23. VAR14:=ABS(VAR12);

  24. VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;

  25. VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;

  26. VAR17:=BARSCOUNT(CLOSE);

  27. VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;

  28. VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;

  29. VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

  30. VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);

  31. VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

  32. VAR1D:=SMA(VAR1C,4,1);

  33. VAR1E:=SMA(VAR1D,3,1);

  34. VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

  35. VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;


  36. STICKLINE(1,峰值,100,1,0),COLORLIMAGENTA;

  37. STICKLINE(VAR20,0,80,5,0),COLORRED,LINETHICK3 ;

  38. 100,COLORGREEN ,LINETHICK2 ;

  39. 0,COLORYELLOW ,LINETHICK2 ;

  40. 临界: 15,COLORBLUE ,LINETHICK3 ;
复制代码

本帖寻求各位老师的解答

 福哥8882022-5-8 22:29发表回复被小王子X采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

来自 四川省广安市

举报

使用道具 扔鸡蛋 回复

2466384
Lv.1

专栏

发表于 2022-5-8 22:30 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河北省唐山市

举报

使用道具 支持 扔鸡蛋 回复

2466384
Lv.1

专栏

发表于 2022-5-8 22:29 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。
来自 河北省唐山市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2466384
Lv.1

专栏

发表于 2022-5-8 22:25 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河北省唐山市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表