风靡全网的“主力操盘线”指标

[通达信] 86802 61
设置
2413907 Lv.3

专栏

发表于 2022-8-13 11:28 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
本帖最后由 会飞的牛88 于 2022-8-13 11:34 编辑

直接上原码:
SWL:(EMA(CLOSE,10)*7+EMA(CLOSE,20)*3)/10;
SWS:DMA(EMA(CLOSE,20),MAX(1,100*(SUM(VOL,5)/(3*CAPITAL)))),COLORWHITE,DOTLINE;
主力操盘线:IF(SWL>SWS,SWL,DRAWNULL),COLORRED,LINETHICK2;
生命线:IF(SWL<SWS,SWL,DRAWNULL),COLORGREEN,LINETHICK2;
STICKLINE(C>=O,L,H,0,0),COLORRED;
STICKLINE(C<O,L,H,0,0),COLORCYAN;
STICKLINE(C<O,C,O,3.5,0),COLORCYAN;
STICKLINE(C>=O,C,O,3.5,0),COLORRED;

KMJ:=MA(C,3);
VAR1:=KMJ>REF(KMJ,1) AND KMJ>REF(KMJ,2);
VAR2:=REF(VAR1,1) AND KMJ<=REF(KMJ,1) AND KMJ>=REF(KMJ,2);
VAR3:=REF(VAR2,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2);
VAR4:=REF(VAR3,1) AND KMJ<=REF(KMJ,1) AND KMJ>=REF(KMJ,2);
VAR5:=REF(VAR4,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2);
VAR6:=REF(VAR5,1) AND KMJ<=REF(KMJ,1) AND KMJ>=REF(KMJ,2);
VAR7:=REF(VAR6,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2);
VAR8:=REF(VAR7,1) AND KMJ<=REF(KMJ,1) AND KMJ>=REF(KMJ,2);
VAR9:=REF(VAR8,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2);
VARA:=REF(VAR9,1) AND KMJ<=REF(KMJ,1) AND KMJ>=REF(KMJ,2);
VARB:=REF(VARA,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2);
VARC:=REF(VARB,1) AND KMJ<=REF(KMJ,1) AND KMJ>=REF(KMJ,2);
VARD:=KMJ<REF(KMJ,1) AND KMJ<REF(KMJ,2);
VARE:=REF(VARD,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2);
VARF:=REF(VARE,1) AND KMJ<=REF(KMJ,1) AND KMJ>=REF(KMJ,2);
VAR10:=REF(VARF,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2);
VAR11:=REF(VAR10,1) AND KMJ<=REF(KMJ,1) AND KMJ>=REF(KMJ,2);
VAR12:=REF(VAR11,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2);
VAR13:=REF(VAR12,1) AND KMJ<=REF(KMJ,1) AND KMJ>=REF(KMJ,2);
VAR14:=REF(VAR13,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2);
VAR15:=REF(VAR14,1) AND KMJ<=REF(KMJ,1) AND KMJ>=REF(KMJ,2);
VAR16:=REF(VAR15,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2);
VAR17:=REF(VAR16,1) AND KMJ<=REF(KMJ,1) AND KMJ>=REF(KMJ,2);
VAR18:=REF(VAR17,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR
VAR17 OR VAR18,1) AND VAR1;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)
AND VARD;

STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA
OR VARB OR VARC,O,C,2,0),COLORRED;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA
OR VARB OR VARC,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA
OR VARB OR VARC,CLOSE,O,2,0),COLOR000088;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA
OR VARB OR VARC,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA
OR VARB OR VARC,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA
OR VARB OR VARC,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR
VAR17 OR VAR18,O,C,2.5,0),COLORLIGRAY;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR
VAR17 OR VAR18,O,C,2.8,0),COLOR555555;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR
VAR17 OR VAR18,O,C,2,0),COLOR888888;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR
VAR17 OR VAR18,O,C,1.5,0),COLORAAAAAA;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR
VAR17 OR VAR18,O,C,1,0),COLORCCCCCC;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR
VAR17 OR VAR18,O,C,0.5,0),COLOREEEEEE;
STICKLINE(VAR1A,MAX(C,O),(H+L)/2,2.8,0),COLOR550055;
STICKLINE(VAR1A,MAX(C,O),(H+L)/2,2,0),COLOR880088;
STICKLINE(VAR1A,MAX(C,O),(H+L)/2,1.5,0),COLORAA00AA;
STICKLINE(VAR1A,MAX(C,O),(H+L)/2,1,0),COLORCC00CC;
STICKLINE(VAR1A,MAX(C,O),(H+L)/2,0.5,0),COLOREE00EE;
STICKLINE(VAR19,O,(H+L)/2,2.8,0),COLOR335555;
STICKLINE(VAR19,O,(H+L)/2,2,0),COLOR338888;
STICKLINE(VAR19,O,(H+L)/2,1.5,0),COLOR33AAAA;
STICKLINE(VAR19,O,(H+L)/2,1,0),COLOR33CCCC;
STICKLINE(VAR19,O,(H+L)/2,0,0),COLOR33EEEE;
KMJMR:DRAWTEXT(VAR19,L*0.99,'←主力建仓'),COLORRED;
KMJMC:DRAWTEXT(VAR1A,H*1.01,'←主力减仓'),COLORGREEN;
----------------------------------------------------------------------

我为你省豆,你可要为我加豆呀.

附件

QQ截图20220813112456.png
  • 江南9968+2理想币 : 很给力,投资愉快,理想因你而精彩;
  • 话筒+2理想币 : 感谢知识分享,感谢经验交流。
  • 冬季123321+68理想币 : 辛苦老师 支持源码
查看全部打赏
来自 河南省信阳市

举报

使用道具 扔鸡蛋 回复

3805141
Lv.2

专栏

发表于 2022-10-1 10:56 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 天津市

举报

使用道具 支持 扔鸡蛋 回复

1390257
Lv.4

专栏

发表于 2022-9-14 09:51 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市嘉定区

举报

使用道具 支持 扔鸡蛋 回复

2281527
Lv.2

专栏

发表于 2022-9-14 08:31 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河北省石家庄市

举报

使用道具 支持 扔鸡蛋 回复

181173
Lv.3

专栏

发表于 2022-9-14 08:28 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市

举报

使用道具 支持 扔鸡蛋 回复

181173
Lv.3

专栏

发表于 2022-9-14 07:57 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市

举报

使用道具 支持 扔鸡蛋 回复

1355812
Lv.2

专栏

发表于 2022-9-13 21:46 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省连云港市

举报

使用道具 支持 扔鸡蛋 回复

3950445
Lv.2

专栏

发表于 2022-9-13 21:07 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省丽水市

举报

使用道具 点亮 支持 扔鸡蛋 回复

11520
Lv.3

专栏

发表于 2022-8-25 20:35 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西南宁市

举报

使用道具 支持 扔鸡蛋 回复

11520
Lv.3

专栏

发表于 2022-8-25 20:27 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西南宁市

举报

使用道具 支持 扔鸡蛋 回复

11520
Lv.3

专栏

发表于 2022-8-25 20:27 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西南宁市

举报

使用道具 点亮 支持 扔鸡蛋 回复

11520
Lv.3

专栏

发表于 2022-8-25 20:24 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西南宁市

举报

使用道具 支持 扔鸡蛋 回复

11520
Lv.3

专栏

发表于 2022-8-25 20:24 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西南宁市

举报

使用道具 支持 (1) 扔鸡蛋 回复

3980489
Lv.2

专栏

发表于 2022-8-25 18:27 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西百色市

举报

使用道具 支持 扔鸡蛋 回复

11520
Lv.3

专栏

发表于 2022-8-25 13:21 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西南宁市

举报

使用道具 点亮 支持 扔鸡蛋 回复

3980489
Lv.2

专栏

发表于 2022-8-25 12:10 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
点评
  • boys666 2022-8-25 13:21
    就是高仿论坛高手攻城的指标的。。成功接近100。有空看下攻城的旧贴
来自 广西百色市

举报

使用道具 支持 扔鸡蛋 回复

3980489
Lv.2

专栏

发表于 2022-8-25 12:09 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西百色市

举报

使用道具 支持 扔鸡蛋 回复

2172635
Lv.3

专栏

发表于 2022-8-24 19:40 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖南省湘潭市

举报

使用道具 点亮 支持 扔鸡蛋 回复

160188
Lv.3

专栏

发表于 2022-8-24 19:22 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省深圳市

举报

使用道具 支持 扔鸡蛋 回复

1796136
Lv.3

专栏

发表于 2022-8-21 20:05 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 甘肃省平凉市

举报

使用道具 支持 扔鸡蛋 回复

11520
Lv.3

专栏

发表于 2022-8-21 19:53 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西南宁市

举报

使用道具 支持 扔鸡蛋 回复

3995985
Lv.1

专栏

发表于 2022-8-21 16:03 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 福建省厦门市

举报

使用道具 支持 扔鸡蛋 回复

3897247
Lv.2

专栏

发表于 2022-8-21 15:20 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省烟台市

举报

使用道具 支持 扔鸡蛋 回复

2038534
Lv.2

专栏

发表于 2022-8-21 12:54 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 福建省南平市

举报

使用道具 支持 扔鸡蛋 回复

3996526
Lv.2

专栏

发表于 2022-8-20 16:25 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河北省石家庄市

举报

使用道具 支持 扔鸡蛋 回复

2011004
Lv.2

专栏

发表于 2022-8-19 16:07 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省开封市

举报

使用道具 点亮 支持 扔鸡蛋 回复

3995913
Lv.1

专栏

发表于 2022-8-19 15:37 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 天津市

举报

使用道具 支持 扔鸡蛋 回复

4000995
Lv.2

专栏

发表于 2022-8-16 17:56 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 辽宁省朝阳市

举报

使用道具 支持 扔鸡蛋 回复

3980489
Lv.2

专栏

发表于 2022-8-16 11:33 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江西省

举报

使用道具 支持 扔鸡蛋 回复

3954395
Lv.2

专栏

发表于 2022-8-16 09:01 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西河池市宜州市

举报

使用道具 支持 扔鸡蛋 回复

2162951
Lv.2

专栏

发表于 2022-8-15 22:24 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 新疆伊犁州

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼 44楼
61楼 43楼
60楼 42楼
59楼 41楼
58楼 40楼
57楼 39楼
56楼 38楼
55楼 37楼
54楼 36楼
53楼 35楼
52楼 34楼
51楼 33楼
50楼 32楼
49楼  
48楼  
47楼  
46楼  
45楼  
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表