请老师帮忙做个选股公式 这个粉色 黄色 绿色 蓝色 一起选出来 或者单独选出来

[通达信] 5235 2
设置
3742159 Lv.2

专栏

发表于 2022-12-14 16:05 复制 显示全部楼层 倒序浏览 |
跳转到指定楼层
M1:=5;
M2:=10;
VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,(-1),(-1)),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
MAVOL1:MA(VOLUME,M1);
MAVOL2:MA(VOLUME,M2);
X_1:=1*AMOUNT;
X_2:=1*MA(AMOUNT,5);
X_3:=1*MA(AMOUNT,10);
X_4:=HHV(X_1,30)=X_1;
X_5:=HHV(X_1,60)=X_1;
X_6:=HHV(X_1,100)=X_1;
X_7:=HHV(X_1,250)=X_1;
STICKLINE(X_4,VOLUME,VOLUME*0.7,1,0),COLORMAGENTA;
STICKLINE(X_5,VOLUME,VOLUME*0.7,1,0),COLORYELLOW;
STICKLINE(X_6,VOLUME,VOLUME*0.7,1,0),COLORGREEN;
STICKLINE(X_7,VOLUME,VOLUME*0.7,1,0),COLORFF7100;
X_8:=LLV(X_1,30)=X_1;
X_9:=LLV(X_1,60)=X_1;
X_10:=LLV(X_1,100)=X_1;
X_11:=LLV(X_1,250)=X_1;
STICKLINE(X_8,(-50000),0,1,0),COLORMAGENTA;
STICKLINE(X_9,(-50000),0,1,0),COLORYELLOW;
STICKLINE(X_10,(-50000),0,1,0),COLORGREEN;
STICKLINE(X_11,(-50000),0,1,0),COLORFF7100;
IF(CROSS(0.9,1/VOL*1000>0.01 AND KDJ.J<0),VOLUME*5,0),COLORYELLOW,LINETHICK2;

PT1:=CONST(LLVBARS(V,5));
STICKLINE(CURRBARSCOUNT=PT1+1,O,V,2.5,0),COLORYELLOW;

{A:FINANCE(7)*0.0003,DOTLINE,COLORWHITE;
DRAWNUMBER(ISLASTBAR,A, 3),COLORYELLOW;}
{倍量}
{STICKLINE(VOLUME>1.8*REF(VOLUME,1) AND C>REF(C,1),O,VOLUME,2,0),COLORRED;}

中间:=VOLUME*0.2;
TT1:=CONST(BARSLAST(中间));
STICKLINE(PERIOD=5 AND CURRBARSCOUNT=TT1+2,中间,中间,20,0),COLOR00FF00;
ZG:=VOLUME/1;
TT2:=CONST(BARSLAST(ZG));
STICKLINE(PERIOD=5 AND CURRBARSCOUNT=TT2+2,ZG,ZG,20,0),COLORYELLOW;

市值Z(亿):C*FINANCE(46)/100000000,NODRAW,COLORMAGENTA;
总额(亿):AMOUNT/100000000.0,NODRAW,COLORRED;
换手:SUM(VOL,1)/CAPITAL*100,COLORYELLOW,NODRAW;

Q1:=V/REF(V,1);
{DRAWNUMBER(CURRBARSCOUNT=1,V,Q1);}

竞价金额:DYNAINFO(15)/10000,NODRAW;
竞价量:DYNAINFO(15)/DYNAINFO(4)/100,NODRAW;
TT3:=CONST(BARSLAST(竞价量));
STICKLINE(PERIOD=5 AND CURRBARSCOUNT=TT3+1,竞价量,竞价量,20,0),COLORMAGENTA;
P:=CONST(BARSLAST(竞价量));
STICKLINE(CURRBARSCOUNT=P+1,O,竞价量,2.5,0),COLORMAGENTA;
OO:=DYNAINFO(15)/DYNAINFO(4)/100;
A:=OO/REF(V,1)*100;
AA:=STRCAT(STRCAT('【竞价量比】:&#160;&#160;',CON2STR(A,2)),'%');
DRAWTEXT_FIX(ISLASTBAR,0.5,0,0,AA),COLORLIRED;

本帖寻求各位老师的解答

 黑馬传奇2022-12-14 16:14发表回复被德农种业采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

附件

微信图片_20221214160426.png
来自 河北省沧州市

举报

使用道具 扔鸡蛋 回复

3787531
Lv.4

专栏

发表于 2022-12-14 16:14 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。
来自 湖北省

举报

使用道具 点亮 支持 扔鸡蛋 回复

3787531
Lv.4

专栏

发表于 2022-12-14 16:19 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
3楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表