返回列表

请高手帮我改个预警公式~~谢过

[通达信]
3992425 Lv.2

专栏

查看:3332 评论:4 复制 设置 显示全部楼层 倒序浏览 |
跳转到指定楼层
设置
当出现黄柱时出现预警提示

请高手帮我改个预警公式~~谢过


HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
HHJSJDB:(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/210,COLORYELLOW;
HHJSJDC:MA(HHJSJDB,5),COLORRED;
均线3:=MA(CLOSE,30),LINETHICK1;
均线2:=MA(CLOSE,20),LINETHICK0;
均线6:=MA(CLOSE,60);
均线12:=MA(CLOSE,120),COLORBLUE,LINETHICK1;
均线九九归一84:MA(CLOSE,84),LINETHICK0;
{买线:=MA(CLOSE,4);}
买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,32)*20+CLOSE,56),LINETHICK0;
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWTEXT (BU,LOW*0.989,'▲'),COLORYELLOW,LINETHICK3;
DRAWTEXT(SEL,HIGH*1.0175,'▼'),COLORFFFFFF,LINETHICK3;
STICKLINE(买线>=卖线,LOW,HIGH,0,0),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,0),COLOR0000AA;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,0),COLOR0000CC;
{WWW.55188.com}
STICKLINE(买线<卖线,CLOSE,OPEN,3,0),COLORAAAA00;
STICKLINE(买线<卖线,CLOSE,OPEN,2,0),COLORBBBB00;
STICKLINE(买线<卖线,LOW,HIGH,0,0),COLORFFFF00;
STICKLINE(CROSS(买线,卖线),OPEN,CLOSE,3,0),COLORYELLOW;
STICKLINE(CROSS(卖线,买线),OPEN,CLOSE,3,0),COLORMAGENTA;
A1:=C>REF(C,4);

NT:=BARSLASTCOUNT(A1);

TJ11:=NT=9;

TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);

AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;

DRAWTEXT(AY>0,H*1.02,VAR2STR(AY,0)),COLORFF00FF;

DRAWTEXT(NT=9,H*1.02,'9'),COLORGREEN;

B1:=C<REF(C,4);

NT0:=BARSLASTCOUNT(B1);

TJ21:=NT0=9 ;

TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);

AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;

DRAWTEXT(AY1>0,L*0.98,VAR2STR(AY1,0)),COLORFF00FF;

DRAWTEXT(NT0=9,L*0.98,'9'),COLORGREEN;

本帖寻求各位老师的解答

092.middle 小乌龟92023-1-19 10:44发表回复被 池中物001采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

092.middle
3952092 Lv.5 common_100_usergroup_iconcommon_108_usergroup_icon

专栏

发表于:2023-1-19 10:44 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
default
√ 该回复已被采纳,支付 10 个共享币可查看详细解答内容。
958.middle
1653958 Lv.5 common_100_usergroup_icon

专栏

发表于:2023-1-19 10:46 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
157.middle
3555157 Lv.5 common_108_usergroup_icon

专栏

发表于:2023-1-19 10:47 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
056.middle
2034056 Lv.4 common_100_usergroup_icon

专栏

发表于:2023-1-19 10:51 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
3楼
4楼
5楼
广告
广告
站长推荐 /2

最新主题