返回列表

通达信六道彩虹指标,辅助看图操作主图公式【请大家回复后下载,新人请多多关照】

4029086 Lv.1

专栏

查看:2000 评论:7 复制 设置 显示全部楼层 倒序浏览 |
跳转到指定楼层
设置
DRAWGBK(1,RGB(0,0,0),RGB(0,0,0),0,'BJ1',0);

N:=120;

K:=BARSLAST(CURRBARSCOUNT=N);

GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0)),NODRAW;{高点}

DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0)),NODRAW;{低点}

KJ:=GD-DD;{高低点差值=分区高度}

GD4:=IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL);

高区:IF(CURRBARSCOUNT<=N,GD,DRAWNULL),COLORRED,LINETHICK2,NODRAW;

低区:IF(CURRBARSCOUNT<=N,DD,DRAWNULL),COLOR00FF00,LINETHICK2,NODRAW;

平衡:=IF(CURRBARSCOUNT<=N,DD+KJ/2,DRAWNULL),COLOR00FFFF,NODRAW;

低:IF(CURRBARSCOUNT<=N/2,DD,DRAWNULL),COLORFFFF00;

高:IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL),COLOR00FFFF;

支撑:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.191,DRAWNULL),COLOR00FFFF;

强势: IF(CURRBARSCOUNT<=N/2,DD+KJ*0.382,DRAWNULL),COLORFF00FF;

突破:IF(CURRBARSCOUNT<=N/2,DD+KJ/2,DRAWNULL),COLOR0000FF;

警示:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.618,DRAWNULL),COLOR00FFFF;

压力:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.809,DRAWNULL),COLOR00FF00;

低涨:IF(CURRBARSCOUNT<=N/2,(C/LLV(LOW,K)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;

天数:BARSLAST(L=DD),COLORCYAN,NODRAW;

顶点:IF(CURRBARSCOUNT<=N/2, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,CROSSDOT,NODRAW;

低点:IF(CURRBARSCOUNT<=N/2, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,CROSSDOT,NODRAW;

STICKLINE(CCI>=200 AND H>=顶点,O,C,2,0),COLORBLUE;

STICKLINE(CCI<=100 AND L<=低点,O,C,2,0),COLORYELLOW;

DRAWBAND(高区,RGB(114,170,207),平衡,RGB(57,81,162));

DRAWBAND(平衡,RGB(114,170,207),低区,RGB(57,81,162));

DRAWBAND(高,RGB(168,3,38),压力,RGB(0,0,0));

DRAWBAND(压力,RGB(236,93,59),警示,RGB(0,0,0));

DRAWBAND(警示,RGB(253,185,107),突破,RGB(0,0,0));

DRAWBAND(突破,RGB(254,251,186),强势,RGB(0,0,0));

DRAWBAND(强势,RGB(202,232,242),支撑,RGB(0,0,0));

DRAWBAND(支撑,RGB(57,81,162),低,RGB(0,0,0));

STICKLINE(CURRBARSCOUNT=N/2,GD,DD,0,0),COLOR408080,NODRAW;

STICKLINE(CURRBARSCOUNT<=N/2,支撑,支撑,2,0),COLOR1E1E1E;

STICKLINE(CURRBARSCOUNT<=N/2,强势,强势,2,0),COLOR1E1E1E;

STICKLINE(CURRBARSCOUNT<=N/2,突破,突破,2,0),COLOR1E1E1E;

STICKLINE(CURRBARSCOUNT<=N/2,警示,警示,2,0),COLOR1E1E1E;

STICKLINE(CURRBARSCOUNT<=N/2,压力,压力,2,0),COLOR1E1E1E;

DRAWTEXT(CURRBARSCOUNT=10,压力,'压力-0.809'),COLOR00FFFF,NODRAW;

DRAWTEXT(CURRBARSCOUNT=10,警示,'警示-0.618'),COLOR00FFFF,NODRAW;

DRAWTEXT(CURRBARSCOUNT=10,突破,'突破-0.500'),COLOR00FFFF,NODRAW;

DRAWTEXT(CURRBARSCOUNT=10,强势,'强势-0.382'),COLOR00FFFF,NODRAW;

DRAWTEXT(CURRBARSCOUNT=10,支撑,'支撑-0.191'),COLOR00FFFF,NODRAW;

DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.09,'【风险区】--高抛避险'),COLORFFFFFF;

DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.3,'【警示区】--逢高减仓'),COLOR000000;

DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.45,'【突破区】--主力拉升'),COLOR000000;

DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.55,'【拉升区】--强势畜锐'),COLOR000000;

DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/3,'【关注区】--逢低买入'),COLOR000000;

DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/10,'【低吸区】--大胆买入'),COLORFFFFFF;

第一防线:REFDATE(低,DATE),DOTLINE,COLORYELLOW,NODRAW;

第二防线:REFDATE(支撑,DATE),DOTLINE,COLORWHITE,NODRAW;

{今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLORCC3299;}

DRAWKLINE(H,O,L,C);

AHC1:=CLOSE*VOL;

AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);

上轨:=1.06*AHC22,COLOR40FF00,LINETHICK1;

下轨:=AHC22*0.94;

{STICKLINE(上轨>下轨,上轨,下轨,5,0),COLOR555555;}

ZT:=REF(C,1)*1.1-C<0.01 AND H=C;

启爆:=CROSS(C,上轨) OR CROSS(C,下轨) AND ZT;

DRAWTEXT(启爆,L,'启爆'),COLORCYAN;

STICKLINE(启爆,C,O,3,1),COLORWHITE;

STICKLINE(启爆,C,O,1,0),COLORGREEN;

STICKLINE(C>=O ,HIGH,LOW,0,1 ),COLORRED;

STICKLINE(C>=O ,OPEN,CLOSE,3.1,0 ),COLOR000033;

STICKLINE(C>=O,OPEN,CLOSE,2.7,0 ),COLOR000066;

STICKLINE(C>=O ,OPEN,CLOSE,2.1,0 ),COLOR000099;

STICKLINE(C>=O ,OPEN,CLOSE,1.5,0 ),COLOR0000CC;

STICKLINE(C>=O ,OPEN,CLOSE,0.9,0 ),COLOR0000FF;

STICKLINE(C>=O ,OPEN,CLOSE,0.3,0 ),COLORCC66FF;

STICKLINE(C<O ,HIGH,LOW,0,1 ),COLORCYAN;

STICKLINE(C<O ,OPEN,CLOSE,3.1,0 ),COLOR990000;

STICKLINE(CLOSE<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;

STICKLINE(CLOSE<O ,OPEN,CLOSE,2.1,0 ),COLORFF4400;

STICKLINE(CLOSE<O ,OPEN,CLOSE,1.5,0 ),COLORFF8800;

STICKLINE(CLOSE<O ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;

STICKLINE(CLOSE<O ,OPEN,CLOSE,0.3,0 ),COLORCYAN;

CC:IF(CURRBARSCOUNT<18,CONST(REF(C,1)),DRAWNULL),COLOR000000,NODRAW;

止赢:1.05*CC,COLORMAGENTA,LINETHICK1;

DRAWTEXT(ISLASTBAR,止赢,'止赢'),LINETHICK1;

止损:0.97*CC,COLORYELLOW,LINETHICK1;

DRAWTEXT(ISLASTBAR,止损,'止损'),LINETHICK1;

DRAWNUMBER(ISLASTBAR ,C,C),COLORWHITE;

AAA:=CONST(HHV(H,50));PL5:=HHV(H,45);

F:=100*(C-REF(C,1))/REF(C,1);

博尔:=IF(C<REF(O,1) AND F<0,1,0);

P1:=博尔;

量化:=IF(C<REF(O,2) AND F<0,1,0);

P2:=量化;

STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,3,0),COLOR0055FF;

操作30日均线:EMA(C,30),COLORYELLOW,LINETHICK4;

红升:IF(操作30日均线>REF(操作30日均线,1),操作30日均线,DRAWNULL),COLORRED,LINETHICK4;

绿降:IF(操作30日均线<REF(操作30日均线,1),操作30日均线,DRAWNULL),COLOR009300,LINETHICK4;

趋势55日线:EMA(C,55),COLORYELLOW,LINETHICK1,NODRAW;

红升4:IF(趋势55日线>REF(趋势55日线,1),趋势55日线,DRAWNULL),COLOR0080FF,LINETHICK1;

绿降4:IF(趋势55日线<REF(趋势55日线,1),趋势55日线,DRAWNULL),COLORFFFF00,DOTLINE,LINETHICK1;

年线:EMA(C,250),COLORYELLOW,LINETHICK1,NODRAW;

年红升:IF(年线>REF(年线,1),年线,DRAWNULL),COLOR8000FF,LINETHICK1;

年绿降:IF(年线<REF(年线,1),年线,DRAWNULL),COLORFFFF00,DOTLINE,LINETHICK1;
550.middle
1550
Lv.8
common_100_usergroup_icon

专栏

发表于:2023-3-28 22:44 复制 查看全部楼层
感谢你分享通达信六道彩虹指标的公式,让论坛中的股友们可以更好地使用和交流该指标。同时也提醒
086.middle
4029086
Lv.1

专栏

发表于:2023-3-28 22:49 复制 查看全部楼层
想给大家上传一下图标,看的更为直观,但是图片链接不回弄,弄了半天没弄好,新人初来乍到,很多还不会,多多关照!
115.middle
4029115
Lv.2

专栏

发表于:2023-3-28 23:33 复制 查看全部楼层
看着有点复杂。
118.middle
4029118
Lv.1

专栏

发表于:2023-3-29 00:33 复制 查看全部楼层
发贴乳突巨额ueu
118.middle
4029118
Lv.1

专栏

发表于:2023-3-29 00:39 复制 查看全部楼层
;了就是这些人都参与讨伐古
118.middle
4029118
Lv.1

专栏

发表于:2023-3-29 00:39 复制 查看全部楼层
想让他第一天发育会哦
128.middle
4026128
Lv.2

专栏

发表于:2023-3-29 11:02 复制 查看全部楼层
能解释一下吗?怎么用的
您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
3楼
4楼
5楼
6楼
7楼
8楼
广告
广告
站长推荐 /1

最新主题