返回列表

求大神将通达信指标修改成同花顺指标

[同花顺]
3653210 Lv.2

专栏

查看:4882 评论:3 复制 设置 显示全部楼层 倒序浏览 |
跳转到指定楼层
设置
求大神将通达信幅图指标公式修改成同花顺幅图指标公式,谢谢!
附上源码:
换手率%:100*VOL/(FINANCE(7)/100)COLORYELLOW,NODRAW;
低迷:IF(换手率%<=1,换手率%,DRAWNULL),COLORFF9900,NODRAW;
温和放量:IF(换手率%>1 && 换手率%<=3,换手率%,DRAWNULL),COLORBBBBBB,NODRAW;
异动:IF(换手率%>3 && 换手率% <=5,换手率%,DRAWNULL),NODRAW;
活跃:IF(换手率%>5 && 换手率%<=8,换手率%,DRAWNULL)COLORMAGENTA,NODRAW;
非常活跃:IF(换手率%>8 && 换手率%<=10,换手率%,DRAWNULL)COLORYELLOW,NODRAW;
高度活跃:IF(换手率%>10 && 换手率%<=15,换手率%,DRAWNULL)COLOR0077FF,NODRAW;
极度活跃:IF(换手率%>15 && 换手率%<=25,换手率%,DRAWNULL)COLORRED,NODRAW;
巨量换手:IF(换手率%>25,换手率%,DRAWNULL)COLOR000099,NODRAW;
STICKLINE(低迷,换手率%,0,2.8,0),COLORFF0000;{低迷蓝色}
STICKLINE(低迷,换手率%,0,2.3,0),COLORFF3300;
STICKLINE(低迷,换手率%,0,1.7,0),COLORFF5500;
STICKLINE(低迷,换手率%,0,1.0,0),COLORFF7700;
STICKLINE(低迷,换手率%,0,0.3,0),COLORFF9900;
STICKLINE(温和放量,换手率%,0,2.8,0),COLOR555555;{温和灰色}
STICKLINE(温和放量,换手率%,0,2.3,0),COLOR777777;
STICKLINE(温和放量,换手率%,0,1.7,0),COLOR999999;
STICKLINE(温和放量,换手率%,0,1.0,0),COLORBBBBBB;
STICKLINE(温和放量,换手率%,0,0.3,0),COLORFF00FF NODRAW;
STICKLINE(异动,换手率%,0,2.8,0),COLOR004400;{异动绿色}
STICKLINE(异动,换手率%,0,2.3,0),COLOR006600;
STICKLINE(异动,换手率%,0,1.7,0),COLOR009900;
STICKLINE(异动,换手率%,0,1.0,0),COLOR00CC00;
STICKLINE(异动,换手率%,0,0.3,0),COLOR00FF00;
STICKLINE(活跃,换手率%,0,2.8,0),COLOR880088;{活跃粉色}
STICKLINE(活跃,换手率%,0,2.3,0),COLORAA00AA;
STICKLINE(活跃,换手率%,0,1.7,0),COLORCC00CC;
STICKLINE(活跃,换手率%,0,1.0,0),COLOREE00EE;
STICKLINE(活跃,换手率%,0,0.3,0),COLORFF33FF;
STICKLINE(非常活跃,换手率%,0,2.8,0),COLOR008888;{非常活跃黄色}
STICKLINE(非常活跃,换手率%,0,2.3,0),COLOR00AAAA;
STICKLINE(非常活跃,换手率%,0,1.7,0),COLOR00CCCC;
STICKLINE(非常活跃,换手率%,0,1.0,0),COLOR00EEEE;
STICKLINE(非常活跃,换手率%,0,0.3,0),COLOR44FFFF;
STICKLINE(高度活跃,换手率%,0,2.8,0),COLOR0000AA;{高度活跃橘红}
STICKLINE(高度活跃,换手率%,0,2.3,0),COLOR0022CC;
STICKLINE(高度活跃,换手率%,0,1.7,0),COLOR0044DD;
STICKLINE(高度活跃,换手率%,0,1.0,0),COLOR0055FF;
STICKLINE(高度活跃,换手率%,0,0.3,0),COLOR0099FF;
STICKLINE(极度活跃,换手率%,0,2.8,0),COLOR000066;{极度活跃红色}
STICKLINE(极度活跃,换手率%,0,2.3,0),COLOR000088;
STICKLINE(极度活跃,换手率%,0,1.7,0),COLOR0000AA;
STICKLINE(极度活跃,换手率%,0,1.0,0),COLOR0000CC;
STICKLINE(极度活跃,换手率%,0,0.3,0),COLOR2222FF;
STICKLINE(巨量换手,换手率%,0,2.8,0),COLOR000022;{巨量换手酱红色}
STICKLINE(巨量换手,换手率%,0,2.3,0),COLOR000033;
STICKLINE(巨量换手,换手率%,0,1.7,0),COLOR000055;
STICKLINE(巨量换手,换手率%,0,1.0,0),COLOR000077;
STICKLINE(巨量换手,换手率%,0,0.3,0),COLOR000099;
X_1B:=REF(CLOSE,1)*1.1-CLOSE<0.01 AND HIGH=CLOSE NODRAW;
前高量:REF(HHV(换手率%,60),REF(X_1B,1)),COLORGREEN NODRAW;
成交量:VOL,VOLSTICK,NODRAW;
N:=90 NODRAW;
后量超前量:V>=HHV(V,N)NODRAW;
DRAWICON(后量超前量,前高量,13);
V5:=MA(V,5),COLORWHITE,NODRAW;
V35:=MA(V,35),COLORGREEN,NODRAW;
V135:=MA(V,135),COLORFF00FF;
XG:=CROSS(V5,V35) AND V>V5 AND V>V135*2 NODRAW;
牛股启动:FILTER(XG,20),LINETHICK3,COLORRED,NODRAW;
DRAWTEXT(牛股启动,前高量,' 牛股启动'), COLORYELLOW;
DRAWICON(牛股启动,前高量,34);
量比B:VOL/REF(MA(VOL,5),1),COLORFFFFFF,NODRAW;
预测量:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,VOL),VOLSTICK NODRAW;
MAVOL1:=MA(预测量,5)NODRAW;
MAVOL2:=MA(预测量,60)NODRAW;
均量金叉:CROSS(MAVOL1,MAVOL2) NODRAW;
DRAWICON(均量金叉,5,11);

A:=34;B:=3;
RRR1:=EMA(100*(CLOSE-LLV(LOW,A))/(HHV(HIGH,A)-LLV(LOW,A)),B)/4,COLORFFFF00,LINETHICK2 NODRAW;
分界线:RRR1,,COLORFFFF00,LINETHICK2 NODRAW;
DRAWICON(CROSS(分界线,2),换手率%,23);

RRR2:IF(RRR1>23.16,RRR1,0),COLOR00FFFF,LINETHICK1 NODRAW;
QQQQ:IF(RRR1<2,6,0),COLOR00FFFF,LINETHICK4 NODRAW;
WWWW:IF(RRR1>21.5,25.5,28),COLOR0000FF,LINETHICK4 NODRAW;
EEEE:IF(RRR1>23.16,24.5,28),COLORRED,LINETHICK4 NODRAW;

STICKLINE((CROSS(23.16,分界线)),0,换手率%,3,0), COLORGREEN;
STICKLINE((CROSS(23.16,分界线)),0,换手率%,1,0), COLORBLUE;

DRAWTEXT((CROSS(23.16,分界线)),VOL*1.1+10000,'.清仓'),COLORGREEN NODRAW;



XG1:DRAWTEXT_FIX(1,0.69,0.267,0,'*******************************************************************'),COLORGREEN;

本帖寻求各位老师的解答

912.middle 注册1112023-8-9 09:08发表回复被 缘梦小马哥采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

附件

08638981-BA7C-4793-BE79-A41E1E317F4E.jpeg
本主题由 任务系统 于 2023-8-8 12:16 审核通过
912.middle
277912
Lv.6
common_100_usergroup_icon

专栏

发表于:2023-8-9 09:08 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
default
√ 该回复已被采纳,支付 10 个共享币可查看详细解答内容。
点评
  • 缘梦小马哥 2023-8-9 21:24
    这是我朋友发给我的同花顺换手率指标,我安装后不显示图形,请你帮我看看哪里出了问题?非常感谢! 换手:VOL/CAPITAL*100,NODRAW; 低迷换手小于1:换手<=1,COLORFFFF00,NODRAW; 温和换手1到3:换手>1 AND 换手<
    210.middle
210.middle
3653210
Lv.2

专栏

发表于:2023-8-9 13:43 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
点评
  • 注册111 2023-8-9 16:54
    就加在最后一项,线条是看不到的,在标题栏上会显示数值。
    912.middle
912.middle
277912
Lv.6
common_100_usergroup_icon

专栏

发表于:2023-8-9 16:54 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
3楼
4楼
广告
广告
站长推荐 /1

最新主题