手机版 理想小程序
理想小程序
RSS 论坛APP
返回列表

请求老师修改4个MACD同时显示

[通达信] 3379 2
设置
3985693 Lv.2

专栏

复制 显示全部楼层 倒序浏览 |
跳转到指定楼层

涨停,技术指标源码,股票公式源码,免费股票软件,股票论坛指标编写_技术互助答疑论坛股票软件指标公式技术理想股票技术论坛

原来的图是5分K线,副图同显示了4个级别的MACD,我复制了源码后,发现无法同时显示,只对应每个级别的K线才能显示,比如我用15分K线图才显示15分的MACD,其它的MACD无法同 ...指标编写_技术互助答疑论坛股票软件指标公式技术

原来的图是5分K线,副图同显示了4个级别的MACD,我复制了源码后,发现无法同时显示,只对应每个级别的K线才能显示,比如我用15分K线图才显示15分的MACD,其它的MACD无法同时显示。请求好心的老师帮忙修改一下。
原图
请求老师修改4个MACD同时显示

我目前的通达信
请求老师修改4个MACD同时显示

附上原来的源码
附图
{MACD 5分}
分DIFF:="MACD.DIF#MIN5"(10,22,7.5);
分DEAF:="MACD.DEA#MIN5"(10,22,7.5);
MACD分:2*(分DIFF-分DEAF),NODRAW;
DRAWBAND(分DIFF,RGB(255,157,255),分DEAF,RGB(21,138,255));
STICKLINE(MACD分>0,0,MACD分,0.01,0) ,COLOR0000FF;
STICKLINE(MACD分<0,0,MACD分,0.01,0) ,COLORFFF000;
GMB:IF(CROSS(分DIFF,分DEAF) AND 分DIFF>0,-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLOR0000FF;
GMC:IF(CROSS(分DIFF,分DEAF) AND 分DIFF<0,-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLOR208FFF;
0,COLORFFFF00,LINETHICK1;
---------------------------------------------------------------------------------------------------
{MACD 15分}
分DIFF:="MACD.DIF#MIN15"(10,22,7.5);
分DEAF:="MACD.DEA#MIN15"(10,22,7.5);
MACD分:2*(分DIFF-分DEAF),NODRAW;
DRAWBAND(分DIFF,RGB(255,157,255),分DEAF,RGB(21,138,255));
STICKLINE(MACD分>0,0,MACD分,0.01,0) ,COLOR0000FF;
STICKLINE(MACD分<0,0,MACD分,0.01,0) ,COLORFFF000;
GMB:IF(CROSS(分DIFF,分DEAF) AND 分DIFF>0,-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLOR0000FF;
GMC:IF(CROSS(分DIFF,分DEAF) AND 分DIFF<0,-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLOR208FFF;
0,COLORFFFF00,LINETHICK1;
--------------------------------------------------------------------------------------------------------------
{MACD 30分}
分DIFF:="MACD.DIF#MIN30"(10,22,7.5);
分DEAF:="MACD.DEA#MIN30"(10,22,7.5);
MACD分:2*(分DIFF-分DEAF),NODRAW;
DRAWBAND(分DIFF,RGB(255,157,255),分DEAF,RGB(21,138,255));
STICKLINE(MACD分>0,0,MACD分,0.01,0) ,COLOR0000FF;
STICKLINE(MACD分<0,0,MACD分,0.01,0) ,COLORFFF000;
GMB:IF(CROSS(分DIFF,分DEAF) AND 分DIFF>0,-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLOR0000FF;
GMC:IF(CROSS(分DIFF,分DEAF) AND 分DIFF<0,-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLOR208FFF;
0,COLORFFFF00,LINETHICK1;
------------------------------------------------------------------------------------------------------
{MACD 60分}
分DIFF:="MACD.DIF#MIN60"(10,22,7.5);
分DEAF:="MACD.DEA#MIN60"(10,22,7.5);
MACD分:2*(分DIFF-分DEAF),NODRAW;
DRAWBAND(分DIFF,RGB(255,157,255),分DEAF,RGB(21,138,255));
STICKLINE(MACD分>0,0,MACD分,0.01,0) ,COLOR0000FF;
STICKLINE(MACD分<0,0,MACD分,0.01,0) ,COLORFFF000;
GMB:IF(CROSS(分DIFF,分DEAF) AND 分DIFF>0,-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLOR0000FF;
GMC:IF(CROSS(分DIFF,分DEAF) AND 分DIFF<0,-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLOR208FFF;
0,COLORFFFF00,LINETHICK1;

本帖寻求各位老师的解答

回复被采纳后将获得奖励 共享币 5 个 ,目前已有 2 个回复 我来解答
959.middle
3877959
Lv.6
common_100_usergroup_icon

专栏

发表于 2023-12-7 21:59 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
912.middle
277912
Lv.6
common_100_usergroup_icon

专栏

发表于 2023-12-8 07:47 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。

附件

捕获.PNG
您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
3楼
131943xjzjpcd6s1hvja2p
160828rrwbe8b2ijeeae8w
站长推荐 /1

最新主题

回顶部 到页底