天风地火---(飞狐、大智慧通用源码)

[飞 狐] 5490 9
设置
679267 Lv.2

专栏

发表于 2007-6-26 02:11 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
天风地火---(飞狐、大智慧通用源码)


{天风地火 n:1 100 3 m:1 100 30}
Var0:=(3*CLOSE+LOW+OPEN+HIGH)/6;
多头线: (20*Var0+19*REF(Var0,1)+18*REF(Var0,2)+17*REF(Var0,3)+16*REF(Var0,4)+15*REF(Var0,5)+14*REF(Var0,6)+13*REF(Var0,7)+12*REF(Var0,8)+11*REF(Var0,9)+10*REF(Var0,10)+9*REF(Var0,11)+8*REF(Var0,12)+7*REF(Var0,13)+6*REF(Var0,14)+5*REF(Var0,15)+4*REF(Var0,16)+3*REF(Var0,17)+2*REF(Var0,18)+REF(Var0,20))/210, CIRCLEDOT,COLORRED,linethick2;
空头线: MA(多头线,10), CIRCLEDOT,COLORGREEN,linethick2;
STICKLINE(多头线>空头线,多头线,空头线,10,10),,COLORRED;
STICKLINE(多头线<空头线,多头线,空头线,10,10), ,COLORGREEN;
STICKLINE(C>O,O,C,7,0),COLORRED;
STICKLINE(C>O,O,C,4,0),COLORB0B0FF;
STICKLINE(C>O,O,C,2,0),COLORYELLOW;
STICKLINE(C>O,L,H,0.1,0),COLORYELLOW;
STICKLINE(C< O,O,C,7,0),COLORFF2020;
STICKLINE(C< O,O,C,4,0),COLORFF6600;
STICKLINE(C< O,O,C,2,0),COLORffcc66;
STICKLINE(C< O,L,H,0.1,0),COLORffcc66;
STICKLINE(C=O AND C>=REF(C,1),O,C,7,0),COLORRED;
STICKLINE(C=O AND C>=REF(C,1),O,C,4,0),COLORB0B0FF;
STICKLINE(C=O AND C>=REF(C,1),O,C,2,0),COLORYELLOW;
STICKLINE(C=O AND C>=REF(C,1),L,H,0.1,0),COLORYELLOW;
STICKLINE(C=O AND C< REF(C,1),O,C,7,0),COLORFF2020;
STICKLINE(C=O AND C< REF(C,1),O,C,4,0),COLORFF6600;
STICKLINE(C=O AND C< REF(C,1),O,C,2,0),COLORffcc66;
STICKLINE(C=O AND C< REF(C,1),L,H,0.1,0),COLORffcc66;
var1:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
A1:=CLOSE/MA(CLOSE,40);
A2:=(CLOSE-OPEN)/OPEN*100>4;
A3:=LOW*1.051<HIGH;
A4:=A3 AND COUNT(A3,5)>1;
B1:=INDEXC;
B2:=MA(B1,5);
B3:=MA(B1,20);
B4:=B1*1.03<B2 AND B1*1.13<B3;
买入1:=(var1<6 AND A1<0.85 AND A2)*90;
买入2:=(var1<6 AND A1<0.76 AND A4)*70;
买入3:=(var1<6 AND B4)*60;
DRAWICON(var1<6 AND A1<0.85 AND A2,l*0.9,1);
DRAWTEXT(var1<6 AND A1<0.85 AND A2,l*0.85,'--->买入1'),colorred;
DRAWICON(var1<6 AND A1<0.76 AND A4,l*0.9,1);
DRAWTEXT(var1<6 AND A1<0.76 AND A4,l*0.85,'--->买入2'),colorred;
DRAWICON(var1<6 AND B4,l*0.9,1);
DRAWTEXT(var1<6 AND B4,l*0.85,'--->买入3'),colorred;
Var2:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
Var3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(Var2+Var3)/AMOUNT*VOL*100*50;
DRAWICON(MV>5,l*0.95,1);
DRAWTEXT(MV>5,l*0.95,'--->异动'),coloryellow;
Var4:=EMA((EMA(CLOSE,95)-EMA(CLOSE,120)),35);
Var5:=((EMA(CLOSE,95)-EMA(CLOSE,120))-Var4)*2;
DRAWICON(Var5>0.3,h*1.05,2);
DRAWTEXT(Var5>0.3,h*1.05,'--->顶'),colorred;
来自 新疆乌鲁木齐市

举报

使用道具 扔鸡蛋 回复

1244957
Lv.4

专栏

发表于 2008-1-24 16:01 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西桂林市

举报

使用道具 点亮 支持 扔鸡蛋 回复

969982
Lv.2

专栏

发表于 2007-7-16 23:07 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市

举报

使用道具 支持 扔鸡蛋 回复

695668
Lv.1

专栏

发表于 2007-7-8 15:21 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市奉贤区

举报

使用道具 支持 扔鸡蛋 回复

976805
Lv.2

专栏

发表于 2007-7-8 15:13 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省佛山市

举报

使用道具 支持 扔鸡蛋 回复

974644
Lv.4

专栏

发表于 2007-7-8 13:28 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 吉林省吉林市

举报

使用道具 支持 扔鸡蛋 回复

916647
Lv.4

专栏

发表于 2007-6-26 09:20 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 甘肃省兰州市

举报

使用道具 支持 扔鸡蛋 回复

910900
Lv.4

专栏

发表于 2007-6-26 09:18 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省聊城市东阿县

举报

使用道具 点亮 支持 扔鸡蛋 回复

390075
Lv.4

专栏

发表于 2007-6-26 09:03 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市浦东新区

举报

使用道具 支持 扔鸡蛋 回复

205399
Lv.3

专栏

发表于 2007-6-26 08:21 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省洛阳市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
9楼
8楼
7楼
6楼
5楼
4楼
3楼
2楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表