哪位朋友可以把这个公式修改一下错误

3230 5
设置
89565 Lv.3

专栏

发表于 2007-7-1 22:52 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
下面的这些代码在大智慧新建公式的时候显示"未定义变量FINANCE"和语法错误“(”
请帮忙 谢谢!


年认同价:=MA(C,240);
价格中枢:=(SUM(年认同价,0)/BARPOS);
G:价格中枢*1.2,LINETHICK4,color009900;
G2:价格中枢*1.618,POINTDOT,Colorwhite;
G3:价格中枢*1.382,POINTDOT,Colorwhite;
G1:价格中枢*0.8,LINETHICK4,color009900;
FILLRGN(G1,G,G1>0),color5f5f5f;
价格中枢,LINETHICK1,COLORFFBB00;
aa1:年认同价+年认同价/FINANCE2(4),colorwhite;
下:aa1*1.3,coloryellow;
中:aa1*1.618,colorred;
顶:aa1*1.9,colorgreen;
a:=(3*c+l+o+h)/6;
X:=(20*a+19*ref(a,1)+18*ref(a,2)+17*ref(a,3)+16*ref(a,4)+15*ref(a,5)+
14*ref(a,6)+13*ref(a,7)+12*ref(a,8)+11*ref(a,9)+10*ref(a,10)+9*ref(a,11)+8*ref(a,12)
+7*ref(a,13)+6*ref(a,14)+5*ref(a,15)+4*ref(a,16)+3*ref(a,17)+2*ref(a,18)+
ref(a,20))/210;
回调认同:eMA(X,13),colorFF00FF;
PARTLINE(回调认同,回调认同<ref(回调认同,1)),COLORGREEN,LINETHICK1;
STICKLINE(close>=open,open,close,8,1),colorred;
STICKLINE(open>close,close,open,8,0 ),colorgreen;
STICKLINE(close>=open,close,HIGH,0.5 ,0 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,0),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),colorgreen;
DRAWTEXTREL(10,105,'代码:'+STKLABEL+'   名称:'+STKNAME),LINETHICK3,Color0000ff;
DRAWTEXTREL(10,180,'总股本:'+NUMTOSTRN(FINANCE(1),0)+'万' +' 流通A股:'+NUMTOSTRN(FINANCE(7),0)+'万'),COLORffffff;
DRAWTEXTREL(10,240,'市盈率:'+NUMTOSTRN(DYNAINFO(39),2)+'%'+' 每股收益:'+NUMTOSTRN(FINANCE(33),3)+'元'+' 每股公积金:'+NUMTOSTRN(FINANCE(18),3)+'元'),colorffffff;
DRAWTEXTREL(10,300,'机构评级:'+Extrastring('评级')),colorffffff;
var100:='所属板块:';
if inblock('A股板块')=1 then var100:=var100+'A股板块,';
if inblock('B股板块')=1 then var100:=var100+'B股板块,';
if inblock('H股')=1 then var100:=var100+'H股,';
if inblock('ST')=1 then var100:=var100+'ST,';
if inblock('安徽')=1 then var100:=var100+'安徽,';
if inblock('奥运')=1 then var100:=var100+'奥运,';
if inblock('北京')=1 then var100:=var100+'北京,';
if inblock('创投')=1 then var100:=var100+'创投,';
if inblock('次新股')=1 then var100:=var100+'次新股,';
if inblock('大盘')=1 then var100:=var100+'大盘,';
if inblock('大智慧88')=1 then var100:=var100+'大智慧88,';
if inblock('低价')=1 then var100:=var100+'低价,';
if inblock('电力')=1 then var100:=var100+'电力,';
if inblock('电脑')=1 then var100:=var100+'电脑,';
if inblock('电器')=1 then var100:=var100+'电器,';
if inblock('电子信息')=1 then var100:=var100+'电子信息,';
if inblock('房地产')=1 then var100:=var100+'房地产,';
if inblock('纺织服装')=1 then var100:=var100+'纺织服装,';
if inblock('福建')=1 then var100:=var100+'福建,';
if inblock('甘肃')=1 then var100:=var100+'甘肃,';
if inblock('钢铁')=1 then var100:=var100+'钢铁,';
if inblock('高价')=1 then var100:=var100+'高价,';
if inblock('高派现')=1 then var100:=var100+'高派现,';
if inblock('工程建筑')=1 then var100:=var100+'工程建筑,';
if inblock('供水供气')=1 then var100:=var100+'供水供气,';
if inblock('广东')=1 then var100:=var100+'广东,';
if inblock('广西')=1 then var100:=var100+'广西,';
if inblock('贵州')=1 then var100:=var100+'贵州,';
if inblock('海南')=1 then var100:=var100+'海南,';
if inblock('河北')=1 then var100:=var100+'河北,';
if inblock('河南')=1 then var100:=var100+'河南,';
if inblock('黑龙江')=1 then var100:=var100+'黑龙江,';
if inblock('湖北')=1 then var100:=var100+'湖北,';
if inblock('湖南')=1 then var100:=var100+'湖南,';
if inblock('化工')=1 then var100:=var100+'化工,';
if inblock('化纤')=1 then var100:=var100+'化纤,';
if inblock('基金')=1 then var100:=var100+'基金,';
if inblock('基金重仓')=1 then var100:=var100+'基金重仓,';
if inblock('机械')=1 then var100:=var100+'机械,';
if inblock('吉林')=1 then var100:=var100+'吉林,';
if inblock('建材')=1 then var100:=var100+'建材,';
if inblock('江苏')=1 then var100:=var100+'江苏,';
if inblock('江西')=1 then var100:=var100+'江西,';
if inblock('交通工具')=1 then var100:=var100+'交通工具,';
if inblock('交通设施')=1 then var100:=var100+'交通设施,';
if inblock('教育传媒')=1 then var100:=var100+'教育传媒,';
if inblock('金融')=1 then var100:=var100+'金融,';
if inblock('可转债')=1 then var100:=var100+'可转债,';
if inblock('辽宁')=1 then var100:=var100+'辽宁,';
if inblock('旅游酒店')=1 then var100:=var100+'旅游酒店,';
if inblock('煤炭石油')=1 then var100:=var100+'煤炭石油,';
if inblock('内蒙古')=1 then var100:=var100+'内蒙古,';
if inblock('酿酒食品')=1 then var100:=var100+'酿酒食品,';
if inblock('宁夏')=1 then var100:=var100+'宁夏,';
if inblock('农林牧渔')=1 then var100:=var100+'农林牧渔,';
if inblock('农业龙头')=1 then var100:=var100+'农业龙头,';
if inblock('其他行业')=1 then var100:=var100+'其他行业,';
if inblock('汽车')=1 then var100:=var100+'汽车,';
if inblock('汽配')=1 then var100:=var100+'汽配,';
if inblock('青海')=1 then var100:=var100+'青海,';
if inblock('券商重仓')=1 then var100:=var100+'券商重仓,';
if inblock('山东')=1 then var100:=var100+'山东,';
if inblock('山西')=1 then var100:=var100+'山西,';
if inblock('陕西')=1 then var100:=var100+'陕西,';
if inblock('商业连锁')=1 then var100:=var100+'商业连锁,';
if inblock('上海')=1 then var100:=var100+'上海,';
if inblock('上证180')=1 then var100:=var100+'上证180,';
if inblock('上证50')=1 then var100:=var100+'上证50,';
if inblock('社保重仓')=1 then var100:=var100+'社保重仓,';
if inblock('深成40')=1 then var100:=var100+'深成40,';
if inblock('深证100')=1 then var100:=var100+'深证100,';
if inblock('深圳')=1 then var100:=var100+'深圳,';
if inblock('石化')=1 then var100:=var100+'石化,';
if inblock('数字电视')=1 then var100:=var100+'数字电视,';
if inblock('四川')=1 then var100:=var100+'四川,';
if inblock('送转')=1 then var100:=var100+'送转,';
if inblock('天津')=1 then var100:=var100+'天津';
if inblock('通信')=1 then var100:=var100+'通信,';
if inblock('外贸')=1 then var100:=var100+'外贸,';
if inblock('网络游戏')=1 then var100:=var100+'网络游戏,';
if inblock('西藏')=1 then var100:=var100+'西藏,';
if inblock('小盘')=1 then var100:=var100+'小盘,';
if inblock('新材料')=1 then var100:=var100+'新材料,';
if inblock('新疆')=1 then var100:=var100+'新疆,';
if inblock('新上海')=1 then var100:=var100+'新上海,';
if inblock('医药')=1 then var100:=var100+'医药,';
if inblock('仪电仪表')=1 then var100:=var100+'仪电仪表,';
if inblock('有色金属')=1 then var100:=var100+'有色金属,';
if inblock('预亏预减')=1 then var100:=var100+'预亏预减,';
if inblock('预盈预增')=1 then var100:=var100+'预盈预增,';
if inblock('云南')=1 then var100:=var100+'云南,';
if inblock('运输物流')=1 then var100:=var100+'运输物流,';
if inblock('造纸印刷')=1 then var100:=var100+'造纸印刷,';
if inblock('浙江')=1 then var100:=var100+'浙江,';
if inblock('振兴东北')=1 then var100:=var100+'振兴东北,';
if inblock('中价')=1 then var100:=var100+'中价,';
if inblock('中盘')=1 then var100:=var100+'中盘,';
if inblock('重庆')=1 then var100:=var100+'重庆,';
if inblock('自选股')=1 then var100:=var100+'自选股,';
if inblock('3G')=1 then var100:=var100+'3G,';
if inblock('IPO受益')=1 then var100:=var100+'IPO受益,';
if inblock('QFII持股')=1 then var100:=var100+'QFII持股,';
if inblock('参股金融')=1 then var100:=var100+'参股金融,';
if inblock('创新试点')=1 then var100:=var100+'创新试点,';
if inblock('低市净率')=1 then var100:=var100+'低市净率,';
if inblock('定向增发')=1 then var100:=var100+'定向增发,';
if inblock('封闭基金')=1 then var100:=var100+'封闭基金,';
if inblock('股权改革')=1 then var100:=var100+'股权改革,';
if inblock('股权激励')=1 then var100:=var100+'股权激励,';
if inblock('股权投资')=1 then var100:=var100+'股权投资,';
if inblock('航天军工')=1 then var100:=var100+'航天军工,';
if inblock('红利')=1 then var100:=var100+'红利,';
if inblock('沪深300')=1 then var100:=var100+'沪深300,';
if inblock('节能环保')=1 then var100:=var100+'节能环保,';
if inblock('每经G股')=1 then var100:=var100+'每经G股,';
if inblock('清欠')=1 then var100:=var100+'清欠,';
if inblock('权证')=1 then var100:=var100+'权证,';
if inblock('外资并购')=1 then var100:=var100+'外资并购,';
if inblock('未股改')=1 then var100:=var100+'未股改';
if inblock('稀缺资源')=1 then var100:=var100+'稀缺资源,';
if inblock('新能源')=1 then var100:=var100+'新能源,';
if inblock('循环经济')=1 then var100:=var100+'循环经济,';
if inblock('整体上市')=1 then var100:=var100+'整体上市,';
if inblock('中证100')=1 then var100:=var100+'中证100,';
DRAWTEXTREL(10,360,var100),colorffffff;
【上市年】:=REF(YEAR,BARSCOUNT(C)-1);
【月】:=REF(MONTH,BARSCOUNT(C)-1);
【日】:=REF(DAY,BARSCOUNT(C)-1);
DRAWTEXTREL(10,430,'(上市日期:'+NUMTOSTRN(【上市年】,0)+'年'+NUMTOSTRN(【月】,0)+'月'+NUMTOSTRN(【日】,0)+'日'),COLOR00ffff,LINETHICK2;DRAWTEXTREL(800,920,'**'),Colorffffff,LINETHICK2;
DRAWTEXTREL(10,500,'上市后总交易天数:'+NUMTOSTRN(BARSCOUNT(C),0)+'天)'),COLOR00ffff,LINETHICK2;
来自 河南省郑州市

举报

使用道具 扔鸡蛋 回复

949961
Lv.2

专栏

发表于 2007-7-7 22:55 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 贵州省遵义市

举报

使用道具 支持 扔鸡蛋 回复

748161
Lv.7

专栏

发表于 2007-7-5 06:56 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

120693
Lv.5

专栏

发表于 2007-7-5 05:55 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 云南省昆明市

举报

使用道具 点亮 支持 扔鸡蛋 回复

7281
Lv.2

专栏

发表于 2007-7-5 03:50 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省江门市开平市

举报

使用道具 点亮 支持 扔鸡蛋 回复

89565
Lv.3

专栏

发表于 2007-7-4 09:06 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省郑州市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
6楼
5楼
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表