[通达信] 疯牛绝佳买点及选股公式

[通达信] 23214 25
设置
776195 Lv.3

专栏

发表于 2007-7-1 23:19 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
疯牛绝佳买点

VAR2:=(HIGH+LOW+(CLOSE)*(2))/(4);
BH:=((EMA((VAR2-LLV(VAR2,15))/(HHV(LOW,15)-LLV(VAR2,15)),2))*(38)),COLOR0000FF,LINESTICK;
BL:=((((-1))*(EMA((VAR2-LLV(VAR2,15))/(HHV(LOW,15)-LLV(VAR2,15)),2))+0.01)*(38)),COLOR339999,LINESTICK;
VAR22:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VAR33:=EMA(VAR22,10);
VAR44:=EMA(VAR33,10);
VAR55:=(3)*(VAR33)-(2)*(VAR44);
VAR66:=EMA(VAR55,5);
桥:(EMA(VAR66,1)),COLOR007700,LINETHICK1;
跨:(REVERSE(桥)),COLORFFFFFF,LINETHICK1;
{(0),COLORFFFF00,LINETHICK3;}
趋势:=(5)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,27))
/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1),2,1);
底部:=5;
{底:DRAWTEXT((CROSS(趋势,底部)),0,'◥◤'),COLOR00FFFF;}
DRAWTEXT(CROSS((趋势),底部),15,'◢◣'),COLOR00FFFF;
{DRAWTEXT(CROSS(趋势,底部),0,''),COLORRED;
DRAWTEXT(CROSS(趋势,底部),20,'●'),COLORGREEN;}
VARA1:=((CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)>=REF(CLOSE,2)) AND (REF(CLOSE,1)<=REF(CLOSE,3))
AND (REF(CLOSE,2)<=REF(CLOSE,3)) AND ((REF(CLOSE,4)>REF(CLOSE,2)) OR (REF(CLOSE,4)<=REF(CLOSE,2))
AND (REF(CLOSE,5)>=REF(CLOSE,3))) OR (CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)<=REF(CLOSE,2))
AND (CLOSE>=REF(CLOSE,2)) AND ((REF(CLOSE,3)>REF(CLOSE,1)) OR (REF(CLOSE,3)<=REF(CLOSE,1)) AND (REF(CLOSE,4)>=REF(CLOSE,2))));
VARA2:=LLV(LOW,5);
VARA3:=HHV(HIGH,5);
VARA4:=EMA(((CLOSE-VARA2)/(VARA3-VARA2))*(100),1);
VARA5:=EMA((0.66699999)*(REF(VARA4,1))+(0.333)*(VARA4),2);
VARA6:=(VARA5<24) AND (OPEN<MA(CLOSE,20));
VARA1 AND (VARA6),COLORFF0000;
STICKLINE(VARA1 AND (VARA6),-40,40,10,1),COLOR2894FF;
VARB2:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VARB3:=EMA(VARB2,7);
VARB4:=EMA(VARB3,10);
VARB5:=(3)*(VARB3)-(2)*(VARB4);
VARB6:=EMA(VARB5,5);
趋势1:=(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)
*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1));
探底:IF((趋势<=5),58,0),COLORFF00FF;
桥1:=EMA(VARB6,1);
美化:=IF(REF((COUNT((桥1<=REF(桥1,1)),5)=5),1) AND (桥1>REF(桥1,1)),10,0);
STICKLINE((美化),-20,20,15,1),COLORFFFF00;
MTM1:MA((CLOSE-REF(CLOSE,13))*31,5),LINETHICK1,COLOR7711EE;
VARF1:=MA(HHV(HIGH,485),17);
VARF2:=MA(HHV(HIGH,222),17);
VARF3:=MA(HHV(HIGH,96),17);
VARF4:=MA(LLV(LOW,485),17);
VARF5:=MA(LLV(LOW,222),17);
VARF6:=MA(LLV(LOW,96),17);
VARF7:=MA((VARF4*0.96+VARF5*0.96+VARF6*0.96+VARF1*0.558+VARF2*0.558+VARF3*0.558)/6,17);
VARF8:=MA((VARF4*1.25+VARF5*1.23+VARF6*1.2+VARF1*0.55+VARF2*0.55+VARF3*0.65)/6,17);
VARF9:=MA((VARF4*1.3+VARF5*1.3+VARF6*1.3+VARF1*0.68+VARF2*0.68+VARF3*0.68)/6,17);
VARFA:=MA((VARF7*3+VARF8*2+VARF9)/6*1.738,17);
VARFB:=IF(C=C,VARFA,VARFA*DAY);
VARFC:=LOW;
VARFD:=REF(LOW,1);
VARFE:=SMA(ABS(VARFC-VARFD),3,1)/SMA(MAX(VARFC-VARFD,0),3,1)*100;
VARFF:=MA(IF(CLOSE*1.35<=VARFB,VARFE*10,VARFE/10),3);
VARF10:=LLV(LOW,30);
VARF11:=HHV(VARFF,30);
绝佳买点:IF(C=C,MA(IF(LOW<=VARF10,(VARFF+VARF11*2)/2,0),3),100000000)/(200),COLORRED,LINETHICK2;
I:=IF(CLOSE<REF(CLOSE,1),0,VOL/CAPITAL);
骤雨初晴:=ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);
W:=COST(10)*0;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26),COLORRED;
DEA:=EMA(DIFF,9),COLORYELLOW;
MACD:=2*(DIFF-DEA)*231,STICK,COLORRED,LINETHICK1;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.9,0),COLOR00FFFF;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.8,0 ),COLORFFEE44;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.1,0 ),COLOR0055FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.1,0 ),COLORFF55BB;
DRAWTEXT(CROSS(绝佳买点,1.20000) ,-32,'疯牛'),COLORYELLOW,LINETHICK2 ;
DRAWTEXT(CROSS(绝佳买点,4.50000) ,63,'倾家荡产买'),COLOR00FFFF,LINETHICK2;
{DRAWTEXT(CROSS(绝佳买点,7.00000) ,88,'疯牛3'),COLORCYAN,LINETHICK4;}
DRAWTEXT(CROSS(绝佳买点,3.60000) ,28,'疯牛2'),COLORFF00FF,LINETHICK4;
{DRAWTEXT(CROSS(绝佳买点,2.40000) ,-55,'疯牛1'),COLORFFFFCC,LINETHICK3 ; };





















选股公式



VAR1:=MA(HHV(HIGH,485),17);
VAR2:=MA(HHV(HIGH,222),17);
VAR3:=MA(HHV(HIGH,96),17);
VAR4:=MA(LLV(LOW,485),17);
VAR5:=MA(LLV(LOW,222),17);
VAR6:=MA(LLV(LOW,96),17);
VAR7:=MA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,17);
VAR8:=MA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,17);
VAR9:=MA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,17);
VARA:=MA((VAR7*3+VAR8*2+VAR9)/6*1.738,17);
VARB:=IF(V>0,VARA,VARA*DAY);
VARC:=LOW;
VARD:=REF(LOW,1);
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),2,1)*100;
VARF:=MA(IF(CLOSE*1.35<=VARB,VARE*10,VARE/10),2);
VAR10:=LLV(LOW,30);
VAR11:=HHV(VARF,30);
绝佳买点:=IF(V>0,MA(IF(LOW<=VAR10,(VARF+VAR11*2)/2,0),2),100000000);
I:=IF(CLOSE<REF(CLOSE,1),VOL/CAPITAL*10053,0);
骤雨初晴:= ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);

if(CROSS(绝佳买点,24000),15,0 ) ;

附件

2007-07-01_231711.gif
来自 北京市

举报

使用道具 扔鸡蛋 回复

2685453
Lv.2

专栏

发表于 2020-7-23 09:12 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省淄博市

举报

使用道具 支持 扔鸡蛋 回复

3075895
Lv.3

专栏

发表于 2020-7-23 02:36 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 云南省昆明市

举报

使用道具 支持 扔鸡蛋 回复

2888813
Lv.6

专栏

发表于 2020-7-7 22:10 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市徐汇区

举报

使用道具 支持 扔鸡蛋 回复

2888813
Lv.6

专栏

发表于 2020-7-7 22:06 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市徐汇区

举报

使用道具 支持 扔鸡蛋 回复

1334743
Lv.4

专栏

发表于 2012-6-7 13:24 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省广州市

举报

使用道具 支持 扔鸡蛋 回复

2236034
Lv.2

专栏

发表于 2010-8-29 23:36 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省许昌市

举报

使用道具 支持 扔鸡蛋 回复

118683
Lv.2

专栏

发表于 2010-8-29 23:25 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省武汉市

举报

使用道具 支持 扔鸡蛋 回复

2182077
Lv.5

专栏

发表于 2010-8-29 22:10 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省

举报

使用道具 支持 扔鸡蛋 回复

1882228
Lv.3

专栏

发表于 2010-8-29 14:17 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河北省唐山市

举报

使用道具 支持 扔鸡蛋 回复

47334
Lv.3

专栏

发表于 2007-8-10 19:14 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 吉林大学前卫北区

举报

使用道具 支持 扔鸡蛋 回复

1042772
Lv.2

专栏

发表于 2007-8-10 08:49 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 辽宁省大连市

举报

使用道具 支持 扔鸡蛋 回复

954267
Lv.2

专栏

发表于 2007-8-10 01:03 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市海淀区

举报

使用道具 点亮 支持 扔鸡蛋 回复

659489
Lv.2

专栏

发表于 2007-8-10 00:51 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 陕西省西安市

举报

使用道具 点亮 支持 扔鸡蛋 回复

896313
Lv.2

专栏

发表于 2007-8-10 00:09 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

附件

2005101616154054.gif
来自 江苏省徐州市

举报

使用道具 支持 扔鸡蛋 回复

685122
Lv.4

专栏

发表于 2007-8-8 17:28 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖南省衡阳市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1002697
Lv.2

专栏

发表于 2007-7-21 14:15 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省济南市

举报

使用道具 点亮 支持 扔鸡蛋 回复

232341
Lv.2

专栏

发表于 2007-7-18 09:28 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市杨浦区

举报

使用道具 点亮 支持 扔鸡蛋 回复

99147
Lv.3

专栏

发表于 2007-7-18 05:46 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 辽宁省沈阳市

举报

使用道具 支持 扔鸡蛋 回复

994958
Lv.2

专栏

发表于 2007-7-18 03:44 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 海南省海口市

举报

使用道具 点亮 支持 扔鸡蛋 回复

775398
Lv.2

专栏

发表于 2007-7-18 00:56 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省郑州市

举报

使用道具 支持 扔鸡蛋 回复

943524
Lv.3

专栏

发表于 2007-7-18 00:13 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 安徽省黄山市

举报

使用道具 支持 扔鸡蛋 回复

916229
Lv.2

专栏

发表于 2007-7-17 23:41 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省绍兴市

举报

使用道具 支持 扔鸡蛋 回复

212746
Lv.2

专栏

发表于 2007-7-7 09:59 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山西省朔州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

671262
Lv.3

专栏

发表于 2007-7-7 09:04 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省洛阳市

举报

使用道具 点亮 支持 扔鸡蛋 回复

841251
Lv.3

专栏

发表于 2007-7-2 09:14 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省东莞市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼 8楼
25楼 7楼
24楼 6楼
23楼 5楼
22楼 4楼
21楼 3楼
20楼 2楼
19楼 楼主
18楼  
17楼  
16楼  
15楼  
14楼  
13楼  
12楼  
11楼  
10楼  
9楼  
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表