求高手将殷宝华公式源码改为通达信可用!!

[通达信] 6372 4
设置
346531 Lv.2

专栏

发表于 2007-7-4 03:18 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
殷宝华公式源码。怎么在通达信和大智慧上无法使用。求高手帮解决!!

殷宝华公式源码


给大家殷宝华公式源码,祝大家节日快乐。
{公称名称: 保华均线}
MA25:EMA(CLOSE,25);
牛熊分水岭:EMA(CLOSE,905);
STICKLINE((MA25 > 牛熊分水岭),MA25,牛熊分水岭,1,0),colorFF;
STICKLINE((MA25 < 牛熊分水岭),MA25,牛熊分水岭,1,0),colorFF00;
DRAWICON(CROSS(MA25,牛熊分水岭),(牛熊分水岭 * 0.98),6);

{公称名称: 保华提醒}
VAR1:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04)));
VAR2:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
VAR3:=REF(CLOSE,1);
VAR4:=((SMA(MAX((CLOSE - VAR3),0),6,1) / SMA(ABS((CLOSE - VAR3)),6,1)) * 100);
买入VAR1 AND VAR2),STICK,colorFF;
卖出:CROSS(80,VAR4),STICK,colorFF00;

{公称名称: 江恩八线}
一号线:EMA(CLOSE,144);
工作线:EMA(CLOSE,14),colorFF;
二号线:EMA(CLOSE,25);
三号线:EMA(CLOSE,318);
生命线:EMA(CLOSE,453),LINETHICK2,colorFF;
五号线:EMA(CLOSE,550);
六号线:EMA(CLOSE,610);
七号线:EMA(CLOSE,730);
八号线:EMA(CLOSE,888);
九号线:EMA(CLOSE,99),colorFF00;

{公称名称: 买卖奇准}
你:=MA(CLOSE,1);
老:=(((LOW + HIGH) + CLOSE) / 3);
板:=MA(老,5);
好:=HHV(板,10);
老板:=MA(老,5);
买卖:=LLV(老板,10);
急买奇准:IF(LLV((你 < 买卖),5),50,0),colorFF;
急卖奇准:IF(HHV((你 < 好),5),100,50),colorFF0000;
短买奇准:IF(LLV((你 < 买卖),10),50,0),colorFFFFFF;
短卖奇准:IF(HHV((你 < 好),10),100,50),colorFF00;

{公称名称: 四号箱体}
HEPGEMA(CLOSE,450) * 2.14),colorFFFFFF;
MA03EMA(CLOSE,450) * 2.01),colorFF00FF;
MA02:(EMA(CLOSE,450) * 1.88),colorFF00;
MA01:(EMA(CLOSE,450) * 1.75),colorFFFFFF;
MA1:(EMA(CLOSE,450) * 1.66),colorFF0000;
MA2:(EMA(CLOSE,450) * 1.5),colorFF00FF;
MA3:(EMA(CLOSE,450) * 1.37),colorFFFF;
MA4:(EMA(CLOSE,450) * 1.33),colorFF00FF;
MA5:(EMA(CLOSE,450) * 1.25),colorFF00;
MA6:(EMA(CLOSE,450) * 1.14),colorFFFFFF;
MA7:(EMA(CLOSE,450) * 0.99),colorFFFFFF;
MA8:(EMA(CLOSE,450) * 0.84),colorFFFFFF;
工作线:EMA(CLOSE,14),colorFFFFFF;
生命线:EMA(CLOSE,47),colorFFFF;

{公称名称: 准备买入}
n:=5;
var1:4*SMA((CLOSE-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100,5,1),3.2,1),COLORYELLOW,linethick0;
var2:8,colorgreen,linethick0;
上升在即: IF(CROSS(var1,var2),80,0),stick,COLOR0000cc,linethick2;
专吸庄血: IF(var1<=8,25,0),stick,COLORwhite,linethick2;
DRAWTEXT(CROSS(var1,var2),80,'准备买入'),COLOR00ffff;
Varo5:=LLV(LOW,27);
Varo6:=HHV(HIGH,34);
Varo7:=EMA((CLOSE-Varo5)/(Varo6-Varo5)*4,4)*25;
建仓区: IF((Varo7<10),80,100) ,color00ccff,linethick1;
0,linethick2 ,colorffcc00
来自 四川省成都市

举报

使用道具 扔鸡蛋 回复

1048477
Lv.2

专栏

发表于 2007-8-18 23:11 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省无锡市锡山区

举报

使用道具 支持 扔鸡蛋 回复

1055392
Lv.2

专栏

发表于 2007-8-18 22:06 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市

举报

使用道具 支持 扔鸡蛋 回复

346531
Lv.2

专栏

发表于 2007-7-4 13:00 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省成都市

举报

使用道具 支持 扔鸡蛋 回复

748161
Lv.7

专栏

发表于 2007-7-4 09:17 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
5楼
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表