那位高手能够把下面这个公式改为通达信,万分感谢

[通达信] 3209 0
设置
956134 Lv.3

专栏

发表于 2007-7-5 20:26 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=(SMA(RSV,3,1));
D:=(SMA(K,3,1));
J:=(3*K-2*D);
KK:=INTPART(SMA(RSV,3,1));
DD:=INTPART(SMA(K,3,1));
JJ:=INTPART(3*K-2*D);
JJ1:=REF(jj,1);
A:=KK-DD;
A1:=REF(KK-DD,1);
A2:=REF(KK-DD,2);
A3:=REF(KK-DD,3);
A4:=REF(KK-DD,4);
A5:=REF(KK-DD,5);
A6:=REF(KK-DD,6);
A7:=REF(KK-DD,7);
B:=A1-A;
B1:=REF(A1-A,1);
B2:=REF(A1-A,2);
B3:=REF(A1-A,3);
B4:=REF(A1-A,4);
B5:=REF(A1-A,5);
B6:=REF(A1-A,6);
CC:=B+B1+B2;
CC1:=REF(B+B1+B2,1);
CC2:=REF(B+B1+B2,2);
CC3:=REF(B+B1+B2,3);
CC4:=REF(B+B1+B2,4);
CC5:=REF(B+B1+B2,5);
CC6:=REF(B+B1+B2,6);
AD:=CC-B2;
AD1:=REF(CC-B2,1);
AD2:=REF(CC-B2,2);
AD3:=REF(CC-B2,3);
AD4:=REF(CC-B2,4);
AD5:=REF(CC-B2,5);
AD6:=REF(CC-B2,6);
N:=KK+DD;
N1:=REF(N,1);
N2:=REF(N,2);
N3:=REF(N,3);
N4:=REF(N,4);
N5:=REF(N,5);
N6:=REF(N,6);
N7:=REF(N,7);
N8:=REF(N,8);
s:=n<75;
s1:=b<-1;
s2:=cc<0;
s3:=b<5;
s4:=n<55;
s5:=b<0;
s6:=b<1;
s7:=cc<-3;
s8:=cc<-9;
bi:=(CLOSE-MA(CLOSE,8))/MA(CLOSE,8)*100< -6.1;
p:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100<-10;
p1:=C/COST(8)<0.8;
p2:=((c-(dma(((3*h+l+o+2*c)/7),v/(sum(amount,13)/
(amount/v/100)/100))))/(dma(((3*h+l+o+2*c)/7),
v/(sum(amount,13)/(amount/v/100)/100))))*100  ;
p3:=p2<-14 and FINANCE2(34)>=1.5;
p4:=("EXPLORER.boll") or ("EXPLORER.kdj") or ("EXPLORER.c-102");
x:=p and p1 and (p3 or p4);
x1:=((b3=0 and cc3<0 and b1>0 and cc2<0) or (b4=0 and ad1=-1 and ad3<0)
or (b1=0 and ad3>0 and a4<0 and b3>=0 and (cc1<0 or cc3<0)));
ss:=(bi AND A1=0 and b5-b4=a3 and ad4<>-3 and ad4<>-1 and cc4<>-3
and n6<60 and n1-n<6 and n6>15) and ((ref(s,26)
and ref(s,13)) or ref(s,50) or ref(s,55));
ss1:=x and x1 and ref(s2,19) and ref(s2,21)
and (ref(s1,3) or ref(s1,13) or ref(s1,92)
or (ref(s1,67) and ref(s3,80)));
ss2:=x and x1 and ref(s2,19) and ref(s2,3)
and (ref(s1,3) or ref(s1,13) or (ref(s2,48)
and (ref(s,25) or ref(s,92))));
gg:=ss or ss1 or ss2;
st:=n<36;
st1:=ref(st,18);
st2:=n<45;
sw:=LLV(L,3)=LLV(L,0) AND BARSCOUNT(C)>=3;
sw1:=OPEN<CLOSE AND OPEN/REF(C,1)
<= 1-2/100 AND CLOSE/OPEN>=1+3/100;
sw2:=CROSS(CLOSE,"BOLL.LOWER"(26,2)) and (st1 or n<23);
sw3:=("EXPLORER.rsi") and ((ref(st2,17) and
ref(st2,38)) or (ref(st2,10) and ref(st2,18)));
ii:=sw and sw1 and (sw3 or sw2);
i:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND
REF(OPEN,1) < REF(CLOSE,2) AND
ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
i1:=("EXPLORER.macd");
ss3:=ref(s,34) and  (ref(s,25) or ref(s4,72)
or (ref(s4,1) and ref(s4,39)));
ss4:=ref(s,28) and  ref(s4,65);
ss5:=ref(s,57) and  (ref(s,149) or ref(s,154));
ii1:=i and i1;
gg1:=(ii or ii1) and (ss3 or ss4 or ss5);
t:=n<25;
t1:=ref(t,31);
w:=LLV(L,3)=LLV(L,0) AND BARSCOUNT(C)>=3;
w4:=COST(10)/C>1.15;
w5:=((CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100)<-19;
aw1:=((CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100)<-18;
at:=n<31;
at1:=ref(at,31);
aw2:=aw1 and n<25 and ref(at,29) and (ref(at,32)
or ref(at,48) or ref(at,49));
ss6:=bi and w and t and w4 and w5 and ad1>0 and
ref(s,13) and  (ref(s,86) or (ref(s,63) and (ref(s,21) or ref(s,28))));
ss7:=aw2 and ((ref(s,70) and  ref(s,21)) or (ref(s,113) and  ref(s,46)));
gg2:=ss6 or ss7;
us1:=ema(winner(c),10);
us2:=ema(winner(c),34);
us3:=if(us1<0.15 and abs(us1-us2)<0.05 and cross(us1,us2),1,0);
us4:=MA(CLOSE,80)-MA(CLOSE,10)/3;
us5:=CLOSE<us4;
u:=us3 and us5;
u1:=n<38;
u2:=ref(u1,33) and (ref(u1,98) or ref(u1,101));
u3:=n<37;
u4:=ref(u1,33) and (ref(u3,2) or ref(u3,72));
au1:=n<32;
aau1:=n<50;
au2:=ref(au1,19) or ref(aau1,13);
as1:=ema(winner(c),3);
as2:=ema(winner(c),25);
as3:=if(us1<0.15 and abs(as1-as2)<0.05 and cross(as1,as2),1,0);
as4:=MA(CLOSE,80)-MA(CLOSE,10)/3;
as5:=CLOSE<us4;
au:=as3 and as5 and ("EXPLORER.boll") and au2;
au5:=as3 and as5 and ("EXPLORER.bias") and (ref(au1,124));
au6:=us3 and us5 and ("EXPLORER.macd") and au2 and
(ref(au1,41) or ref(au1,2));
au7:=CLOSE<(MA(CLOSE,80)-MA(CLOSE,10)/3);
au8:="VMACD.MACD"(15,63,13)>0
AND LLV(CLOSE/MA(CLOSE,58),25)<0.78
AND (MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW))
+ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100))/(AMOUNT/VOL/100)*50>2;
oi4:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
oi:=CLOSE/MA(CLOSE,40)*100<76;
oi1:=CLOSE/MA(CLOSE,60)*100<74;
oi2:=HIGH>LOW*1.051;
oi3:=oi2 AND COUNT(oi2,5)>1;
au9:=oi4<6 AND (oi OR oi1) AND oi3;
ou1:=n<42;
ou2:=ref(ou1,28) and (ref(ou1,59) or ref(ou1,81)
or ref(ou1,84) or ref(ou1,129) or ref(ou1,148)
or ref(ou1,155) or ref(ou1,188) or ref(ou1,189));
oi5:=(CROSS(CLOSE,"BOLL.LOWER"(26,2))) and (ou2 or n<20);
oi6:=(HIGH=CLOSE AND HIGH<>LOW) and (n<22 or ref(ou1,29)
or ref(ou1,63) or ref(ou1,65) or ref(ou1,76));
oi7:=ABS(HIGH-LOW);
oi8:=SUM(oi7,7)/CLOSE>0.5 AND SUM(oi7,7)/CLOSE<0.8
AND CLOSE>7 AND CLOSE<11;
oi9:=oi8 and (n<20 or ref(ou1,18) or (ref(ou1,2) and ref(ou1,16)));
ss8:=(u and (u2 or u4)) and ref(s2,20) and (ref(s,75) or ref(s,98)
or ref(s,195));
ss9:=(u and (u2 or u4)) and ref(s2,73) and (ref(s2,61)
or ref(s2,92) or ref(s2,102) or ref(s2,96));
ss11:=(au5 or au or au6) and ((ref(s5,13) and
ref(s6,31)) or (ref(s5,8) and ref(s3,38)) or
(ref(s6,56) and ref(s6,66)));
ss12:=au7 and au8 and au9 and oi5 and
ref(s,29) and (ref(s5,15) or ref(s5,65) or
ref(s5,111) or ref(s5,136) or ref(s5,155));
ss13:=au7 and au8 and au9 and oi5 and
ref(s2,8) and (ref(s2,48) or ref(s2,12));
ss14:=au7 and au8 and au9 and oi6 and
(ref(s7,88) and (ref(s8,86)) or (ref(s8,81) and ref(s2,47)));
ss15:=au7 and au8 and au9 and oi9 and ref(s2,3);
gg3:=ss8 or ss9 or ss11 or ss12 or ss13 or ss14 or ss15;
kkddj:gg or gg1 or gg2 or gg3;
来自 福建省福州市

举报

使用道具 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表