恳请高手将这个主图公式改为通达信的

[通达信] 3435 0
设置
551196 Lv.2

专栏

发表于 2007-7-9 00:13 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
实战博弈
DRAWGBK(1,COLORRGB(44,22,108),COLORRGB(33,0,0),0),color10000;
KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100));
趋势线:=EMA(((KS / 10) + EMA(CLOSE,10)),3);
AA:= - 100 * (趋势线 - CLOSE) / 趋势线;
AC:=(EMA(AA,5) );
STICKLINE(((((CLOSE >= OPEN) ) AND (AA >= 0)) AND (AA >= AC)),OPEN,CLOSE,7.8,1),colorFF;
STICKLINE(((((OPEN > CLOSE) ) AND (AA >= 0)) AND (AA >= AC)),CLOSE,OPEN,7.8,0),colorFF;
STICKLINE(((((CLOSE >= OPEN) ) AND (AA >= 0)) AND (AA >= AC)),CLOSE,HIGH,0.5,1),colorFF;
STICKLINE(((((CLOSE >= OPEN) ) AND (AA >= 0)) AND (AA >= AC)),OPEN,LOW,0.5,1),colorFF;
STICKLINE(((((OPEN > CLOSE) ) AND (AA >= 0)) AND (AA >= AC)),CLOSE,LOW,0.5,0),colorFF;
STICKLINE(((((OPEN > CLOSE) ) AND (AA >= 0)) AND (AA >= AC)),OPEN,HIGH,0.5,0),colorFF;
STICKLINE(((((CLOSE >= OPEN) ) AND (AA >= 0)) AND (AA < AC)),OPEN,CLOSE,7.8,1),colorFF00FF;
STICKLINE(((((OPEN > CLOSE)) AND (AA >= 0)) AND (AA < AC)),CLOSE,OPEN,7.8,0),colorFF00FF;
STICKLINE(((((CLOSE >= OPEN) ) AND (AA >= 0)) AND (AA < AC)),CLOSE,HIGH,0.5,1),colorFF00FF;
STICKLINE(((((CLOSE >= OPEN) ) AND (AA >= 0)) AND (AA < AC)),OPEN,LOW,0.5,1),colorFF00FF;
STICKLINE(((((OPEN > CLOSE) ) AND (AA >= 0)) AND (AA < AC)),CLOSE,LOW,0.5,0),colorFF00FF;
STICKLINE(((((OPEN > CLOSE) ) AND (AA >= 0)) AND (AA < AC)),OPEN,HIGH,0.5,0),colorFF00FF;
STICKLINE((((CLOSE >= OPEN) ) AND (AA < 0)),OPEN,CLOSE,7.8,1),colorD38784;
STICKLINE((((OPEN > CLOSE)) AND (AA < 0)),CLOSE,OPEN,7.8,0),colorD38784;
STICKLINE((((CLOSE >= OPEN) ) AND (AA < 0)),CLOSE,HIGH,0.5,1),colorD38784;
STICKLINE((((CLOSE >= OPEN) ) AND (AA < 0)),OPEN,LOW,0.5,1),colorD38784;
STICKLINE((((OPEN > CLOSE) ) AND (AA < 0)),CLOSE,LOW,0.5,0),colorD38784;
STICKLINE((((OPEN > CLOSE) ) AND (AA < 0)),OPEN,HIGH,0.5,0),colorD38784;
AG:=SUM((VOL / FINANCE(7)),1);
STICKLINE(((((((CLOSE >= OPEN) AND (DATATYPE < 7)) ) AND (AG >= 8)) AND (AG < 15)) AND (AA >= 0)),OPEN,(OPEN * 1.008),10,0),colorFF;
STICKLINE(((((((OPEN > CLOSE) AND (DATATYPE < 7)) ) AND (AG >= 8)) AND (AG < 15)) AND (AA >= 0)),(OPEN * 1.008),OPEN,10,0),colorFF;
STICKLINE(((((((CLOSE >= OPEN) AND (DATATYPE < 7)) ) AND (AG >= 8)) AND (AG < 15)) AND (AA < 0)),OPEN,(OPEN * 0.998),10,0),colorFF;
STICKLINE(((((((OPEN > CLOSE) AND (DATATYPE < 7)) ) AND (AG >= 8)) AND (AG < 15)) AND (AA < 0)),(OPEN * 0.998),OPEN,10,0),colorFF;
STICKLINE((((((CLOSE >= OPEN) AND (DATATYPE < 7)) ) AND (AG >= 15)) AND (AA >= 0)),OPEN,(OPEN * 1.008),15,0),colorFFFFFF;
STICKLINE((((((OPEN > CLOSE) AND (DATATYPE < 7)) ) AND (AG >= 15)) AND (AA >= 0)),(OPEN * 1.008),OPEN,15,0),colorFFFFFF;
STICKLINE((((((CLOSE >= OPEN) AND (DATATYPE < 7)) ) AND (AG >= 15)) AND (AA < 0)),OPEN,(OPEN * 0.998),15,0),colorFFFFFF;
STICKLINE((((((OPEN > CLOSE) AND (DATATYPE < 7)) ) AND (AG >= 15)) AND (AA < 0)),(OPEN * 0.998),OPEN,15,0),colorFFFFFF;
SSL:=EMA(CLOSE,3);
MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);
MM:=(IF(((DATATYPE > 5) AND (DATATYPE < 9)),MA(MMV,1),IF((DATATYPE = 5),MA(MMV,4),IF((DATATYPE = 4),MA(MMV,8),IF((DATATYPE = 3),MA(MMV,16),IF((DATATYPE = 2),MA(MMV,32),0))))) );
STICKLINE(((SSL > MM) ),SSL,MM,0.1,0),colorFF;
SA:=(MM * 0.985);
SS:=(MA(CLOSE,5));
DD:=(MA(CLOSE,13));
GG:=(MA(CLOSE,21));
常用指标:IF(((SSL > MM)),SSL,SA),LINETHICK1,colorFF;
NHSH__:IF(((SSL > MM) ),MM,SA),LINETHICK1,colorFFFFFF;
QLZHM:IF(((SSL > MM)),MM,SA),LINETHICK2,colorFF00FF;
PARTLINE(((SSL <= MM) ),SA),LINETHICK3,colorFF0000;
VAR2Y:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR3Y:=(((CLOSE - REF(OPEN,29)) / REF(OPEN,29)) * 100);
VAR4Y:=REF(CLOSE,1);
VAR5Y:=((SMA(MAX((CLOSE - VAR4Y),0),6,1) / SMA(ABS((CLOSE - VAR4Y)),6,1)) * 100);
VAR6Y:=((SMA(MAX((CLOSE - VAR4Y),0),12,1) / SMA(ABS((CLOSE - VAR4Y)),12,1)) * 100);
VAR7Y:=((SMA(MAX((CLOSE - VAR4Y),0),24,1) / SMA(ABS((CLOSE - VAR4Y)),24,1)) * 100);
VAR8Y:=(((CLOSE - LLV(LOW,45)) / (HHV(HIGH,45) - LLV(LOW,45))) * 100);
VAR9Y:=SMA(VAR8Y,3,1);
VARAY:=SMA(VAR9Y,3,1);
VARBY:=((3 * VAR9Y) - (2 * VARAY));
VARCY:=(CROSS(VAR5Y,10) AND (VAR3Y < (0 - (28 * 20))));
VARDY:=((100 - CROSS(76,VAR5Y)) AND (VAR3Y > (5 * 20)));
DRAWICON(((CROSS(76,VAR5Y) AND (VAR3Y > 5)) ),(HIGH * 1.0099),5),colorFFFFFF;
VAREY:=((((CROSS(VAR9Y,VARAY) AND (VARAY < 10)) AND (VAR3Y < (0 - 30))) AND (VAR2Y > 3)) * 30);
VARFY:= - ((((VARAY < 11) AND (VAR5Y < 15)) AND (VAR3Y < (0 - 26))) * 10);
DRAWICON((CROSS(VARFY,(0 - 9))),(LOW * 0.998),4);
能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) * 4)));
VAR3C:=EMA(能量线,1);
VAR4C:=REF(能量线,1);
STICKLINE(((VAR3C > VAR4C)),VAR3C,VAR4C,7.5,0),colorFFFF;
来自 山西省吕梁市

举报

使用道具 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表