通达信--新短线猎枪

[通达信] 31507 64
设置
550840 Lv.3

专栏

发表于 2007-7-15 09:48 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
通达信--新短线猎枪


{短线猎枪源码:参数:P5:49,1,300}
牛熊界:MA(CLOSE,P5),LINETHICK2,COLORWHITE;
KS:=((CLOSE-EMA(CLOSE,13))/EMA(CLOSE,13))*(-100);
趋势线:=EMA(KS/10+EMA(CLOSE,10),3);
AA:= -100*(趋势线-CLOSE)/趋势线;
AC:=EMA(AA,5);
{STICKLINE(CLOSE>=OPEN AND AA>=0 AND AA>=AC,OPEN,CLOSE,2.8,1),COLOR0000FF;
STICKLINE(OPEN>CLOSE AND AA>=0 AND AA>=AC,CLOSE,OPEN,2.8,0),COLOR0000FF;
STICKLINE(CLOSE>=OPEN AND AA>=0 AND AA<AC,OPEN,CLOSE,2.8,1),COLORFF00FF;
STICKLINE(OPEN > CLOSE AND AA >= 0 AND AA < AC,CLOSE,OPEN,2.8,0),COLORFF00FF;
STICKLINE(CLOSE>=OPEN AND AA<0,OPEN,CLOSE,2.8,0),COLORD38784;
STICKLINE(OPEN>CLOSE AND AA<0,CLOSE,OPEN,2.8,0),COLORD38784;}
AG:=SUM((VOL/FINANCE(7)),1);
{STICKLINE(((((((CLOSE >= OPEN) AND (DATATYPE < 7)) ) AND (AG >= 8)) AND (AG < 15)) AND (AA >= 0)),OPEN,(OPEN * 1.008),10,0),COLOR0000FF;
STICKLINE(((((((OPEN > CLOSE) AND (DATATYPE < 7)) ) AND (AG >= 8)) AND (AG < 15)) AND (AA >= 0)),(OPEN * 1.008),OPEN,10,0),COLOR0000FF;
STICKLINE(((((((CLOSE >= OPEN) AND (DATATYPE < 7)) ) AND (AG >= 8)) AND (AG < 15)) AND (AA < 0)),OPEN,(OPEN * 0.998),10,0),COLOR0000FF;
STICKLINE(((((((OPEN > CLOSE) AND (DATATYPE < 7)) ) AND (AG >= 8)) AND (AG < 15)) AND (AA < 0)),(OPEN * 0.998),OPEN,10,0),COLOR0000FF;
STICKLINE((((((CLOSE >= OPEN) AND (DATATYPE < 7)) ) AND (AG >= 15)) AND (AA >= 0)),OPEN,(OPEN * 1.008),15,0),COLORFFFFFF;
STICKLINE((((((OPEN > CLOSE) AND (DATATYPE < 7)) ) AND (AG >= 15)) AND (AA >= 0)),(OPEN * 1.008),OPEN,15,0),COLORFFFFFF;
STICKLINE((((((CLOSE >= OPEN) AND (DATATYPE < 7)) ) AND (AG >= 15)) AND (AA < 0)),OPEN,(OPEN * 0.998),15,0),COLORFFFFFF;
STICKLINE((((((OPEN > CLOSE) AND (DATATYPE < 7)) ) AND (AG >= 15)) AND (AA < 0)),(OPEN * 0.998),OPEN,15,0),COLORFFFFFF;}
SSL:=EMA(CLOSE,3);
MMV:=EMA(SLOPE(CLOSE,22)*20+CLOSE,55);
MM:=1;
{(IF(((DATATYPE > 7) AND (DATATYPE < 11)),MA(MMV,1),IF((DATATYPE = 7),MA(MMV,4),IF((DATATYPE = 6),MA(MMV,8),IF((DATATYPE = 5),MA(MMV,16),IF((DATATYPE = 4),MA(MMV,32),0))))) );}

SA:=0.985;
SS:=MA(CLOSE,5);
DD:=MA(CLOSE,13);
GG:=MA(CLOSE,21);
短趋势:IF(SS>MM,SSL,SA),LINETHICK1,COLORWHITE;
空方:IF(SSL>MM,MA(MMV,8),SA),LINETHICK1,COLORFFFFFF;
多方:IF(SSL>MM,MA(MMV,16),SA),LINETHICK2,COLORFF00FF;{
IF(SA,SSL<=MM,DRAWNULL),LINETHICK3,COLORFF0000;}
VAR2Y:=((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1))*100;
VAR3Y:=((CLOSE - REF(OPEN,29)) / REF(OPEN,29))*100;
VAR4Y:=REF(CLOSE,1);
VAR5Y:=((SMA(MAX((CLOSE - VAR4Y),0),6,1) / SMA(ABS((CLOSE - VAR4Y)),6,1)) * 100);
VAR6Y:=((SMA(MAX((CLOSE - VAR4Y),0),12,1) / SMA(ABS((CLOSE - VAR4Y)),12,1)) * 100);
VAR7Y:=((SMA(MAX((CLOSE - VAR4Y),0),24,1) / SMA(ABS((CLOSE - VAR4Y)),24,1)) * 100);
VAR8Y:=(((CLOSE - LLV(LOW,45)) / (HHV(HIGH,45) - LLV(LOW,45))) * 100);
VAR9Y:=SMA(VAR8Y,3,1);
VARAY:=SMA(VAR9Y,3,1);
VARBY:=((3 * VAR9Y) - (2 * VARAY));
VARCY:=CROSS(VAR5Y,10) AND VAR3Y<-28*20;
VARDY:=((100 - CROSS(76,VAR5Y)) AND VAR3Y>5*20);
DRAWICON(CROSS(76,VAR5Y) AND VAR3Y>5,HIGH*1.0099,5),COLORFFFFFF;
VAREY:=(CROSS(VAR9Y,VARAY) AND VARAY<10 AND VAR3Y<-30 AND VAR2Y>3)*30;
VARFY:= -((VARAY<11 AND VAR5Y<15 AND VAR3Y<-26)*10);
DRAWICON(CROSS(VARFY,-9),LOW*0.998,4);
能量线:=DMA((CLOSE+OPEN)/2,(VOL/(SMA(VOL,4,1)*4)));
VAR3C:=EMA(能量线,1);
VAR4C:=REF(能量线,1);
STICKLINE(VAR3C>VAR4C,VAR3C,VAR4C,2.5,0),COLOR00FFFF;
X:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);
Y:=EMA(CLOSE,10);
LL:=REF(CLOSE,2);
MM1:=((SMA(MAX((CLOSE - LL),0),6,1) / SMA(ABS((CLOSE - LL)),6,1)) * 100);
DB:=IF(MM1<REF(MM1,1) AND MM1>79,MM1,0);
DRAWICON(CROSS(Y,X),(LOW * 0.985),1),LINETHICK3,COLORRED;
DRAWICON(CROSS(X,Y),(HIGH * 1.02),2),LINETHICK2,COLOR00FF00;{
DRAWTEXT(DB,(HIGH * 1.02),'↓顶'),LINETHICK2,COLOR00FF00;}
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
DD1:=EMA(((0.667 * REF(AK1,1)) + (0.333 * AK1)),2);
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((((CLOSE - VAR3) / (VAR4 - VAR3)) * 100),3);
VAR6:=((AK + VAR5) / 2);
VAR7:=EMA(((0.667 * REF(VAR5,1)) + (0.333 * AK1)),2);
VAR8:=EMA(VAR6,5);
BB:=EMA(((0.667 * REF(VAR8,1)) + (0.333 * VAR8)),2);
AB:=CROSS(AK1,AK);
BB1:=(CROSS(AK1,BB) AND (BB < 30));
CD:=(BB1 * 0.6);
DRAWTEXT(CD=0.6,LOW*0.99,'↑底2'),LINETHICK1,COLOR33CC99;
DRAWTEXT(AB=1,LOW*0.99,'↑底1'),LINETHICK1,COLORWHITE;

C1:=(CLOSE+LOW+HIGH)/3;
C2:=EMA(C1,6);
C3:=EMA(C2,5);
C4:=CROSS(C2,C3);
DRAWTEXT(C4,LOW/1.01,''),LINETHICK3,COLORRED;
C5:=CROSS(C3,C2);
DRAWTEXT(C5,HIGH*1.03,''),LINETHICK3,COLORBLUE;
STICKLINE(CLOSE<OPEN AND REF(CLOSE,1)>REF(OPEN,1),REF(CLOSE,1),REF(CLOSE,1),20,0),COLORFFFFFF;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV12:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=3*K12-2*D12;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
压力位:IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),COLORGREEN,LINETHICK2;
支撑位:IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24))))
,COLOR77AAFF,LINETHICK2;
来自 河北省石家庄市

举报

使用道具 扔鸡蛋 回复

132847
Lv.4

专栏

发表于 2012-6-8 14:01 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省东莞市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1334743
Lv.4

专栏

发表于 2012-6-8 13:57 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省江门市

举报

使用道具 支持 扔鸡蛋 回复

2520343
Lv.4

专栏

发表于 2012-6-8 11:55 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 福建省龙岩市

举报

使用道具 支持 扔鸡蛋 回复

2604388
Lv.2

专栏

发表于 2012-6-8 09:02 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省南通市

举报

使用道具 支持 扔鸡蛋 回复

2087067
Lv.4

专栏

发表于 2011-3-25 21:54 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省

举报

使用道具 支持 扔鸡蛋 回复

2063268
Lv.3

专栏

发表于 2011-3-25 18:07 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省南阳市

举报

使用道具 支持 扔鸡蛋 回复

2308014
Lv.3

专栏

发表于 2011-2-25 16:30 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省武汉市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1592598
Lv.2

专栏

发表于 2009-11-23 13:19 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖南省衡阳市

举报

使用道具 支持 扔鸡蛋 回复

1562300
Lv.2

专栏

发表于 2009-11-22 21:24 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省江门市

举报

使用道具 支持 扔鸡蛋 回复

1875589
Lv.4

专栏

发表于 2009-11-22 21:19 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省烟台市

举报

使用道具 支持 扔鸡蛋 回复

1450026
Lv.4

专栏

发表于 2008-12-10 09:03 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省绵阳市

举报

使用道具 支持 扔鸡蛋 回复

1361230
Lv.2

专栏

发表于 2008-12-9 22:19 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市松江区

举报

使用道具 支持 扔鸡蛋 回复

498531
Lv.3

专栏

发表于 2008-12-8 21:27 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市卢湾区

举报

使用道具 支持 扔鸡蛋 回复

1460153
Lv.3

专栏

发表于 2008-12-8 01:04 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 辽宁省盘锦市

举报

使用道具 支持 扔鸡蛋 回复

635487
Lv.4

专栏

发表于 2008-10-23 11:02 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市徐汇区

举报

使用道具 支持 扔鸡蛋 回复

1339338
Lv.3

专栏

发表于 2008-9-17 21:25 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省徐州市睢宁县

举报

使用道具 支持 扔鸡蛋 回复

1339431
Lv.2

专栏

发表于 2008-9-17 18:37 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省德州市

举报

使用道具 支持 扔鸡蛋 回复

1365965
Lv.3

专栏

发表于 2008-9-17 15:33 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西南宁市

举报

使用道具 支持 扔鸡蛋 回复

1346099
Lv.3

专栏

发表于 2008-9-17 12:52 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省荆门市

举报

使用道具 支持 扔鸡蛋 回复

1406431
Lv.2

专栏

发表于 2008-9-17 12:42 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市静安区

举报

使用道具 支持 扔鸡蛋 回复

1351826
Lv.4

专栏

发表于 2008-9-16 22:04 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省河源市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1367395
Lv.3

专栏

发表于 2008-9-16 21:30 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

附件

1_最牛情侣搭配.jpg 在线检测未来函数 通达信指标代码翻译工具

59.82 KB, 下载次数: 14, 下载积分: 共享币 -21 个

来自 江苏省盐城市射阳县

举报

使用道具 点亮 支持 扔鸡蛋 回复

1373492
Lv.3

专栏

发表于 2008-8-27 08:56 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 辽宁省大连市

举报

使用道具 支持 扔鸡蛋 回复

631505
Lv.3

专栏

发表于 2008-8-27 08:29 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 LAN

举报

使用道具 支持 扔鸡蛋 回复

59516
Lv.4

专栏

发表于 2008-8-27 08:20 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 辽宁省沈阳市

举报

使用道具 支持 扔鸡蛋 回复

1294168
Lv.3

专栏

发表于 2008-8-26 19:20 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市昌平区

举报

使用道具 支持 扔鸡蛋 回复

1179254
Lv.2

专栏

发表于 2008-2-15 13:56 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省中山市

举报

使用道具 支持 扔鸡蛋 回复

143063
Lv.2

专栏

发表于 2008-2-15 00:42 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省广州市

举报

使用道具 支持 扔鸡蛋 回复

1239326
Lv.2

专栏

发表于 2008-2-11 14:41 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 辽宁省抚顺市

举报

使用道具 支持 扔鸡蛋 回复

349763
Lv.3

专栏

发表于 2008-2-10 21:15 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省广州市白云区

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼 47楼
64楼 46楼
63楼 45楼
62楼 44楼
61楼 43楼
60楼 42楼
59楼 41楼
58楼 40楼
57楼 39楼
56楼 38楼
55楼 37楼
54楼 36楼
53楼 35楼
52楼  
51楼  
50楼  
49楼  
48楼  
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表