一个适合中线选股的公式

[通达信] 7295 2
设置
971405 Lv.3

专栏

发表于 2007-7-15 14:36 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
才学习编写的一个中线选股的通信达公式。忒希望各位老师朋友提出修改的意见。就叫:ZXCG
编码:
A:=(C-REF(C,1))/REF(C,1)*100;
A1:=BARSLAST( A>3);
A2:=IF(A1>0,1,0);
O1:=IF(A2=1 AND A1=1,O,REF(O,A1-1));
H1:=IF(A2=1 AND A1=1,H,HHV(H,A1));
L1:=IF(A2=1 AND A1=1,L,LLV(L,A1));
C1:=IF(A2=1 AND A1=1,C,C);
STICKLINE(A2=1 AND C1>O1,O1 ,C1 ,4 ,1),COLORRED;
STICKLINE(A2=1 AND C1< O1,O1 ,C1 ,4,1 ),COLOR00FF00;
STICKLINE(A2=1 AND C1>O1,H1 ,L1 ,1 ,1),COLORRED;
STICKLINE(A2=1 AND C1< O1,H1 ,L1 ,1 ,1),COLOR00FF00;
STICKLINE(A2=0 ,O ,C ,4 ,1),COLORYELLOW;
STICKLINE(A2=0 ,H ,L ,1 ,1),COLORYELLOW;
AMV0:=VOL*(O+C)/2;
MA5成本:SUM(AMV0,5)/SUM(VOL,5),COLORC0C0C0,LINETHICK1;
MA13成本:SUM(AMV0,13)/SUM(VOL,13),COLORCCCCFF,LINETHICK1;
MA34成本:SUM(AMV0,34)/SUM(VOL,34),COLOR00FF00,LINETHICK1;
MA60成本:SUM( AMV0,60)/SUM(VOL,60 ),COLORFF00FF,LINETHICK2;
MA90成本:SUM(AMV0,90)/SUM(VOL,90),COLORFFFF00,LINETHICK1;
MA120成本:SUM(AMV0,120)/SUM(VOL,120),COLORCC99DD,LINETHICK1;
FL:=LLV(MA5成本,2);
多空线:HHV( MA5成本,2 ),COLORFFFFFF,LINETHICK2;
杀入线:MA5成本-( FL-MA5成本 ),COLORFF0000,LINETHICK2;
K:=HIGH/CLOSE;
风险线:1/(SUM(K,1)/SUM(CLOSE,1))*(6/5),COLORRED,LINETHICK1;

使用方法如下:
1、绿色K线后如果出现黄色K线就可以逢低买入股票了;
2、黄色K线后面出现了红色K线,则股票进入强势调整;
3、在红色K线出现上影线时,抛出股票;
4、再出绿色K线时,股票进入了弱势调整。
5、如果绿色K线越大,黄色K线就越大。
6、股价突破60均线后,出现的黄色K线可信度较高。
7、均线为平均持股成本,使用方法和CYC相同。

未命名.jpg
来自 山东省青岛市

举报

使用道具 扔鸡蛋 回复

1334743
Lv.4

专栏

发表于 2012-6-8 15:50 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市

举报

使用道具 支持 扔鸡蛋 回复

1733286
Lv.6

专栏

发表于 2012-6-8 11:48 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省南充市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
2楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表