杨百万公式集(原代码)

31539 33
设置
880525 Lv.3

专栏

发表于 2007-7-15 22:24 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
分析家、大智慧L2 都可使用!
百万测底
趋势线: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1), , [00050001];
见底信号: 10, , [00030001];
买点准备: IF(趋势线<=10,50,0), , [00040001];
买入时间: IF(CROSS(趋势线,见底信号),100,0), , [00050001];

百万冲浪
(n=7, n1=21)
Var1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
Var2:=REVERSE(Var1);
Var3:=SMA(Var1,3,1);
K: SMA(Var3,3,1), , [00050001];
D: SMA(K,4,1), , [00040001];
Var4:=CROSS(D,K) AND D>80;
STICKLINE(Var4,0,110,7,0), , [000B0001];
Var5:=1/SUM(1-CLOSE/REF(CLOSE,1),)/100*VOL/WINNER(CLOSE)*OPEN;
A1: IF(Var5>100,100,IF(Var5<-100,-100,Var5));
Var6:=COUNT(CLOSE>OPEN,20);
Var7:=COUNT(CLOSE<OPEN,20);
Var8:=IF(Var6>Var7,CLOSE,HIGH);
Var9:=EMA(Var8,13);
VarA:=CLOSE-Var9;
VarB:=EMA(VarA,21);
VarC:=(HHV(CLOSE,)-LLV(CLOSE,))/SUM(ABS(CLOSE-REF(CLOSE,1)),);
VarD:=VarC*(-1);
IF(CROSS(VarB,VarC),A1+100,A1);
IF(Var5<100 AND VarA>0,-100,A1);
STICKLINE(Var5>100,0,A1,2,0), , [00010001];
STICKLINE(Var5<-100,0,A1,2,0), , [00010001];
VarE:=MA(WINNER(CLOSE),18)*100;
CROSS(VarE,2.5)*(-95), , [000B0002];
VarF:=REF(LOW,1)*0.9;
Var10:=LOW*0.9;
Var11:=(Var10*VOL+VarF*(CAPITAL-VOL))/CAPITAL;
Var12:=EMA(Var11,30);
Var13:=CLOSE-REF(CLOSE,1);
Var14:=MAX(Var13,0);
Var15:=ABS(Var13);
Var16:=SMA(Var14,7,1)/SMA(Var15,7,1)*100;
Var17:=SMA(Var14,13,1)/SMA(Var15,13,1)*100;
Var18:=BARSCOUNT(CLOSE);
Var19:=SMA(MAX(Var13,0),6,1)/SMA(ABS(Var13),6,1)*100;
Var1A:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
Var1B:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Var1C:=SMA((SMA(Var1B,4,1)-50)*2,3,1);
Var1D:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Var1E:=SMA(Var1D,4,1);
Var1F:=SMA(Var1E,3,1);
Var20:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
Var21:=Var19<=25 AND Var1A<-95 AND Var20>20 AND Var1C<-30 AND Var1F<30 AND Var12-CLOSE>=-0.25 AND Var16<22 AND Var17<28 AND Var18>50;
STICKLINE(Var21,0,75,3,0), , [00070001];
DRAWTEXT(CROSS(Var21,0.5) AND COUNT(Var21=1,10)=1,20,'百万导弹'), , [00010001];

百万金银
(n=27, n1=3,  n2=3,  n3=4)
Var1:=(CLOSE-LLV(LOW,))/(HHV(HIGH,)-LLV(LOW,))*100;
Var2:=REVERSE(Var1);
Var3:=SMA(Var1,,1);
K: SMA(Var3,,1), , [00050001];
D: SMA(K,,1), , [00040001];
Var4:=SMA(Var2,,1);
W: SMA(Var4,,1), , [00040001];
R: SMA(W,,1), , [00040001];
Var5:="YHD1-1.A#WEEK";
Var6:="YHD1-1.B#WEEK";
Var7:="YHD1-1.A#DAY";
Var8:="YHD1-1.B#DAY";
短线买: CROSS(Var7,Var8) AND Var7<25 AND Var6<30;
短线卖: CROSS(Var8,Var7) AND Var7>70 AND Var6>60;
周叉买: CROSS(Var5,Var6) AND Var5<35;
周叉卖: CROSS(Var6,Var5) AND Var6>70;
STICKLINE(短线买,0,35,7,0), , [00070001];
STICKLINE(短线卖,0,70,7,0), , [00050001];
STICKLINE(周叉买,0,35,5,0), , [00050001];
STICKLINE(周叉卖,0,95,8,0), , [00090001];

百万买卖
(n=27, n1=3,  n2=3,  n3=3)
Var1:=(CLOSE-LLV(LOW,))/(HHV(HIGH,)-LLV(LOW,))*100;
Var2:=REVERSE(Var1);
Var3:=SMA(Var1,,1);
K: SMA(Var3,,1), , [00050001];
D: SMA(K,,1), , [00040001];
YY: 0, , [00020001];
HH: 80, , [00030001];
BB: 15, , [00010001];
IF(CROSS(K,BB),50,0), , [00050001];
IF(CROSS(K,D) AND K<40,35,0), , [00050001];
IF(CROSS(D,K) AND D>75,95,0), , [00050001];

百万强弱
(n=9, n1=3,  n2=3,  n3=3)
Var1:=(CLOSE-LLV(LOW,))/(HHV(HIGH,)-LLV(LOW,))*100;
Var2:=REVERSE(Var1);
Var3:=SMA(Var1,,1);
K: SMA(Var3,,1), , [00040001];
D: SMA(K,,1), , [00040001];
J: 3*K-2*D, , [00050001];
Var4:=SMA(Var2,,1);
W: SMA(Var4,,1), , [00040001];
R: SMA(W,,1), , [00040001];
Var5:=REF(CLOSE,1);
RSI1: SMA(MAX(CLOSE-Var5,0),5,1)/SMA(ABS(CLOSE-Var5),5,1)*100, , [00050001];
Var6:=MA(WINNER(CLOSE),)*100;
CROSS(Var6,2.5)*(-45), , [00070002];
Var7:=REF(LOW,1)*0.9;
Var8:=LOW*0.9;
Var9:=(Var8*VOL+Var7*(CAPITAL-VOL))/CAPITAL;
VarA:=EMA(Var9,30);
VarB:=CLOSE-REF(CLOSE,1);
VarC:=MAX(VarB,0);
VarD:=ABS(VarB);
VarE:=SMA(VarC,7,1)/SMA(VarD,7,1)*100;
VarF:=SMA(VarC,13,1)/SMA(VarD,13,1)*100;
Var10:=BARSCOUNT(CLOSE);
Var11:=SMA(MAX(VarB,0),6,1)/SMA(ABS(VarB),6,1)*100;
Var12:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
Var13:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Var14:=SMA((SMA(Var13,4,1)-50)*2,3,1);
Var15:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Var16:=SMA(Var15,4,1);
Var17:=SMA(Var16,3,1);
Var18:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
Var19:=Var11<=25 AND Var12<-95 AND Var18>20 AND Var14<-30 AND Var17<30 AND VarA-CLOSE>=-0.25 AND VarE<22 AND VarF<28 AND Var10>50;
STICKLINE(Var19,0,35,3,0), , [00070001];
DRAWTEXT(CROSS(Var19,0.5) AND COUNT(Var19=1,10)=1,20,'百万导弹'), , [00010001];

百万趋势
(n=9, n1=3,  n2=3,  n3=3)
Var1:=(CLOSE-LLV(LOW,))/(HHV(HIGH,)-LLV(LOW,))*100;
Var2:=REVERSE(Var1);
Var3:=SMA(Var1,,1);
K: SMA(Var3,,1), , [00050001];
D: SMA(K,,1), , [00040001];
Var4:=SMA(Var2,,1);
W: SMA(Var4,,1), , [00040001];
R: SMA(W,,1), , [00040001];
YY: 0, , [00020001];
HH: 80, , [00030001];
DD: -80, , [00030001];
BB: 20, , [00010001];
-20, , [00010001];

对不起!有事,离开一会儿,还有几个稍后再发!

[ 本帖最后由 滨0103 于 2007-7-15 22:48 编辑 ]
来自 湖北省武汉市

举报

使用道具 扔鸡蛋 回复

584952
Lv.3

专栏

发表于 2010-6-9 14:24 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省汕尾市

举报

使用道具 支持 扔鸡蛋 回复

2025861
Lv.2

专栏

发表于 2010-5-3 08:32 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 辽宁省鞍山市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1339200
Lv.2

专栏

发表于 2010-5-2 14:07 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省扬州市

举报

使用道具 支持 扔鸡蛋 回复

1053281
Lv.2

专栏

发表于 2010-1-3 23:37 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 福建省福州市

举报

使用道具 支持 扔鸡蛋 回复

1945056
Lv.1

专栏

发表于 2009-12-9 23:09 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市丰台区

举报

使用道具 点亮 支持 扔鸡蛋 回复

1682961
Lv.5

专栏

发表于 2009-10-20 06:53 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省扬州市

举报

使用道具 支持 扔鸡蛋 回复

1539274
Lv.2

专栏

发表于 2009-10-10 18:20 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 内蒙古呼和浩特市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1259461
Lv.1

专栏

发表于 2008-3-25 22:57 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市

举报

使用道具 支持 扔鸡蛋 回复

715984
Lv.2

专栏

发表于 2007-9-30 11:33 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河北省保定市

举报

使用道具 支持 扔鸡蛋 回复

660722
Lv.1

专栏

发表于 2007-9-30 09:51 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 LAN

举报

使用道具 支持 扔鸡蛋 回复

1122524
Lv.1

专栏

发表于 2007-9-20 13:33 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 重庆市垫江县

举报

使用道具 支持 扔鸡蛋 回复

1043979
Lv.2

专栏

发表于 2007-9-17 00:14 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 中国

举报

使用道具 支持 扔鸡蛋 回复

1036761
Lv.1

专栏

发表于 2007-9-16 23:19 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河北省石家庄市

举报

使用道具 点亮 支持 扔鸡蛋 回复

720323
Lv.3

专栏

发表于 2007-9-16 22:36 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省菏泽市

举报

使用道具 支持 扔鸡蛋 回复

720323
Lv.3

专栏

发表于 2007-9-16 22:34 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省菏泽市

举报

使用道具 支持 扔鸡蛋 回复

1056468
Lv.2

专栏

发表于 2007-9-9 10:49 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省潍坊市

举报

使用道具 点亮 支持 扔鸡蛋 回复

608009
Lv.3

专栏

发表于 2007-8-26 11:09 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 安徽省淮北市

举报

使用道具 点亮 支持 扔鸡蛋 回复

998427
Lv.1

专栏

发表于 2007-8-25 23:23 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省深圳市福田区

举报

使用道具 支持 扔鸡蛋 回复

1042110
Lv.3

专栏

发表于 2007-8-25 08:49 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河北省沧州市

举报

使用道具 支持 扔鸡蛋 回复

1060190
Lv.1

专栏

发表于 2007-8-19 12:56 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山西省

举报

使用道具 点亮 支持 扔鸡蛋 回复

887851
Lv.2

专栏

发表于 2007-8-19 12:33 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市闵行区

举报

使用道具 支持 扔鸡蛋 回复

1045662
Lv.1

专栏

发表于 2007-8-11 01:14 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市浦东新区

举报

使用道具 支持 扔鸡蛋 回复

300619
Lv.3

专栏

发表于 2007-8-5 14:40 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 陕西省西安市

举报

使用道具 支持 扔鸡蛋 回复

811708
Lv.2

专栏

发表于 2007-7-17 16:36 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省深圳市

举报

使用道具 点亮 支持 扔鸡蛋 回复

880525
Lv.3

专栏

发表于 2007-7-16 17:05 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省武汉市

举报

使用道具 点亮 支持 扔鸡蛋 回复

761160
Lv.3

专栏

发表于 2007-7-16 16:50 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省绍兴市

举报

使用道具 支持 扔鸡蛋 回复

428534
Lv.4

专栏

发表于 2007-7-16 16:28 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 陕西省西安市

举报

使用道具 支持 扔鸡蛋 回复

347021
Lv.2

专栏

发表于 2007-7-16 13:14 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省武汉市

举报

使用道具 支持 扔鸡蛋 回复

997862
Lv.1

专栏

发表于 2007-7-16 00:18 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 新疆阿拉尔市

举报

使用道具 支持 扔鸡蛋 回复

993584
Lv.2

专栏

发表于 2007-7-15 22:48 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 云南省昆明市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼 16楼
33楼 15楼
32楼 14楼
31楼 13楼
30楼 12楼
29楼 11楼
28楼 10楼
27楼 9楼
26楼 8楼
25楼 7楼
24楼 6楼
23楼 5楼
22楼 4楼
21楼  
20楼  
19楼  
18楼  
17楼  
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表