请高手把这个公式改为分析家的

2493 0
设置
118952 Lv.3

专栏

发表于 2007-7-25 13:40 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
请高手把这个公式改为分析家的,谢谢!
买点在黄金三八线
input:K(21,1,100);
VARE:=2070231;
U1:=IF((DATE <= VARE),1,0);
VAR1:=(((CLOSE - LLV(LOW,100)) / (HHV(HIGH,100) - LLV(LOW,100))) * 200);
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=((3 * VAR2) - (2 * VAR3));
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=(EMA((((CLOSE - VAR5) / (VAR6 - VAR5)) * 100),4) * 2);
VAR8:=EMA(((0.667 * REF(VAR7,1)) + (0.333 * VAR7)),2);
VAR9:=((3 * VAR7) - (2 * VAR8));
VARA:=(POW(MA(CLOSE,5),2) + MA(CLOSE,5));
VARB:=(POW(MA(LOW,5),2) + MA(LOW,5));
VARC:=(POW(MA(HIGH,5),2) + MA(HIGH,5));
VARD:=(((((VARA - LLV(VARB,64)) / (HHV(VARC,64) - LLV(VARB,64))) * 150) + 65) - 10);
VARE:=((SMA(VARD,3,1) * 1.5) - 100);
VARF:=SMA(VARE,3,1);
VAR10:=((3 * VARE) - (2 * VARF));
VAR11:=(((HIGH + LOW) + (CLOSE * 2)) / 4);
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(((VAR11 - VAR12) * 100) / VAR13);
VAR15:=EMA(VAR14,5);
VAR16:=EMA(VAR15,13);
VAR17:=((EMA(VAR15,13) + 200) - 100);
VAR18:=EMA(VAR17,10);
VAR19:=((3 * VAR17) - (2 * VAR18));
VAR1A:=(((VAR2 + VAR7) + VARE) + VAR17);
VAR1B:=(((VAR3 + VAR8) + VARF) + VAR18);
VAR1C:=(((VAR4 + VAR9) + VAR10) + VAR19);
VAR1D:=(((HIGH + LOW) + CLOSE) / 3);
VAR1E:=((AMOUNT / VOL) / 100);
VAR1F:=((SUM(AMOUNT,5) / SUM(VOL,5)) / 100);
VAR20:=((VAR1D - MA(VAR1D,34)) / (0.015 * AVEDEV(VAR1D,34)));
VAR21:=DMA(((AMOUNT / VOL) / 100),(VOL / CAPITAL));
VAR22:=((((HIGH + LOW) + CLOSE) + VAR1D) / 4);
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(((VAR22 - VAR23) / VAR24) * 100);
VAR26:=((VAR1D - MA(VAR1D,24)) / (0.015 * AVEDEV(VAR1D,24)));
VAR27:=EMA(VAR25,5);
VAR28:=((VAR1E - MA(VAR1E,21)) / (0.015 * AVEDEV(VAR1E,21)));
VAR29:=((VAR1F - MA(VAR1F,90)) / (0.015 * AVEDEV(VAR1F,90)));
VAR2A:=(((((((VAR29 + VAR28) + VAR27) + VAR26) + VAR20) / 5) + 165) / 4);
VAR2B:=(((EMA(EMA(EMA(VAR2A,15),10),5) - 25) * 2) + VAR21);
VAR2C:=(((((VAR1A + VAR1B) + (VAR1C * 30)) / 32) / 5) - 15);
VAR2D:=EMA(VAR2C,13);
VAR2E:=(((VAR2A + VAR2C) / 2) / 1.1);
(0 - 24),POINTDOT;
50,POINTDOT;
105,POINTDOT;
A: (VAR2E * U1),LINETHICK2,colorFF00;
TR:=MAX(MAX((HIGH - LOW),ABS((REF(A,1) - HIGH))),ABS((REF(A,1) - LOW)));
VAR0:=EMA(EMA(EMA(A,2),2),2);
生命线:=HHV(VAR0,10);
B: ((((VAR2B + VAR2D) / 2) * 0.92) * U1),LINETHICK2,colorFF;
CC: ((((VAR2B + VAR2D) / 2) * 0.3018) * U1),LINETHICK2;
DD: ((((VAR2B + VAR2D) / 2) * 0.08) * U1),LINETHICK2;
VAR1N:=1070831;
U1:=IF((DATE <= VAR1N),1,0);
TR:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);
LDFU:=(((DMP * 100) / TR) * U1);
DF:=(EMA(LDFU,7) * 0.5);
VAR1:=MA(LOW,1);
VAR2:=MA(HIGH,2);
VAR3:=MA(CLOSE,2);
VAR6:=(((HHV(VAR2,9) - VAR3) / (HHV(VAR2,9) - LLV(VAR1,9))) * 100);
TR:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) * U1);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);
PDI:=(((DMP * U1) * 100) / TR);
MDI:=((DMM * 100) / TR);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),3);
【势】:=(SMA(VAR6,3,1) * U1);
魔王黄金坑: (IF((((ADX > 72) AND (PDI < 3.8)) AND (【势】 > 60)),70,118) * U1),LINETHICK2,colorFF00FF;
RSV2:=(((CLOSE - LLV(LOW,20)) / (HHV(HIGH,20) - LLV(LOW,20))) * 100);
K2:=SMA(RSV2,3,1);
D2:=SMA(K2,3,1);
J2:=((3 * K2) - (2 * D2));
动力线:=EMA(J2,6);
筹码线:=IF((DATE < 1090501),(ABS(((CLOSE - LLV(LOW,265)) / LLV(LOW,265))) * 100),0);
Q:=(((((MA(筹码线,1) + MA(筹码线,3)) + MA(筹码线,5)) + MA(筹码线,7)) + MA(筹码线,9)) / 5);
神偷指数:=(EMA(((100 * (CLOSE - LLV(LOW,36))) / (HHV(HIGH,36) - LLV(LOW,36))),K) / 4);
暗器22:=IF(CROSS(筹码线,动力线),(0 - 55),0);
暗器23:=IF(CROSS(神偷指数,动力线),(0 - 55),0);
QQ:=(暗器22 OR 暗器23);
DRAWICON(((QQ > 0) AND U1),神偷指数,1);
TJ:=IF((STRCMP(USERNAME,'yngs') = 0),1,0);
相对胜率:=ABS((((COST(50) - CLOSE) / CLOSE) * 100));
庄筹线:=EMA((WINNER(CLOSE) * 70),5);
A1:=(((CLOSE - REF(CLOSE,13)) / CLOSE) * 100);
飞狐神探:=A1;
有短线资金入场:IF((((相对胜率 > 30) AND (庄筹线 < 3)) AND (A1 <= (0 - 10))),A1,(0 - 23)),LINETHICK3,colorFF99FF;
VAR1N:=20101232;
U1:=IF((DATE <= VAR1N),1,0);
异动量:(IF(((((VOL > REF(VOL,1)) AND (REF(VOL,1) > REF(VOL,2))) AND (CLOSE < REF(CLOSE,1))) AND (HIGH < (SUM((((HIGH + LOW) / 2) * VOL),5) / SUM(VOL,5)))),(0 - 10),(0 - 20)) * U1),LINETHICK2,colorFFFF;
VARQ1:=REF(((((LOW + OPEN) + CLOSE) + HIGH) / 4),1);
VARQ2:=(SMA(ABS((LOW - VARQ1)),13,1) / SMA(MAX((LOW - VARQ1),0),10,1));
VARQ3:=EMA(VARQ2,10);
VARQ4:=LLV(LOW,33);
VARQ5:=(EMA(IF((LOW <= VARQ4),VARQ3,0),3) * 1);
主力进场:STICKLINE((VARQ5 > REF(VARQ5,1)),0,VARQ5,7,0),colorFFFF00;
VAR1:=(((CLOSE - LLV(LOW,24)) / (HHV(HIGH,24) - LLV(LOW,24))) * 100);
VAR2:=SMA(VAR1,3,1);
VAR3:=(SMA(VAR2,3,1) * VAR1);
VAR4:=SMA(VAR3,3,1);
VAR9:=(CROSS(VAR4,VAR3) AND (VAR3 > 80));
AA:=(SMA(ABS((LOW - REF(LOW,1))),30,1) / SMA(MAX((LOW - REF(LOW,1)),0),30,1));
TP:=(EMA(IF((LOW <= LLV(LOW,30)),AA,0),3) * 10);
VAR26:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VAR36:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VAR46:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VAR56:=(((VAR26 + (2 * VAR36)) + (3 * VAR46)) / 6);
VAR66:=MA(VAR56,3);
VAR76:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
VAR86:=SMA(VAR76,2,1);
VAR96:=SMA(VAR86,2,1);
VARA:=((3 * VAR86) - (2 * VAR96));
关注:STICKLINE((CROSS(VARA,VAR96) AND (COUNT((VAR66 < (0 - 9)),2) >= 1)),1,40,8,0),LINETHICK3,colorFFFFFF;
来自 陕西省宝鸡市

举报

使用道具 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

优惠券
优惠券
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表