请高手把大智慧指标改成分析家的

3304 6
设置
128518 Lv.3

专栏

发表于 2007-7-25 16:25 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
公式原码在这里!!!!
DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19)),COLORwhite;
DEA:=EMA(DIFF,9),COLORf00ff0 ;
MACD:=0.90*(DIFF-DEA), COLORSTICK;
tj:=(diff>=dea);
tj1:=(diff>=0);

stickline(tj,h,l,0.5,0),COLORyellow;
stickline(tj,o,c,4,0),COLORyellow;
stickline(tj1 and tj,h,l,0.5,0),colorf00ff0;
stickline(tj1 and tj,o,c,4,1),colorf00ff0;
stickline(diff<dea,h,l,0.5,0),colorf0f000;
stickline(diff<dea,o,c,4,0),colorf0f000;

Var1:=(CLOSE*2+HIGH+LOW)/4;
SK:= EMA(Var1,13)-EMA(Var1,73);
SD:= EMA(SK,2);
drawtext((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 ) or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)) ,l*0.99,'短线'),colorred;
stickline((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 ) or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)),h,l,0.5,0),colorred;
stickline((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 ) or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)),o,c,10,1),linethick3,colorred;

MA1:=MA(CLOSE,15);
MA6:MA(C,5),COLORWHITE;
MA18:MA(C,13),COLORGREEN;
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
A:=REF(C,BARSLAST(HD)); B:=REF(L,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
顶:IF(T1,A,A),COLORYELLOW,POINTDOT;
底:IF(T2,B,B),COLORGREEN,POINTDOT;

加码价:=((c-ref(ma18,1))/18+ma18)*1.004;
加码条件:=cross(c,加码价) and 加码价>ref(加码价,1);
黄K加码:IF(加码条件,l,h),coloryellow,POINTDOT;
STICKLINE(加码条件,h,l,0,1),coloryellow,linethick2;
STICKLINE(加码条件,o,c,4,1),coloryellow,linethick2;

买进价:=((c-ref(ma6,1))/6+ma6)*1.004;
买进条件:=cross(c,买进价) and 买进价>ref(买进价,1);
白K买进:IF(买进条件,l,h),COLORWHITE,POINTDOT;
STICKLINE(买进条件,h,l,0,1),colorwhite,linethick2;
STICKLINE(买进条件,o,c,4,1),colorwhite,linethick2;
来自 山东省济南市

举报

使用道具 扔鸡蛋 回复

1221630
Lv.4

专栏

发表于 2008-10-1 23:13 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 云南省昆明市

举报

使用道具 支持 扔鸡蛋 回复

195491
Lv.3

专栏

发表于 2007-7-26 11:25 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省潍坊市

举报

使用道具 支持 扔鸡蛋 回复

128518
Lv.3

专栏

发表于 2007-7-26 09:01 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省济南市

举报

使用道具 支持 扔鸡蛋 回复

205399
Lv.3

专栏

发表于 2007-7-26 08:13 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省洛阳市西工区

举报

使用道具 点亮 支持 扔鸡蛋 回复

128518
Lv.3

专栏

发表于 2007-7-26 05:21 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省济南市

举报

使用道具 支持 扔鸡蛋 回复

128518
Lv.3

专栏

发表于 2007-7-25 16:28 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省济南市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
7楼
6楼
5楼
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表