庄家显形--通达信--学习求助帖

[其 他] 2696 2
设置
1538034 Lv.2

专栏

发表于 2009-6-20 11:50 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
本人对指标的研究很肤浅现在还有很多问题不能解决.向老师们请教:请高手把通达信指标改成大智慧L2指标并在出现“买”点红柱时写选股公式!
资金:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3)/4;
STICKLINE((资金>23.16),0,23.16,5,0),{COLORGREEN},COLOR008CFF,LINETHICK2;
三天内卖:IF(资金>23.16,资金,0),COLOR0000FF;
顶部:23;
AA:=1;
BB:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
CC:=IF(((((AMOUNT / CLOSE) / (HHV(AMOUNT,9) / HHV(CLOSE,9))) * 100) > 100),100,(((AMOUNT / CLOSE) / (HHV(AMOUNT,9) / HHV(CLOSE,9))) * 100));
DD:=(BB / CC);
价异动排序:=IF(AA,(DD / REF(DD,1)),0),STICK,COLOR0000FF;
EE:=(CC / BB);
量异动排序:=IF(AA,(EE / REF(EE,1)),0),STICK,COLORFFFF00;
AAA:=((EMA(CLOSE,5) - REF(EMA(CLOSE,5),1)) / REF(EMA(CLOSE,5),1));
BBB:=((EMA(INDEXC,5) - REF(EMA(INDEXC,5),1)) / REF(EMA(INDEXC,5),1));
CCC:=REF(HHV(CLOSE,120),1);
DDD:=REF(LLV(CLOSE,120),1);
WW:=((100 * (CLOSE - DDD)) / (CCC - DDD));
今日资金流:=(AMOUNT/100000000);
五日资金流:=(EMA(今日资金流,5)/REF(EMA(今日资金流,5),5));
庄股:=((((((五日资金流 >= 2) AND (AAA > BBB)) AND (WW < 35)) AND AA) AND (BARSCOUNT(CLOSE) > 30)) OR (((((五日资金流 >= 2) AND (AAA > BBB)) AND (WW < 100)) AND AA) AND (BARSCOUNT(CLOSE) < 50)));
庄家显形:IF(庄股,40,0),LINETHICK1,COLORFF00FF;
DRAWTEXT(庄股,33,'庄');
ZF:=(HHV(HIGH,30)-LLV(LOW,30))/LLV(LOW,30);
CQ:=REF(ZF,1)<=0.3;
GL:=BARSCOUNT(CLOSE)>30;
TP:=CLOSE>=REF(HHV(HIGH,30),1);
启动:CQ AND GL AND TP,LINETHICK3{,COLOR00FF00},COLOR9DFFFF;
STICKLINE(启动,0,6,7,0),COLOR00BBFF;
DRAWTEXT(启动,-15,'拉'),COLORFFAA66;
庄筹估算:=EMA(WINNER(C)*70,5);
散筹估算:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,3);{5}
控庄估算:=散筹估算- 庄筹估算;
启动线:=(HHV(HIGH,26)+LLV(LOW,26))/2;
启动快线:=(HHV(HIGH,9)+LLV(LOW,9))/2;
阻力一:=REF((启动线+启动快线)/2,26);
阻力二:=REF((HHV(HIGH,52)+LLV(LOW,52))/2,26);
打压区:STICKLINE(庄筹估算<散筹估算 AND 庄筹估算<控庄估算,-1,1,10,0),COLORWHITE;
吸筹区:STICKLINE(庄筹估算>=控庄估算 AND 庄筹估算<散筹估算 OR (控庄估算<=0 ) OR (控庄估算<=0 AND  (C<阻力一 OR C<阻力二)) OR (控庄估算<=0 AND (启动线<阻力一 OR 启动线<阻力二)),-1,1,10,0),COLORGREEN;
拉升区:STICKLINE(控庄估算<=0  AND 启动线>=阻力一 AND 启动线>=阻力二,-5,1,10,0),COLOR0000FF;

VAR8:=DYNAINFO(5);
VAR9:=BARSCOUNT(HIGH);
VAR10:=(SMA((HIGH / HHV(CLOSE,120)),3,1) * 100);
VAR11:=IF((VAR9 > 20),VAR10,0);
VAR12:=IF((HIGH < VAR8),0,IF((LOW > VAR8),1,(((VAR8 - HIGH) + 0.009) / ((LOW - HIGH) + 0.009))));
VAR13:=(DMA(VAR12,(VOL / CAPITAL)) * 60);
VAR14:=IF((((VAR13 > 0) AND (VAR13 > REF(VAR13,1))) AND (VAR11 >= 88)),VAR13,0);
VAR15:=((3 * SMA((((CLOSE - HHV(HIGH,27)) / (LLV(LOW,27) - HHV(HIGH,27))) * 100),5,1)) - (2 * SMA(SMA((((HIGH - HHV(HIGH,27)) / (LLV(LOW,27) - HHV(HIGH,27))) * 100),5,1),3,1)));
VAR16:=EMA(VAR15,8);
VAR17:=((3 * SMA((((HIGH - HHV(HIGH,55)) / (LLV(LOW,55) - HHV(HIGH,55))) * 100),5,1)) - (2 * SMA(SMA((((HIGH - HHV(HIGH,55)) / (LLV(LOW,55) - HHV(HIGH,55))) * 100),5,1),3,1)));
VAR18:=(EMA(VAR17,3) - 10);
出仓区:STICKLINE(((VAR14 > 0) AND ((VAR18 < 20) OR ((VAR18 > REF(VAR18,1)) AND (VAR18 < 50)))),0,30,1,0),COLORFFAA66;
机构出仓区:0,COLORFFAA66;

Z_J1:=EMA(C,2)-EMA(C,150);
Z_J2:=EMA(Z_J1,100);
Z_J3:=2*(Z_J1-Z_J2);
Z_J4:=POW(Z_J3,3)*0.1+POW(Z_J3,1);
主流资金:=IF(Z_J3>0.1,Z_J4,0)*2.5,COLORGREEN;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),10,1)/SMA(ABS(CLOSE-LC),10,1)*100,COLOR9900FF;
低位金叉:=CROSS(RSI1,50) AND( 主流资金>REF(主流资金,1));
DRAWTEXT(低位金叉,-15,' 买'),COLORYELLOW;
STICKLINE(低位金叉,-0.1,-22,1,0),COLORRED,LINETHICK1;
STICKLINE(低位金叉,-20,-25,1,0),COLORFF9900,LINETHICK1;
QQ截图未命名8.png
来自 陕西省咸阳市

举报

使用道具 扔鸡蛋 回复

2138807
Lv.2

专栏

发表于 2010-12-4 00:01 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖南省长沙市

举报

使用道具 支持 扔鸡蛋 回复

1548735
Lv.3

专栏

发表于 2009-6-20 22:20 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省丽水市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
2楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表