求助数字K线公式的“K线里的数字”是什么意思

[大智慧] 22806 1
设置
1477398 Lv.0

专栏

发表于 2009-11-20 12:38 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
理想论坛的老师及本论坛的程序高手:您们好!
烦请帮我解释一下:
第一:在K线中画{彩色牛K};{兰色熊K}分别表示什么意思
第二:K线中的数字(0、1、2、3、4、5、6)分别表示什么意思。
“K线中的数字(0、1、2、3、4、5、6)”源码在本公式哪个地方编写的,引用了一个什么函数。
顺祝工作顺利,身体安康!!!


76M)_NOG3V9[B{]7NTPA%Z4.jpg




{一、数字K线源码}

DRAWTEXTREL(16,950,STKLABEL+' ※'+STKNAME+' '+BKNAME),LINETHICK2,COLOR00FFFF;
N:=20;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N));
量能饱和度:=IF(SAT>1,1,SAT)*100;
DRAWTEXTABS(30,86,'●量能饱和度:'+NUMTOSTRN(量能饱和度,2)+'%'),LINETHICK2,COLORred;
DRAWRECTREL(1,83,18,382,RGB(30,30,30)),COLORWHITE;
AAA:=量能饱和度<=10;
BBB:=量能饱和度>10 AND 量能饱和度<=20;
CCC:=量能饱和度>20 AND 量能饱和度<=30;
DDD:=量能饱和度>30 AND 量能饱和度<=50;
EEE:=量能饱和度>50 AND 量能饱和度<=70;
FFF:=量能饱和度>70 AND 量能饱和度<=80;
GGG:=量能饱和度>80 AND 量能饱和度<=90;
HHH:=量能饱和度>90;
IF BARSTATUS=2 AND AAA THEN BEGIN DRAWRECTREL(3,350,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND BBB THEN BEGIN DRAWRECTREL(3,320,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND CCC THEN BEGIN DRAWRECTREL(3,290,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND DDD THEN BEGIN DRAWRECTREL(3,230,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND EEE THEN BEGIN DRAWRECTREL(3,170,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND FFF THEN BEGIN DRAWRECTREL(3,140,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND GGG THEN BEGIN DRAWRECTREL(3,110,16,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND HHH THEN BEGIN DRAWRECTREL(3,85,16,380,RGB(255,0,0));
END;
gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
今日阻力:=REF(明日阻力, 1);
今日支撑:=REF(明日支撑, 1);
STICKLINE(DISPSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,30,0),Color0000FF;
STICKLINE(DISPSTATUS=2 and c<今日阻力,今日阻力,今日阻力,30,0),Color00FF00;
STICKLINE(DISPSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,30,0),ColorFF00FF;
STICKLINE(DISPSTATUS=2 and c<今日支撑,今日支撑,今日支撑,30,0),ColorFF0000;
DRAWTEXTREL(406,117,'---------------------------------------'),ColorFFFFFF;
IF BARSTATUS=2 and c>=今日支撑 THEN   
DRAWTEXTREL(408,147,'◇今日支撑:'+NUMTOSTRN(今日支撑,2)),colorred;
IF BARSTATUS=2 and c<今日支撑 THEN   
DRAWTEXTREL(408,147,'◇今日支撑:'+NUMTOSTRN(今日支撑,2)),colorred;
IF BARSTATUS=2 and c>=今日阻力 THEN   
DRAWTEXTREL(408,187,'◇今日阻力:'+NUMTOSTRN(今日阻力,2)),Color0000FF;
IF BARSTATUS=2 and c<今日阻力 THEN   
DRAWTEXTREL(408,187,'◇今日阻力:'+NUMTOSTRN(今日阻力,2)),Color00FF00;
IF BARSTATUS=2 and c>=明日支撑 THEN   
DRAWTEXTREL(510,147,'  ◇明日支撑:'+NUMTOSTRN(明日支撑,2)),Color00FFFF;
IF BARSTATUS=2 and c<明日阻力 THEN   
DRAWTEXTREL(510,187,'  ◇明日阻力:'+NUMTOSTRN(明日阻力,2)),Color00FFFF;
DRAWTEXTREL(406,217,'===================='),ColorFFFFFF;

DRAWTEXTREL(480,95,'〖主图专用〗'),color9ACD32;

IF BARSTATUS=2 and v>ref(v,1) and ma(v,5)>ref(ma(v,5),1) THEN
DRAWTEXTREL(698,950,'※ 今日成交量大于昨日,且有继续增大趋势!'),LINETHICK3,Color8285FF;
IF BARSTATUS=2 and v<ref(v,1) and ma(v,5)>ref(ma(v,5),1) THEN
DRAWTEXTREL(698,950,'※ 今日成交量小于昨日,但有放大迹象!'),LINETHICK3,Color8285FF;
IF BARSTATUS=2 and v>ref(v,1)and ma(v,5)<ref(ma(v,5),1) THEN
DRAWTEXTREL(698,950,'※ 今日成交量大于昨日, 但有缩小迹象!'),LINETHICK3,Color8285FF;
IF BARSTATUS=2 and v<ref(v,1)and ma(v,5)<ref(ma(v,5),1) THEN
DRAWTEXTREL(698,950,'※ 今日成交量小于昨日,且有缩小迹象!'),LINETHICK3,Color8285FF;
下档线:=(((CLOSE - LLV(LOW,13))/(HHV(HIGH,13) - LLV(LOW,13))) * 100);
aRSV:=SMA(下档线,3,1);
aK:=SMA(aRSV,3,1);
aD:=((3 * aRSV) - (2 * aK));
aJ12:=(((CLOSE - LLV(LOW,55))/(HHV(HIGH,55) - LLV(LOW,55))) * 100);
aRSV24:=SMA(aJ12,3,1);
aK24:=SMA(aRSV24,3,1);
aD24:=((3 * aRSV24) - (2 * aK24));
撑压位:=IF(CROSS(aD24,aD),HIGH,REF(HIGH,BARSLAST(CROSS(aD24,aD))));
底:=LLV(HIGH,30){,COLOR00FF00,LINETHICK2};
STICKLINE(BARSTATUS=2,撑压位,撑压位,30,1),LINETHICK1,COLORFFFFFF;
DRAWTEXT(BARSTATUS=2,撑压位,'撑压'),COLORFFFFFF,VALIGN1;
STICKLINE(BARSTATUS=2,底,底,30,1),COLOR00FF00,LINETHICK1;
DRAWTEXT(BARSTATUS=2,底,'底线'),COLOR00FF00,VALIGN0;
AA05:MA(C,5),colorff00ff,linethick1;
五日乖离率:=(c-AA05)/AA05*100;
BB05:=atan((aa05/ref(aa05,1)-1)*100)*180/3.1416;
速度5:=sma(ema((AA05-ref(AA05,1))/ref(AA05,1),3)*100,3,1);
加速度5:ema((速度5-ref(速度5,1)),3),linethick0;
{STICKLINE(BB05>30 and AA05>ref(AA05,1),AA05,REF(AA05,1),8,1),colorff00ff;}
AA10:MA(C,10),coloryellow;
AA20:=MA(c,20);
BB10:=atan((aa10/ref(aa10,1)-1)*100)*180/3.1416;
{STICKLINE(BB05<0 and AA05<ref(AA05,1),AA05,REF(AA05,1),3,1),colorcyan;}
AA30:MA(C,30),colorwhite;
三拾日乖离率:(c-AA30)/AA30*100,linethick0;
Var1:=(AA20-AA30)>ref((AA20-AA30),1) and AA20>ref(aa20,1) and AA30>ref(AA30,1);
Var2:=(AA30-AA20)<ref((AA30-AA20),1) and AA20<ref(aa20,1) and AA30<ref(AA30,1);
BB30:=atan((aa30/ref(aa30,1)-1)*100)*180/3.1416;
{STICKLINE(BB30>15 and AA30>ref(AA30,1),AA30,REF(AA30,1),8,1),colorff00ff;}
强势狙击:=filter(BB30>30 and BB10>45 and cross(BB05,60),10);
加仓:=filter(count(cross(BB05,30),5)>=1 and AA05>ref(aa05,1) and 三拾日乖离率>ref(三拾日乖离率,1) and AA10>ref(AA10,1)
and 加速度5>ref(加速度5,1) and 速度5>ref(速度5,1),10) ;
清仓:=filter(count(cross(30,BB05),5)>=1 and (c>AA30 or O>AA30) and AA05<ref(aa05,1) and 三拾日乖离率<ref(三拾日乖离率,1) and AA10<ref(AA10,1),10);
drawtext(加仓,low*0.98,'←加仓'),colorred;
JC:=cross(0,五日乖离率) and 三拾日乖离率<ref(三拾日乖离率,1) and AA10>ref(AA10,1) ;
减仓:=filter(JC,10);
MR:=count(cross(五日乖离率,0),3)>=1 and 三拾日乖离率>ref(三拾日乖离率,1) and AA05>ref(AA05,1) and (c/ref(c,1)-1)*100>5 and ref(c,1)<AA30;
买入:=filter(MR,10);
drawtext(减仓,high*1.02,'←减仓'),colorcyan;
drawtext(买入,low*0.98,'←买入'),coloryellow;
drawtext(清仓 ,high*1.02,'←清仓'),COLORGREEN;
drawtext(强势狙击,LOW*0.98,'←强势狙击'),coloryellow;
Var21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
Var3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(Var21+Var3)/AMOUNT*VOL*100*50;
DRAWTEXT(MV>6 and l<=llv(l,10),l*0.96,'←异动'),colorcyan;
aa:=if(c>=ref(c,3),1,0);
bb:=if(c>=ref(c,5),1,0);
cc:=if(c>=ref(c,7),1,0);
dd:=if(c>=ref(c,8),1,0);
ee:=if(c>=ref(c,13),1,0);
ff:=if(c>=ref(c,21),1,0);
gz2:=aa+bb+cc+dd+ee+ff;
Var11:=EMA(CLOSE,3)-EMA(CLOSE,6)-(EMA(CLOSE,6)-EMA(CLOSE,12))*(-100);
Var12:=EMA(Var11,3);
Var5:=CROSS(Var11,Var12);
Var6:=CROSS(Var12,Var11);
STICKLINE(C>=O,l,H,0,0),COLOR0000FF,LAYER2;
STICKLINE(C<O,l,H,0,0),COLORFFFF00,LAYER2;
STICKLINE(C>=O,O,C,10,1),COLOR0000FF,LAYER2;
STICKLINE(C<O,O,C,8,0),COLORFFFF00,LAYER2;
STICKLINE(Var6,OPEN,CLOSE,8,0),COLORBLUE,LAYER0;{兰色熊K}
STICKLINE(Var5,OPEN,CLOSE,5,0),COLORYELLOW,LAYER0;{彩色牛K}
STICKLINE(Var5,OPEN,CLOSE-(CLOSE-OPEN)*0.33,5,0),COLORaaccdd,LAYER0;{彩色牛K}
STICKLINE(Var5,OPEN,CLOSE-(CLOSE-OPEN)*0.66,5,0),COLORRED,LAYER0;{彩色牛K}
DRAWTEXT(c>0,(O+C)/2,NUMTOSTRN(gz2,0 )),coloryellow,LAYER0,ALIGN1,VALIGN0,LINETHICK1;{彩色牛K};

[ 本帖最后由 致远2018 于 2009-11-22 19:15 编辑 ]

附件

111.jpg

举报

使用道具 扔鸡蛋 回复

15863
Lv.4

专栏

发表于 2014-9-4 07:47 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省南阳市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表