请高手老师帮忙。买入做为选股条件。谢谢!周末愉快!

[通达信] 1539 4
设置
1618232 Lv.3

专栏

发表于 2009-11-21 09:18 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
CCED :=(HIGH + LOW + CLOSE)/3;
CC1:=(CCED-MA(CCED,M))/(0.015*AVEDEV(CCED,M));
C1:=SMA(CC1,3,1);
C2:=SMA(C1,3,1);
C3:=3*C1-2*C2;
CB1:=EMA(C3,5);
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
RSI:=(RSI1-50)*5;
R1:=SMA(RSI,3,1);
D1:=SMA(R1,3,1);
J1:=3*R1-2*D1;
RR1:=EMA(J1,5);
RR2:=REF(RR1,1);
RR:=RR1>RR2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
K1:=(K-50)*5;
K2:=SMA(K1,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
买入1:=RR AND NOT(REF(RR,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100;
N:=20;JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000);
DX:=MA(DDX,5)*N;
DDX1:=SMA(DX,3,1);
DDX2:=SMA(DDX1,3,1);
买入2:=DDX>0 AND MA(V,5)>MA(MA(V,5),5) AND CROSS(DDX1,DDX2);
VA6:=(CLOSE+HIGH+LOW)/3;
VA8:=LLV(LOW,34);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
生命线:=EMA(VARD,1);
买入3:=CROSS(VARC,生命线) AND VARC>VARD AND VARC<55 AND C>O;
买入A:=买入1 AND 买入2;
买入B:=买入2 AND 买入3;
买入C:=买入1 AND 买入3;
卖出1:=H=HHV(H,10) AND (H-C)/C>0.005 AND (REF(CLOSE,1)-REF(CLOSE,30))/REF(CLOSE,30)>0.05;
卖出2:=H=HHV(HIGH,25) AND C<REF(C,1);
VAR2:=SMA(ABS(REF((L+O+C+H)/4,1)-H),13,1)/SMA(MAX(REF((L+O+C+H)/4,1)-H,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=HHV(H,28);
VAR5:=EMA(IF(H>=VAR4,VAR3,0),3)*(-0.1);
卖出3:=VAR5<REF(VAR5,1);
V1:=MA(C,3)=HHV(MA(C,3),10);
V2:=MA(C,3)>MA(C,5);
V3:=MA(V,5)>MA(V,10)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
卖出4:=V1 AND V2 AND V3 AND V4;
卖出A:=卖出3 AND 卖出4;
买入:买入A OR  买入B OR 买入C,COLORRED;
卖出:卖出1 OR 卖出2 OR 卖出A,STICK,COLORGREEN;
来自 广东省珠海市

举报

使用道具 扔鸡蛋 回复

1851290
Lv.3

专栏

发表于 2009-11-21 10:09 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山西省长治市

举报

使用道具 支持 扔鸡蛋 回复

1334163
Lv.7

专栏

发表于 2009-11-21 10:06 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

1685910
Lv.3

专栏

发表于 2009-11-21 09:51 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖南省邵阳市

举报

使用道具 支持 扔鸡蛋 回复

1618232
Lv.3

专栏

发表于 2009-11-21 09:19 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省珠海市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
5楼
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表