(一发老师的分时涨停)请老师们帮写个选股公式

[飞 狐] 2213 0
设置
1171571 Lv.3

专栏

发表于 2009-11-21 19:54 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
一发老师的分时涨停,请老师们帮写个选股公式,公式如下;

zq:=DATATYPE;
r1:=OPENMINUTES(TIME);
zs:=ref(c,r1);
zsr:=DYNAINFO(3);
j:=SUM(C*V,SUMBARS(VOL,CAPITAL))/SUM(V,SUMBARS(VOL,CAPITAL));
jj:=SUM(C*V,0)/SUM(V,0);
jj1:=SUM(C*V,r1)/SUM(V,r1);
jja:=if(zq=6,jj,if(zq=1,jj1,jj));
zsa:=if(zq=6,zsr,if(zq=1,zs,zsr));
cr:=if(zq=6,c>0,if(zq=1,r1>1,c>0));
PARTLINE(cr,zsa),COLORGRAY,POINTDOT;
dk:=(SMA(C,2,1)-SMA(C,6,1))*2.1;
STICKLINE(dk>0and jja>0 ,zsa,ZSa+dk,0.1,0),Color5050FF;
STICKLINE(dk<=0and jja>0 ,zsa,ZSa+dk,0.1,0),ColorCyan;
if datatype>=0 then exit;
rc:=DYNAINFO(3);
q:=datacount;
hh:=DYNAINFO(5);
LL:=DYNAINFO(6);
f:=max(hh-rc,rc-LL);
ff:=f/rc*100;
q1h:=if(ff<1,0.9898*rc,rc-f*1.02);
q1l:=if(ff<1,0.9798*rc,rc-2*f*1.016);
FILLRGN(1,q1h,q1l),colorblack;
R:=INDEXC;
Rh:=hhv(r,0);
RL:=LLv(r,0);
Rb:=(q1h-q1l)/(RH[q]-RL[q]);
Ry:=(q1h+q1l-rb*(RH[q]+RL[q]))/2;
r*rb+ry,COLORFF00FF;
(SUM(r*INDEXV,r)/SUM(INDEXV,r))*rb+ry,COLOR00FF00;
流通:=FINANCE(7)/10000;
qj1:=CAPITAL/800; qj2:=CAPITAL/1000; qj3:=CAPITAL/1500; qj4:=CAPITAL/2000; qj5:=CAPITAL/4000; qj6:=CAPITAL/6000; qj7:=CAPITAL/8000; qj8:=CAPITAL/10000;qj9:=ESTDATA(8)/13000;
XS:=IF(CAPITAL<1,qj9,IF(流通<1,qj1,IF(流通>=1 AND 流通<5,qj2,IF(流通>=5 AND 流通<10,qj3,IF(流通>=10 AND 流通<20,qj4,IF(流通>=20 AND 流通<40,qj5,IF(流通>=40 AND 流通<60,qj6,IF(流通>=60 AND 流通<=100,qj7,IF(流通>=100,qj8,0)))))))));
XS1:=XS*1.618;
主动买入:=SUM(BUYVOL,0);
主动卖出:=SUM(SELLVOL,0);
特单买:=IF(BUYVOL>XS1,BUYVOL,0);
特单卖:=IF(SELLVOL>XS1,SELLVOL,0);
大单买:=IF(BUYVOL>XS and BUYVOL<=XS1,BUYVOL,0);
大单卖:=IF(SELLVOL>XS and SELLVOL<=XS1,SELLVOL,0);
小单买:=IF(BUYVOL<=XS,BUYVOL,0);
小单卖:=IF(SELLVOL<=XS,SELLVOL,0);
特单买入:=SUM(特单买,0);
特单卖出:=SUM(特单卖,0);
大单买入:=SUM(大单买,0);
大单卖出:=SUM(大单卖,0);
小单买入:=SUM(小单买,0);
小单卖出:=SUM(小单卖,0);
大单差:=(特单买入+大单买入)-(特单卖出+大单卖出);
k1:=hhv(h,0);
k2:=llv(l,0);
k3:=barslast(OPENMINUTES(TIME)<=240);
t1:=barslast(OPENMINUTES(TIME)<=60);
DRAWSL(OPENMINUTES(TIME)>=60,ref(k1,t1),0,k3,2),LINEDOT;
DRAWSL(OPENMINUTES(TIME)>=60,ref(k2,t1),0,k3,2),LINEDOT;
DRAWICON(OPENMINUTES(TIME)>60 and cross(c,ref(k1,t1)+0.001),ref(k1,t1),1);
VARA:=IF(BUYVOL<=REF(ASKVOL(1),1)+REF(ASKVOL(2),1)+REF(ASKVOL(3),1) AND CLOSE>=REF(ASKPRICE(3),1),BUYVOL,0);
上扫单:=SUM(INTPART(IF(VARA>XS AND VARA<XS1,BUYVOL,0)),0);
VARB:=IF(SELLVOL<=REF(BIDVOL(1),1)+REF(BIDVOL(2),1)+REF(BIDVOL(3),1) AND CLOSE<=REF(BIDPRICE(3),1),SELLVOL,0);
下扫单:=SUM(INTPART(IF(VARB>XS AND VARA<XS1,SELLVOL,0)),0);
总:=(特单买入+特单卖出+大单买入+大单卖出+小单买入+小单卖出+上扫单+下扫单);
DRAWTEXTEX(DYNAINFO(7),1,20,20,'■ 大单买: '+NUMTOSTR(特单买入,0)),LINETHICK2,colorFF;
DRAWTEXTEX(DYNAINFO(7),1,260,20,'占:'+NUMTOSTR(FLOOR(特单买入/总*100),0)+' %'),LINETHICK2,colorFF;
DRAWTEXTEX(DYNAINFO(7),1,20,80,'■ 大单卖: '+NUMTOSTR(特单卖出,0)),LINETHICK2,colorFF00;
DRAWTEXTEX(DYNAINFO(7),1,260,80,'占:'+NUMTOSTR(FLOOR(特单卖出/总*100),0)+' %'),LINETHICK2,colorFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,140,'■ 中单买: '+NUMTOSTR(大单买入,0)),LINETHICK2,colorFF;
DRAWTEXTEX(DYNAINFO(7),1,260,140,'占:'+NUMTOSTR(FLOOR(大单买入/总*100),0)+' %'),LINETHICK2,colorFF;
DRAWTEXTEX(DYNAINFO(7),1,20,200,'■ 中单卖: '+NUMTOSTR(大单卖出,0)),LINETHICK2,colorFF00;
DRAWTEXTEX(DYNAINFO(7),1,260,200,'占:'+NUMTOSTR(FLOOR(大单卖出/总*100),0)+' %'),LINETHICK2,colorFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,260,'■ 小单买: '+NUMTOSTR(小单买入,0)),LINETHICK2,colorFF00FF;
DRAWTEXTEX(DYNAINFO(7),1,260,260,'占:'+NUMTOSTR(FLOOR(小单买入/总*100),0)+' %'),LINETHICK2,colorFF00FF;
DRAWTEXTEX(DYNAINFO(7),1,20,320,'■ 小单卖: '+NUMTOSTR(小单卖出,0)),LINETHICK2,colorFFFF00;
DRAWTEXTEX(DYNAINFO(7),1,260,320,'占:'+NUMTOSTR(FLOOR(小单卖出/总*100),0)+' %'),LINETHICK2,colorFFFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,380,'■ 上扫单: '+NUMTOSTR(上扫单,0)),LINETHICK2,colorFF;
DRAWTEXTEX(DYNAINFO(7),1,260,380,'占:'+NUMTOSTR(FLOOR(上扫单/总*100),0)+' %'),LINETHICK2,colorFFFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,440,'■ 下扫单: '+NUMTOSTR(下扫单,0)),LINETHICK2,colorFFFF00;
DRAWTEXTEX(DYNAINFO(7),1,260,440,'占:'+NUMTOSTR(FLOOR(下扫单/总*100),0)+' %'),LINETHICK2,colorFFFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,500,'■ 大单差: '+NUMTOSTR(大单差,0)),LINETHICK2,colorFF00;
DRAWTEXTEX(DYNAINFO(7),1,260,500,'占:'+NUMTOSTR(大单差/(大单买入+大单卖出)*100,0)+' %'),LINETHICK2,colorFF00;
DRAWTEXTEX(DYNAINFO(7),1,20,560,'■ 多空差: '+NUMTOSTR((主动买入-主动卖出),0)),LINETHICK2,colorFFFF;
DRAWTEXTEX(DYNAINFO(7),1,260,560,'占:'+NUMTOSTR((主动买入-主动卖出)/总*100,0)+' %'),LINETHICK2,colorFFFF;
//
来自 四川省成都市

举报

使用道具 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表