送上我的DDE组合预警,附预警分析及飞狐的2个副图指标(源码)

22164 57
设置
1862567 Lv.4

专栏

发表于 2009-11-22 11:52 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
飞狐的2个副图指标是最近看飞狐感觉还行的2个,分享给大家。

DDE预警信号是多,但收益非常不错,思路是所有DDX指标全红,也就是DDX,DDY,DDZ,60日的这3个指标,另外加上FBKP大于1.5,还有一些其他的限制条件。

我最近的股票池都只用2个,一个是根据多方炮做出来的,收益不错,信号很少,第2个是用张兴文老师的成交量制作出来的,大家可以试一下。自己动手才会有体会,一味的收集其他朋友的池子很容易使自己思路混乱。

波段之王:
VAR1:=(CLOSE+HIGH+LOW+OPEN)/4;
VAR2:=SUMBARS(VOL,CAPITAL);
VAR3:=HHV(VAR1,VAR2);
VAR4:=LLV(VAR1,VAR2);
VAR5:=(2*VAR1-VAR4-REF(VAR4,1))/(VAR3-VAR4);
VAR6:=(VAR1-VAR4)/(VAR3-VAR4);
VAR7:=IF(VAR1<=VAR4,VAR5*60,VAR6*60);
波段之王:IF(VAR7>0,VAR7+20,20);
VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VAR9:=EMA(VAR8,7);
VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
波段买入:IF(VARA+VARB<7 AND CROSS(VAR8,VAR9) AND VAR9<-18 AND VAR9<VARB,60,50);
DRAWICON(波段买入=60,70,3);
VARC:=HHV(HIGH,9)-LLV(LOW,9);
VARD:=HHV(HIGH,9)-CLOSE;
VARE:=CLOSE-LLV(LOW,9);
VARF:=VARD/VARC*100-70;
VAR10:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR11:=(2*CLOSE+HIGH+LOW)/4;
VAR12:=SMA(VARE/VARC*100,3,1);
VAR13:=LLV(LOW,34);
VAR14:=SMA(VAR12,3,1)-SMA(VARF,9,1);
VAR15:=IF(VAR14>100,VAR14-100,0);
VAR16:=HHV(HIGH,34);
VAR17:=EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8);
波段卖出:VAR17;
VAR18:=EMA(VAR17,5);
STICKLINE(VAR17>0 AND VAR17-VAR18>=0,79,80,6,0),colorgreen;
STICKLINE(VAR17>0 AND VAR17-VAR18<0,79,80,6,1),colorred;
STICKLINE(VAR17>0 AND VAR17-VAR18>=0,19,20,6,0),colorblue;
STICKLINE(VAR17>0 AND VAR17-VAR18<0,19,20,6,1),colorred;
STICKLINE(VAR17-VAR18>0,VAR17,VAR18,8,1),colorgreen;
STICKLINE(VAR17-VAR18<0,VAR17,VAR18,8,1),colorred;

波段看盘:
参数设置:p1:13,0,999
                   p2:5,0,999
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),4,1))/(SMA(ABS(CLOSE-LC),4,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),8,1))/(SMA(ABS(CLOSE-LC),8,1))*100;
RSI3:=(SMA(MAX(CLOSE-LC,0),12,1))/(SMA(ABS(CLOSE-LC),12,1))*100;
VAR1:=(RSI1+RSI2+RSI3)/3;
VAR2:=MA(CLOSE,5);
VAR3:=MA(CLOSE,10);
VAR4:=MA(CLOSE,20);
VAR5:=MA(CLOSE,30);
VAR6:=(VAR2+VAR3+VAR4+VAR5)/4;
VAR7:=(VAR6-REF(VAR6,P1))/REF(VAR6,13)*100;
VAR8:=(VAR6-REF(VAR6,P1))/REF(VAR6,13)*100;
VAR9:=EMA(VAR7,P2);
趋势:VAR9,POINTDOT,colorFFFFFF;
反转:STICKLINE(VAR9>1*REF(VAR9,1),VAR7,0,2,0),colorC0C0C0;
持股:STICKLINE(VAR7>1*REF(VAR7,1),VAR7,VAR9,7,1),colorred;
持币:STICKLINE(VAR7<1*REF(VAR7,1),VAR7,VAR9,7,1),colorFF0000;
离场:STICKLINE(趋势>=0 AND VAR7<1*REF(VAR7,1),VAR7,趋势,7,1),colorgreen;
预警:STICKLINE(趋势>=20 AND 趋势>REF(趋势,1),VAR7,趋势,7,0),coloryellow;
风险:STICKLINE(趋势>=40 AND 趋势>REF(趋势,1),VAR7,趋势,7,0),colorEE00EE;
头部:STICKLINE(趋势>5 AND CROSS(80,VAR1),VAR7,趋势,7,0),colorFFB97A;

不多说了,上图。

附件

1.jpg
2.jpg
DDE预警组合.rar

8.65 KB, 下载次数: 564, 下载积分: 分享值 -3 个

飞狐波段公式.FNC

7.29 KB, 下载次数: 249, 下载积分: 分享值 -3 个

来自 上海市

举报

使用道具 扔鸡蛋 回复

2452730
Lv.4

专栏

发表于 2012-8-20 06:23 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市

举报

使用道具 支持 扔鸡蛋 回复

1348092
Lv.5

专栏

发表于 2010-11-23 22:52 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省商丘市

举报

使用道具 支持 扔鸡蛋 回复

1381134
Lv.2

专栏

发表于 2010-11-23 22:48 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省江门市

举报

使用道具 支持 扔鸡蛋 回复

1353187
Lv.4

专栏

发表于 2010-6-30 12:41 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 福建省福州市仓山区

举报

使用道具 支持 扔鸡蛋 回复

1370304
Lv.2

专栏

发表于 2010-6-30 09:23 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 辽宁省沈阳市

举报

使用道具 支持 扔鸡蛋 回复

299774
Lv.4

专栏

发表于 2010-6-30 09:05 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市

举报

使用道具 支持 扔鸡蛋 回复

928156
Lv.3

专栏

发表于 2010-6-30 08:22 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市

举报

使用道具 支持 扔鸡蛋 回复

2144758
Lv.4

专栏

发表于 2010-6-30 04:56 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省镇江市

举报

使用道具 支持 扔鸡蛋 回复

1624073
Lv.3

专栏

发表于 2010-6-29 22:50 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省平顶山市

举报

使用道具 支持 扔鸡蛋 回复

1952324
Lv.4

专栏

发表于 2010-6-29 22:44 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省

举报

使用道具 支持 扔鸡蛋 回复

2087180
Lv.3

专栏

发表于 2010-6-29 21:55 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市

举报

使用道具 支持 扔鸡蛋 回复

2088188
Lv.2

专栏

发表于 2010-4-24 21:38 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省绍兴市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2017670
Lv.3

专栏

发表于 2010-4-23 17:37 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 吉林省吉林市

举报

使用道具 支持 扔鸡蛋 回复

1444998
Lv.3

专栏

发表于 2010-4-23 15:48 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 安徽省宣城市广德县

举报

使用道具 支持 扔鸡蛋 回复

299774
Lv.4

专栏

发表于 2010-4-23 15:10 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市

举报

使用道具 支持 扔鸡蛋 回复

1298508
Lv.3

专栏

发表于 2010-4-23 12:11 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省成都市

举报

使用道具 支持 扔鸡蛋 回复

1651147
Lv.2

专栏

发表于 2010-4-23 10:29 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 重庆市

举报

使用道具 支持 扔鸡蛋 回复

2017670
Lv.3

专栏

发表于 2010-4-23 09:28 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 吉林省吉林市

举报

使用道具 支持 扔鸡蛋 回复

1940484
Lv.4

专栏

发表于 2010-4-23 08:58 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省郑州市

举报

使用道具 支持 扔鸡蛋 回复

1348133
Lv.1

专栏

发表于 2010-4-23 07:39 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市平谷区

举报

使用道具 支持 扔鸡蛋 回复

1465864
Lv.2

专栏

发表于 2010-4-22 21:39 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省武汉市

举报

使用道具 支持 扔鸡蛋 回复

1538670
Lv.3

专栏

发表于 2010-4-22 21:27 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 安徽省宿州市

举报

使用道具 支持 扔鸡蛋 回复

1271954
Lv.2

专栏

发表于 2010-4-22 20:46 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江西省南昌市

举报

使用道具 支持 扔鸡蛋 回复

39375
Lv.3

专栏

发表于 2010-4-22 19:47 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市

举报

使用道具 支持 扔鸡蛋 回复

1125504
Lv.3

专栏

发表于 2010-4-22 19:36 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省黄石市

举报

使用道具 支持 扔鸡蛋 回复

1125504
Lv.3

专栏

发表于 2010-4-22 19:35 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省黄石市

举报

使用道具 支持 扔鸡蛋 回复

1820125
Lv.4

专栏

发表于 2010-4-22 19:23 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省青岛市

举报

使用道具 支持 扔鸡蛋 回复

1164934
Lv.2

专栏

发表于 2010-4-22 17:50 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江西省南昌市

举报

使用道具 支持 扔鸡蛋 回复

1635198
Lv.4

专栏

发表于 2010-4-22 17:41 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省成都市

举报

使用道具 支持 扔鸡蛋 回复

1795330
Lv.3

专栏

发表于 2010-4-22 17:37 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省湖州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼 40楼
57楼 39楼
56楼 38楼
55楼 37楼
54楼 36楼
53楼 35楼
52楼 34楼
51楼 33楼
50楼 32楼
49楼 31楼
48楼 30楼
47楼 29楼
46楼 28楼
45楼  
44楼  
43楼  
42楼  
41楼  
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表