请老师帮忙写出选股公式。已解决,感谢【西风冷然】。

[通达信] 1750 3
设置
1566674 Lv.2

专栏

发表于 2009-11-22 13:52 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
请老师帮忙写出下面指标的选股公式。非常感谢!
请老师分别写出当副图上出现最佳选入斋主全仓选入。
VAR1:(CLOSE-MA(CLOSE,12))/MA(CLOSE,1)*100,COLORGREEN,LINETHICK2;
VAR2:IF((VAR1 > 0),VAR1,0),CIRCLEDOT;
VAR4:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
VAR5:=(EMA(VAR4,3)-50)*2;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13),COLORGREEN,LINETHICK2;
VAR10:EMA(0.382*REF(VAR9,2)+0.618*VAR9,6),COLORRED;
DRAWICON(CROSS(VAR9,VAR10-2),VAR10,5);
STICKLINE(VAR2>=0,0,VAR2,8,0),COLORRED;
DRAWICON(CROSS(VAR5,-80),VAR1,25);
立竿见影:IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,23,0),LINETHICK2;
DRAWICON(立竿见影=23,23,1);
E:=CROSS(83,RSI);
STICKLINE( E,70,80,4,0),COLOR00FF00;
DRAWTEXT(E,66,' 逃顶');
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:IF(CROSS(最佳买入,0),61,0),STICK,COLORRED,LINETHICK4;
DRAWTEXT(CROSS(最佳买入,0),62,'最佳买入'),COLOR00FFFF;
STICKLINE(最佳买入选股,0,0.3,7.5,0),COLOR102099;
STICKLINE(最佳买入选股,0,0.3,6,0),COLOR1020AA;
STICKLINE(最佳买入选股,0,0.3,5.5,0),COLOR1020BB;
STICKLINE(最佳买入选股,0,0.3,4,0),COLOR1020CC;
STICKLINE(最佳买入选股,0,0.1,3.5,0),COLOR1020DD;
STICKLINE(最佳买入选股,0,0.1,2,0),COLOR1020EE;
天:80,POINTDOT,COLORBLUE,LINETHICK4;
海:20,POINTDOT,COLORRED,LINETHICK4;
AA:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
BB:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
CC:=EMA(AA,2);
DD:=EMA(BB,5);
TJ0:=CROSS(CC,DD);
上:=EMA(C,3);
中:=EMA(C,5);
下:=EMA(中,5);
TJ1:=CROSS(上,中);
TJ2:=上>REF(上,1);
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,5)-REF(EMA(X1,5),1))*3.1416*10;
EMA3:=EMA(C,3);
TJ3:=BB5>1 AND EMA(X1,5)>REF(EMA(X1,3),1);
STICKLINE(TJ1 AND TJ2  AND TJ0 AND TJ3,0,50,4,0)COLOR009999;
STICKLINE(TJ1 AND TJ2  AND TJ0 AND TJ3,0,50,3,0)COLOR00BBBB;
STICKLINE(TJ1 AND TJ2  AND TJ0 AND TJ3,0,50,1.5,0)COLOR00DDDD;
STICKLINE(TJ1 AND TJ2  AND TJ0 AND TJ3,0,50,0.6,0)COLOR00FFFF;
DRAWTEXT(TJ1 AND TJ2  AND TJ0 AND TJ3,48,'斋主全仓'),COLORRED;
斋主全仓:IF(CROSS('斋主全仓',0),0.9,0),STICK,COLORRED;
VARH2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VARH3:=SMA(SMA(VARH2,3,1),3,1)/28.57;
VARH4:=EMA(VARH3,5);
操盘:=3*VARH3-2*VARH4;
AH1:=CROSS(操盘,VARH3) AND VARH3<2.1 AND C>O;
STICKLINE(AH1,50,0,4,0),COLOR770077;
STICKLINE(AH1,50,0,3,0),COLOR990099;
STICKLINE(AH1,50,0,2,0),COLORBB00BB;
STICKLINE(AH1,50,0,1,0),COLORDD00DD;
STICKLINE(AH1,56,0,0.3,0),COLOR00FFFF;
DRAWTEXT(AH1,56,'财神'),COLORRED;

[ 本帖最后由 彩票人家 于 2009-11-22 16:30 编辑 ]

附件

截图01.png
来自 广东省广州市

举报

使用道具 扔鸡蛋 回复

1566674
Lv.2

专栏

发表于 2009-11-22 16:29 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 重庆市

举报

使用道具 支持 扔鸡蛋 回复

1059843
Lv.7

专栏

发表于 2009-11-22 15:44 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 支持 扔鸡蛋 回复

1560412
Lv.4

专栏

发表于 2009-11-22 14:50 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省德州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表