麻烦谈下这个指标的思路

[通达信] 1833 0
设置
1055700 Lv.2

专栏

发表于 2009-11-23 15:49 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
{===================== ☆大盘功能开关 =====================}
{资金进出}
Z_X0:=SMA(AMOUNT,10,1)/10000000;  
XL_1:=(Z_X0-LLV(Z_X0,4))/(HHV(Z_X0,4)-LLV(Z_X0,4))*100;         
XL_2:=LLV(Z_X0,4)+SMA(XL_1,4,1)/100*(HHV(Z_X0,4)-LLV(Z_X0,4));     
XL_3:=SMA(XL_2,3,1);
资金:=Z_X0,NODRAW,COLORGREEN,LINETHICK2;
K2:=BACKSET(资金>REF(资金,1),2);
资金强:IF(K2,资金,DRAWNULL),COLOR0660FF,LINETHICK2;
K3:=BACKSET(资金<REF(资金,1),2);
资金弱:IF(K3,资金,DRAWNULL),COLOR005500,LINETHICK1;
{A:=IF(资金>=REF(资金,1),资金,DRAWNULL);
DRAWBAND(A,RGB(255,80,80),A,0);
AA:=IF(资金<=REF(资金,1),资金,DRAWNULL);
DRAWBAND(AA,RGB(0,250,80),AA,0);}            
分界:=MA(Z_X0,8);
{大盘--转向三角}
Z_X1:=REF(EMA(Z_X0,5),1);
Z_X2:=(EMA(Z_X0,5)-Z_X1)/Z_X1*100;
Z_X3:=REF(EMA(Z_X0,5),BARSLAST(CROSS(Z_X2,0))+1);
Z_X4:=REF(EMA(Z_X0,5),BARSLAST(CROSS(0,Z_X2))+1);
{===================== 【大盘图解模板】===================== }
{大盘--资金进出}
STICKLINE(Z_X0<REF(Z_X0,1)||(AMOUNT/REF(AMOUNT,1)<0.97),Z_X0,REF(Z_X0,1),3,0),LINETHICK2,COLORWHITE;{//资金离场}
STICKLINE(Z_X0>=REF(Z_X0,1),Z_X0,REF(Z_X0,1),3,0),LINETHICK2,COLORRED;{//资金进场}
STICKLINE(Z_X0<分界,Z_X0,REF(Z_X0,1),3,0),LINETHICK2,COLORFFA900;{//空仓}
{大盘--转向}
DRAWLINE(CROSS(Z_X2,0),Z_X1,CROSS(0,Z_X2),Z_X1,0),COLORFF6FFF;{//粉红--斜线}
IF(Z_X2>=0 AND Z_X3=REF(Z_X3,1),Z_X3,DRAWNULL),COLORFF6FFF; {//粉红--直线}
DRAWLINE(CROSS(0,Z_X2),Z_X1,CROSS(Z_X2,0),Z_X1,0),COLORGREEN;{//绿--斜线}
IF(Z_X2<0 AND Z_X4=REF(Z_X4,1),Z_X4,DRAWNULL),COLORGREEN; {//绿--直线}
DRAWLINE(CROSS(0,Z_X2) OR CROSS(Z_X2,0),Z_X1,ISLASTBAR,Z_X1,0),COLORYELLOW; {//黄--最后斜线};
下面是 TDX的动态翻译

Z_X0赋值:成交额(元)的10日[1日权重]移动平均/10000000
XL_1赋值:(Z_X0-4日内Z_X0的最低值)/(4日内Z_X0的最高值-4日内Z_X0的最低值)*100
XL_2赋值:4日内Z_X0的最低值+XL_1的4日[1日权重]移动平均/100*(4日内Z_X0的最高值-4日内Z_X0的最低值)
XL_3赋值:XL_2的3日[1日权重]移动平均
资金赋值:Z_X0,NODRAW,画绿色,LINETHICK2
K2赋值:若资金>昨日资金则将最近2周期置为1
输出资金强:如果K2,返回资金,否则返回无效数,COLOR0660FF,LINETHICK2
K3赋值:若资金<昨日资金则将最近2周期置为1
输出资金弱:如果K3,返回资金,否则返回无效数,COLOR005500,LINETHICK1
分界赋值:Z_X0的8日简单移动平均
Z_X1赋值:昨日Z_X0的5日指数移动平均
Z_X2赋值:(Z_X0的5日指数移动平均-Z_X1)/Z_X1*100
Z_X3赋值:上次Z_X2上穿0距今天数+1日前的Z_X0的5日指数移动平均
Z_X4赋值:上次0上穿Z_X2距今天数+1日前的Z_X0的5日指数移动平均
当满足条件Z_X0<昨日Z_X0或者(成交额(元)/昨日成交额(元)<0.97)时,在Z_X0和昨日Z_X0位置之间画柱状线,宽度为3,0不为0则画空心柱.,LINETHICK2,画白色
当满足条件Z_X0>=昨日Z_X0时,在Z_X0和昨日Z_X0位置之间画柱状线,宽度为3,0不为0则画空心柱.,LINETHICK2,画红色
当满足条件Z_X0<分界时,在Z_X0和昨日Z_X0位置之间画柱状线,宽度为3,0不为0则画空心柱.,LINETHICK2,COLORFFA900

想请老师 说下
1思路
2这指标的优点或缺点
3大盘功能开关与资金进出什么关系
来自 浙江省杭州市

举报

使用道具 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表