(卖出,买入;魔鬼划线)高手请进,先谢过

[通达信] 1669 3
设置
2105810 Lv.2

专栏

发表于 2010-4-10 22:47 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
A:老师,对不起,我不太懂公式,弱弱的问一下,第二个含未来就不能编成选股吗?
B:老师我为了实现这个愿望等了快一个月了,今天才发现这个论坛就注册了,所以恳请您拿出一点点的时间帮我做个选股公式吧,谢谢您的辛勤劳动。
C:我刚才看了很多公式,但感觉都和我这个不大一样,只能再麻烦您了。
————————————————————————
选股要求
1、第一个公式是:下面的红色趋势线走平或上升。
2、第二个公式是:下面出现红色的买入趋势箭头。
3、如果您对第二个公式有什么好见解,还望一块改一下。
——————————————————————————————————————
N       20
M       32
P1       80
P2       100

VAR1:=(C+H+O+L)/4;
卖出:XMA(VAR1,N)*(1+P1/1000);
买入:XMA(VAR1,M)*(1-P2/1000);
幅度:100*(卖出-买入)/买入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),3,0),COLORMAGENTA;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),3,0),COLORMAGENTA;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORMAGENTA;
STICKLINE(买入>HIGH,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
DRAWTEXT(CROSS(LOW,买入),LOW*0.95,'B'),COLORRED,LINETHICK2;
BY:CROSS(LOW,买入),NODRAW;
DRAWTEXT(CROSS(卖出,HIGH),HIGH*1.02,'S'),COLORGREEN;
SL:CROSS(卖出,HIGH),NODRAW;
N1:=7;
LC:=REF(CLOSE,1);
X:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORYELLOW,LINETHICK1;
魔鬼:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1),COLOR00FF00;
魔王:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),1,X),COLOR00FF00;
TJ0:=X=魔王;
TJ1:=X=魔鬼;
TJ2:=X<REF(X,1);
TJ3:=X>REF(1,X);
JRS1:=DRAWICON(TJ1 AND TJ2,X,1);
JRS2:=DRAWICON(TJ0 AND TJ3,X,2);
DRAWICON(FILTER(JRS1>0,1),L*0.97,1);
DRAWICON(FILTER(JRS2>0,1),H*1.02,2);

[ 本帖最后由 赵鑫鑫505 于 2010-4-11 15:21 编辑 ]
来自 山东省枣庄市

举报

使用道具 扔鸡蛋 回复

2090050
Lv.2

专栏

发表于 2010-4-14 16:03 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 福建省福州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2105810
Lv.2

专栏

发表于 2010-4-11 13:59 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省枣庄市

举报

使用道具 支持 扔鸡蛋 回复

1768014
Lv.4

专栏

发表于 2010-4-10 22:58 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 辽宁省锦州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表