选股公式

[通达信] 5611 12
设置
1315954 Lv.1

专栏

发表于 2010-4-12 12:56 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
出现大黑马和小黑马时的选股公式
N:10;
VA6:=(2*CLOSE+HIGH+LOW)/4;
VA8:=LLV(LOW,34);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
生命线:EMA(VARD,N), COLORBLUE,LINETHICK2;
生命线S:IF(生命线>REF(生命线,1),生命线,DRAWNULL),COLORFF00FF,LINETHICK2;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
B2:=EMA(B1,5);
STICKLINE(B1-B2>0,B1,B2,2,0),COLORRED;
STICKLINE(B1-B2<0,B1,B2,2,0),COLOR008000;
SS1:=(LOW+HIGH+CLOSE*2)/4;
SS2:= MA(SS1,4);
SS3:=HHV(SS2,10);
SS4:=MA(SS3,3);
SS5:=1.25*SS4-0.25*SS3;
XKKJ:=IF(SS5>SS3,SS3,SS5);
FF1:=LLV(SS2,10);
FF2:=MA(FF1,3);
FF3:=1.25*FF2-0.25*FF1;
DKKJ:=IF(FF3<FF1,FF1,FF3);
MA13:=MA(C,13);
ZDHM:=CROSS(C,DKKJ) AND CROSS(C,MA13) AND CROSS(C,XKKJ);
ZHM:=CROSS(C,MA13) AND CROSS(C,XKKJ);
大黑马:IF(ZDHM OR ZHM,50,0),COLORYELLOW,POINTDOT;
A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
小黑马:IF(CROSS(D1,K1),45,0),COLORFFCC66,POINTDOT;
STICKLINE(大黑马>0,0,大黑马*1.1,1,0),COLORWHITE;
STICKLINE(大黑马>0 AND 大黑马<52,30,大黑马,1,0),COLORRED;
STICKLINE(大黑马>0,0,大黑马*0.8,2,0),COLORRED;
STICKLINE(大黑马>0,0,大黑马*0.4,2,0),COLORRED;
STICKLINE(大黑马>0,0,大黑马*0.2,3,0),COLORYELLOW;
STICKLINE(大黑马>0,0,大黑马*0.1,3,0),COLORFFCC66;
STICKLINE(小黑马>0,0,小黑马*1.1,1,0),COLORGRAY;
STICKLINE(小黑马>0 AND 小黑马<52,30,小黑马,1,0),COLORFFCC66;
STICKLINE(小黑马>0,0,小黑马*0.8,2,0),COLORFFCC66;
STICKLINE(小黑马>0,0,小黑马*0.4,2,0),COLORFFCC66;
{STICKLINE(小黑马>0,0,小黑马*0.2,10,0),COLORRED;
STICKLINE(小黑马>0,0,小黑马*0.1,10,0),COLORBLUE;};
来自 广西南宁市

举报

使用道具 扔鸡蛋 回复

2193237
Lv.2

专栏

发表于 2010-7-3 10:37 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 重庆市

举报

使用道具 支持 扔鸡蛋 回复

1483192
Lv.3

专栏

发表于 2010-7-3 06:35 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河北省保定市

举报

使用道具 支持 扔鸡蛋 回复

1483192
Lv.3

专栏

发表于 2010-7-3 06:22 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河北省保定市

举报

使用道具 支持 扔鸡蛋 回复

677492
Lv.2

专栏

发表于 2010-6-17 17:13 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 新疆乌鲁木齐市

举报

使用道具 支持 扔鸡蛋 回复

1721624
Lv.2

专栏

发表于 2010-4-13 06:46 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省焦作市

举报

使用道具 支持 扔鸡蛋 回复

1594735
Lv.3

专栏

发表于 2010-4-13 00:33 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省武汉市

举报

使用道具 支持 扔鸡蛋 回复

741554
Lv.3

专栏

发表于 2010-4-12 23:12 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省黄冈市

举报

使用道具 支持 扔鸡蛋 回复

2086040
Lv.2

专栏

发表于 2010-4-12 23:08 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西柳州市鹿寨县

举报

使用道具 点亮 支持 扔鸡蛋 回复

2086040
Lv.2

专栏

发表于 2010-4-12 22:58 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西柳州市鹿寨县

举报

使用道具 支持 扔鸡蛋 回复

1472663
Lv.2

专栏

发表于 2010-4-12 21:34 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省成都市

举报

使用道具 支持 扔鸡蛋 回复

1985024
Lv.2

专栏

发表于 2010-4-12 21:23 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山西省临汾市

举报

使用道具 支持 扔鸡蛋 回复

1812403
Lv.2

专栏

发表于 2010-4-12 16:41 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市徐汇区

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
12楼
11楼
10楼
9楼
8楼
7楼
6楼
5楼
4楼
3楼
2楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表