请老师帮我将飞狐公式转换为通达信公式

[飞 狐] 3022 4
设置
1812721 Lv.4

专栏

发表于 2010-8-23 12:23 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
请老师帮我将飞狐公式转换为通达信公式
{主力}
Z_L1:=(H+L+C)/3;                  Z_L2:=AMOUNT/IF(H=L,4,H-L);            Z_L3:=Z_L2*(MIN(O,C)-L)*2;
Z_L4:=Z_L2*(Z_L1-MIN(C,O))*2;     Z_L5:=Z_L2*(MAX(C,O)-Z_L1)*2;          Z_L6:=Z_L2*(H-MAX(O,C))*2;
主力增减:(Z_L3+Z_L4-Z_L5-Z_L6)/10000*6,LINETHICK,PRECISION,COLORRED;     
{散户}
S_h1:=Z_L2*(MIN(O,C)-L);        S_h2:=Z_L2*(Z_L1-MIN(C,O));          S_h3:=Z_L2*(H-MAX(O,C));
S_h4:=Z_L2*(MAX(C,O)-Z_L1);     S_h5:=1-(S_h1+S_h2);                 S_h6:=1-(S_h3+S_h4);            S_h7:=V/SUM(V,60)*100;
散户增减:(S_h5-S_h6)/10000/S_h7,LINETHICK,PRECISION,COLORGREEN;
{MACD}
DIFF:EMA(C,12)-EMA(C,26),LINETHICK,PRECISION2,COLORWHITE;    DEA:EMA(DIFF,9),LINETHICK,PRECISION2,ColorFFB7B2;    MACD:=2*(DIFF-DEA);
{相对MACD--指数参考用}
相对F:=(EMA(C/INDEXC,12)-EMA(C/INDEXC,26))*1000;   相对A:=EMA(相对F,9);     相对MACD:=2*(相对F-相对A);
{KD--快速}
K:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
D:=EMA(0.667*REF(K,1)+0.333*K,2);
{信号}
A_X1:=EMA(C,7);   A_X2:=EMA(C,19);
UP:=LINEVALUE(L=LLV(L,BARSLAST(CROSS(A_X2,A_X1))+1),LLV(L,BARSLAST(CROSS(A_X2,A_X1))+1),H=HHV(H,BARSLAST(CROSS(A_X1,A_X2))+1),
HHV(H,BARSLAST(CROSS(A_X1,A_X2))+1),0,0);
UZ:=LINEVALUE(H=HHV(H,BARSLAST(CROSS(A_X1,A_X2))+1),HHV(H,BARSLAST(CROSS(A_X1,A_X2))+1),L=LLV(L,BARSLAST(CROSS(A_X2,A_X1))+1),
LLV(L,BARSLAST(CROSS(A_X2,A_X1))+1),0,0);
买:(LLV(K,2)=LLV(K,7) AND COUNT(K<0,2) AND CROSS(K,MA(K,2))) AND REF(UZ,1)<REF(UZ,2) AND UP>REF(UZ,1),LINETHICK;{选股}
//卖:=(HHV(K,2)=HHV(K,7) AND COUNT(K>0,2) AND CROSS(MA(K,2),K)) AND REF(UP,1)>REF(UP,2) AND UP>REF(UZ,1),LINETHICK;
{叠加}
n1:=sysparam(3);     n2:=sysparam(2);     n3:=(n1-n2)+1;     hh:=hhv(DIFF,n3);     ll:=llv(MACD,n3);
zhh:=hh[n1];         zll:=ll[n1];         Rh:=hhv(K,0);      RL:=LLv(K,0);         q:=datacount;  
Rb:=(zhh-zll)/(RH[q]-RL[q]);              Ry:=(zhh+zll-rb*(RH[q]+RL[q]))/2;
多:K*rb+ry,LINETHICK,PRECISION2,ColorFF89FF;      
空:D*rb+ry,LINETHICK,PRECISION2,COLORCYAN;        
{-----------------【图解模板】---------------------}
DRAWGBK((DATE > 0),COLORRGB(0,33,0),COLORRGB(0,33,0),1);
{}
FILLRGN(多>空,多,空),COLORBROWN;                                 FILLRGN(多<空,多,空),Color007800;
STICKLINE(MACD<ref(MACD,1) and MACD<0,0,MACD,0,0),ColorFFCF78;          STICKLINE(MACD<ref(MACD,1) and MACD>0,0,MACD,0,0),COLORYELLOW;
STICKLINE(MACD>ref(MACD,1) and MACD<0,0,MACD,0,0),COLORMAGENTA;         STICKLINE(MACD>ref(MACD,1) and MACD>0,0,MACD,0,0),COLORRED;
STICKLINE(CAPITAL>0&&相对MACD<=REF(相对MACD,1)&&相对MACD>0,REF(MACD,1),MACD,5,0),ColorFFCF78;
STICKLINE(CAPITAL>0&&相对MACD<=REF(相对MACD,1)&&相对MACD<0,REF(MACD,1),MACD,5,0),ColorFF6A00;
STICKLINE(CAPITAL>0&&相对MACD>REF(相对MACD,1)&&相对MACD<0,REF(MACD,1),MACD,5,0),COLORMAGENTA;
STICKLINE(CAPITAL>0&&相对MACD>REF(相对MACD,1)&&相对MACD>0,REF(MACD,1),MACD,5,0),COLORRED;
加速线:2.8*(DEA-DIFF),LINEDOT,PRECISION2,Color00B7B2;
PARTLINE(1,DIFF),LINEDASHDOT,COLORWHITE;
PARTLINE(1,DEA),ColorFFB7B2;
PARTLINE(1,多),ColorFF89FF;
PARTLINE(1,空),COLORCYAN;
DRAWICON(买,多,4),ALIGN,PXDN28;
//DRAWICON(卖,多,5),ALIGN,PXUP8;

[ 本帖最后由 蓝天碧水09 于 2010-8-23 12:29 编辑 ]
来自 广东省佛山市

举报

使用道具 扔鸡蛋 回复

1444845
Lv.3

专栏

发表于 2012-4-1 11:50 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 重庆市

举报

使用道具 支持 扔鸡蛋 回复

1790326
Lv.3

专栏

发表于 2010-12-26 22:43 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市海淀区

举报

使用道具 支持 扔鸡蛋 回复

1700860
Lv.7

专栏

发表于 2010-8-24 15:17 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

814270
Lv.5

专栏

发表于 2010-8-23 12:34 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市浦东新区

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
4楼
3楼
2楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表