求助老师做一下天狼剑的五角星选股公式

[大智慧] 3089 9
设置
2153092 Lv.2

专栏

发表于 2010-8-24 03:14 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
B1:=MA(C,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
停损下限:IF(LLV(MA(B2,8),3)<b2,LLV(MA(B2,8),3),b2);
FILLRGN(b2,sma2,b2>sma2,RGB(255,200,0),b2<sma2,RGB(0,255,0));
snakeA:HHV(MA(B2,1),13),coloryellow;
Var1:=(2*CLOSE+HIGH+LOW)/4;
Var2:=MA(Var1,7);
Var3:=Var2-MA(Var1,7/2)<0;
Var4:=Var2-MA(Var1,7/2)>0;
Var5:=BARSLAST(Var3);
Var6:=0-BARSLAST(Var4);
Var7:=IF(Var3<=0,Var5,Var6);
STICKLINE(snakea>b2 AND b2>SMA2,snakea,b2,1,1),colorblue;
STICKLINE(snakea>SMA2 AND b2<SMA2,snakea,SMA2,1,1),colorblue;
Var11:=(CLOSE*2+HIGH+LOW)/4;
Var21:=EMA(Var11,13)-EMA(Var11,34);
Var31:=EMA(Var21,5);
STICKLINE((C>=O),OPEN,LOW,1,0),color0726CA;
STICKLINE((C>=O),CLOSE,HIGH,1,0),color0726CA;
STICKLINE((C<O),CLOSE,LOW,1,0),colorDE9100;
STICKLINE((C<O),OPEN,HIGH,1,0),colorDE9100;
STICKLINE((C<O),CLOSE,OPEN,8,0),colorFF5B00;
STICKLINE((C<O),CLOSE,OPEN,10,0),color000000;
STICKLINE((C<O),CLOSE,OPEN,7,0),colorFF6C00;
STICKLINE((C<O),CLOSE,OPEN,6,0),colorFF7B00;
STICKLINE((C<O),CLOSE,OPEN,5,0),colorFF9C00;
STICKLINE((C<O),CLOSE,OPEN,4,0),colorFFBE00;
STICKLINE((C<O),CLOSE,OPEN,2.5,0),colorFFCC00;
STICKLINE((C<O),CLOSE,OPEN,1.5,0),colorFFFF00;
STICKLINE((C>O),CLOSE,OPEN,8,0),color070084;
STICKLINE((C>O),CLOSE,OPEN,10,0),color000000;
STICKLINE((C>O),CLOSE,OPEN,7,0),color0000A3;
STICKLINE((C>O),CLOSE,OPEN,6,0),color0000B7;
STICKLINE((C>O),CLOSE,OPEN,5,0),color0000CD;
STICKLINE((C>O),CLOSE,OPEN,4,0),color0000E9;
STICKLINE((C>O),CLOSE,OPEN,2,0),color0754E9;
STICKLINE((C>O),CLOSE,OPEN,1.5,0),color076EF3;
STICKLINE((C>O),CLOSE,OPEN,1,0),color077BF3;
VAR2A:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3A:=((REF(VAR2A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4A:=((REF(VAR3A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5A:=((REF(VAR4A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6A:=((REF(VAR5A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7A:=((REF(VAR6A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8A:=((REF(VAR7A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9A:=((REF(VAR8A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARAA:=((REF(VAR9A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARBA:=((REF(VARAA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARCA:=((REF(VARBA,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARDA:=((REF(VARCA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAREAA:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARFA:=((REF(VAREAA,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF

(CLOSE,2)));
VAR10A:=((REF(VARFA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF

(CLOSE,2)));
VAR11A:=((REF(VAR10A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF

(CLOSE,2)));
VAR12A:=((REF(VAR11A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF

(CLOSE,2)));
VAR13A:=((REF(VAR12A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF

(CLOSE,2)));
VAR14A:=((REF(VAR13A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF

(CLOSE,2)));
VAR15A:=((REF(VAR14A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF

(CLOSE,2)));
VAR16A:=((REF(VAR15A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF

(CLOSE,2)));
VAR17A:=((REF(VAR16A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF

(CLOSE,2)));
VAR18A:=((REF(VAR17A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF

(CLOSE,2)));
VAR19A:=((REF(VAR18A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF

(CLOSE,2)));
VAR1A:=(REF((((((((((((VAREAA OR VARFA) OR VAR10A) OR VAR11A) OR VAR12A) OR

VAR13A) OR VAR14A) OR VAR15A) OR VAR16A) OR VAR17A) OR VAR18A) OR VAR19A),1) AND

VAR2A);
STICKLINE(var1A,O,O+(C-O)/3,8,0),color0000ff;
STICKLINE(var1A,O,O+(C-O)/3,7,0),color1029ff;
STICKLINE(var1A,O,O+(C-O)/3,6,0),color1040ff;
STICKLINE(var1A,O,O+(C-O)/3,5,0),color1083ff;
STICKLINE(var1A,O,O+(C-O)/3,4,0),color10abff;
STICKLINE(var1A,O,O+(C-O)/3,3,0),color10d0ff;
STICKLINE(var1A,O,O+(C-O)/3,2,0),color10ffff;
STICKLINE(var1A,O,O+(C-O)/3,1,0),color00ffff;
AA:=(REF((((((((((((VAR2A OR VAR3A) OR VAR4A) OR VAR5A) OR VAR6A) OR VAR7A) OR

VAR8A) OR VAR9A)

OR VARAA) OR VARBA) OR VARCA) OR VARDA),1) AND VAREAA);

STICKLINE(aa,O,O+(C-O)/3,8,0),color008800;
STICKLINE(aa,O,O+(C-O)/3,7,0),color009900;
STICKLINE(aa,O,O+(C-O)/3,6,0),color00aa00;
STICKLINE(aa,O,O+(C-O)/3,5,0),color00bb00;
STICKLINE(aa,O,O+(C-O)/3,4,0),color00cc00;
STICKLINE(aa,O,O+(C-O)/3,3,0),color00dd00;
STICKLINE(aa,O,O+(C-O)/3,2,0),color00ee00;
STICKLINE(aa,O,O+(C-O)/3,1,0),color00ff00;

a13:=EMA(CLOSE,55);
a14:=MA(CLOSE,75);
a15:=EMA(a14,3);
a16:=EMA(a15,3);
a17:=(HIGH + LOW) / 5;
a18:=(MA(a17,4)) - (MA(a17,34));
a19:=CROSS(a18,0);
a20:=CROSS(0,a18);
a21:=BARSLAST(a19);
a22:=BARSLAST(a20);
a23:=REF(a19,1);
a24:=REF(a20,1);
a25:=BARSLAST(a23);
a26:=BARSLAST(a24);
a27:=IF((a25 < a26),(REF((HHV(HIGH,2)),a25)),(REF((LLV(LOW,2)),a26)));
a28:=(((REF(CLOSE,1)) <= (REF(a27,1))) AND (CLOSE > a27)) AND (a21 < a22);
a29:=(((REF(CLOSE,1)) >= (REF(a27,1))) AND (CLOSE < a27)) AND (a22 < a21);
a30:=a28 AND ((COUNT(a28,a21)) = 1);
a31:=a29 AND ((COUNT(a29,a22)) = 1);
a32:=a30 AND ((REF(BARSLAST(a31),1)) < (REF(BARSLAST(a30),1)));
a33:=a31 AND ((REF(BARSLAST(a31),1)) > (REF(BARSLAST(a30),1)));
DRAWTEXT(a32,SMA2*0.99,'←═╬∝'),coloryellow;

ac:=AMOUNT/(VOL);
yy:=MA(ac,13);
lll:=(C-yy)/yy*100;
MIDc :=  MA(CLOSE,22);
UPPERc:= MIDc + 2*STD(C,22);
LOWERc:= MIDc - 2*STD(C,22);
bba:=(C-lowerc)/(upperc-lowerc);
bbc:=FORCAST(bba,3);
LIFENGcyc:=(REF(lll,1)<-15 AND REF(bba,1)<0 AND lll>REF(lll,1));
STICKLINE(LIFENGcyc,LOW*0.93,LOW*0.95,6,0);
STICKLINE(lifengcyc>0,C,O,8,0),colorred;
STICKLINE(lifengcyc>0,C,O,7,0),color1029FF;
STICKLINE(lifengcyc>0,C,O,6,0),color1040FF;
STICKLINE(lifengcyc>0,C,O,4,0),color1083FF;
STICKLINE(lifengcyc>0,C,O,2,0),color10ABFF;
STICKLINE(lifengcyc>0,C,O,1.5,0),color10D0FF;
STICKLINE(lifengcyc>0,C,O,1,0),color10FFFF;

DRAWTEXT(LIFENGcyc>0,LOW*0.99,'☆'),colordd00dd;
来自 辽宁省沈阳市

举报

使用道具 扔鸡蛋 回复

2517124
Lv.3

专栏

发表于 2018-11-4 23:54 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省

举报

使用道具 支持 扔鸡蛋 回复

2830481
Lv.1

专栏

发表于 2018-3-13 16:45 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省无锡市

举报

使用道具 支持 扔鸡蛋 回复

2846524
Lv.3

专栏

发表于 2014-8-1 19:25 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省汕头市

举报

使用道具 支持 扔鸡蛋 回复

2452885
Lv.4

专栏

发表于 2013-6-20 23:30 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省汕尾市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2010-8-26 02:27 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省攀枝花市

举报

使用道具 支持 扔鸡蛋 回复

1756919
Lv.4

专栏

发表于 2010-8-24 17:05 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省枣庄市

举报

使用道具 支持 扔鸡蛋 回复

1497933
Lv.4

专栏

发表于 2010-8-24 16:54 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 安徽省安庆市

举报

使用道具 支持 扔鸡蛋 回复

2239010
Lv.2

专栏

发表于 2010-8-24 14:50 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 埃及

举报

使用道具 支持 扔鸡蛋 回复

1799664
Lv.4

专栏

发表于 2010-8-24 06:59 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省孝感市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
10楼
9楼
8楼
7楼
6楼
5楼
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表