手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

求老师将下列指标改为选股公式

[通达信]
设置
1518 2 股东股东股东 Lv.4 发表于 · 2010-12-17 21:15 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
求老师将下列指标改为选股公式:
要求:股价由压力线附近回调至趋势线(X2)附近正负2%并收红K线及当换手率大于3 。

M1:2.00   100.00  18.00
A:=AMOUNT/V/100;VARA:=EMA((((A-EMA(A,13))/EMA(A,13))*(0-100)),5);
X1:=EMA(((VARA/10)+EMA(A,10)),3);Y1:=EMA(A,3);
Y2:=(C+0.618*REF(C,1)+0.382*REF(C,2)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
X2:EMA(((slope(C,22)*20)+C),55);
压力:MA(REF(HHV(C,30),1),2);支撑:MA(REF(LLV(C,30),1),2);
DA:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,4))/4;
DB:=(EMA(C,10)+EMA(C,20)+EMA(C,40)+EMA(C,80))/4;
DRAWTEXT(60*(40*(EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9)<0
AND
COUNT(COUNT(CROSS
((EMA(CLOSE,12)-EMA(CLOSE,26)),EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9)),BARSLAST
(EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9)>=0))=2,21)=1)
AND SLOPE(MA(C,5),2)>0) AND
MA(C,55)>REF(MA(C,55),1) AND
REF(MA(C,55),1)<=REF(MA(C,55),2),L*0.95,'买入'),COLOR0080FF;
JH:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;
DRAWICON(60*(40*(EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9)<0
AND
COUNT(COUNT(CROSS
((EMA(CLOSE,12)-EMA(CLOSE,26)),EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9)),BARSLAST
(EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9)>=0))=2,21)=1)
AND SLOPE(MA(C,5),2)>0) AND
MA(C,55)>REF(MA(C,55),1) AND
REF(MA(C,55),1)<=REF(MA(C,55),2),LOW,5);
股东股东股东
Lv.4
发表于 2010-12-18 07:06 复制 查看全部楼层
首先谢谢秋沛老师!!!但此公式测试提示“输出公式不能超过一个”望解决。

[ 本帖最后由 股东股东股东 于 2010-12-18 07:18 编辑 ]
秋沛
Lv.2
发表于 2010-12-17 21:31 复制 查看全部楼层
游客,如果您要查看本帖隐藏内容请回复
从压力线回调我表达为股价三日内曾经下穿压力线,你看看吧。

[ 本帖最后由 股奴1985 于 2010-12-17 23:11 编辑 ]
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表