请老师把这个MACD指标改写出RSI底背离条件公式(已答复:清浊)

[大智慧] 6352 9
设置
1982916 Lv.2

专栏

发表于 2011-3-28 00:47 复制 显示全部楼层 倒序浏览 |
跳转到指定楼层
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS(DEA,DIFf),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
MACD底背:IF(B1>0,-0.1,0),COLORRED,LINETHICK0;
KDJ底背:IF(B2>0,-0.1,0),COLORFF00FF,LINETHICK0;
RSI底背:IF(B3>0,-0.1,0),COLORYELLOW,LINETHICK0;
MACD顶背:IF(D1>0,0.1,0),COLOR00FF00,LINETHICK0;
KDJ顶背:IF(D2>0,0.1,0),COLORFFCC66,LINETHICK0;
RSI顶背:IF(D3>0,0.1,0),COLORWHITE,LINETHICK0;
STICKLINE(B1>0,-0.1,0,4,0),COLORRED;
STICKLINE(B2>0,-0.1,0,4,0),COLORFF00FF;
STICKLINE(B3>0,-0.1,0,4,0),COLORYELLOW;
STICKLINE(D1>0,0.1,0,4,0),COLOR00FF00;
STICKLINE(D2>0,0.1,0,4,0),COLORFFCC66;
STICKLINE(D3>0,0.1,0,4,0),COLORWHITE;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORRED;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORYELLOW;
STICKLINE(MACD<REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORCYAN;
STICKLINE(MACD>=REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORMAGENTA;
STICKLINE(C>0,0,0,50,1),COLORBLUE;
DIFF,COLORGREEN;
DEA,COLORYELLOW;
PARTLINE(DIFF,DIFF>MA(DIFF,2)),COLORRED;
PARTLINE(DEA,DEA>MA(DEA,2)),COLORMAGENTA;
DRAWTEXT(REF(MACD,1)>0 AND MACD<0,MACD-0.01,'1');
DRAWTEXT(REF(MACD,2)>0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'2');
DRAWTEXT(REF(MACD,3)>0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'3');
DRAWTEXT(REF(MACD,4)>0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'4');
DRAWTEXT(REF(MACD,5)>0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'5');

[ 本帖最后由 股董玩股 于 2011-3-28 23:23 编辑 ]
来自 山东省

举报

使用道具 扔鸡蛋 回复

739551
Lv.4

专栏

发表于 2011-3-28 08:28 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省南京市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1758148
Lv.7

专栏

发表于 2011-3-28 23:22 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

2085559
Lv.3

专栏

发表于 2011-5-25 22:05 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省恩施州

举报

使用道具 点亮 支持 扔鸡蛋 回复

631945
Lv.3

专栏

发表于 2011-5-31 14:53 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西北海市

举报

使用道具 支持 扔鸡蛋 回复

1753330
Lv.6

专栏

发表于 2014-1-24 17:35 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市

举报

使用道具 支持 扔鸡蛋 回复

2802669
Lv.3

专栏

发表于 2015-6-3 12:01 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省德阳市广汉市

举报

使用道具 支持 扔鸡蛋 回复

2912273
Lv.2

专栏

发表于 2015-12-10 20:32 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 黑龙江省佳木斯市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2864817
Lv.2

专栏

发表于 2016-9-23 21:44 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖南省长沙市

举报

使用道具 支持 扔鸡蛋 回复

3949774
Lv.2

专栏

发表于 2021-10-28 19:58 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省金华市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
3楼
4楼
5楼
6楼
7楼
8楼
9楼
10楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表