请老师将通达信版多周期MACD改为选股公式

[通达信] 6601 7
设置
1846687 Lv.4

专栏

发表于 2011-10-14 18:53 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
请老师将通达信版多周期MACD改为选股公式。当周MACD发红时,日MACD指标DIF由兰变红时写成选股指标,源码【【DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORFF00FF,NODRAW;
DEA:EMA(DIF,9),COLOR1AFFFF,NODRAW;
MACD:(DIF-DEA)*2,COLOR0000F2,NODRAW;
STICKLINE("MACD.MACD#WEEK">=0,0,"MACD.MACD#WEEK",4,0),COLOR000055;
STICKLINE("MACD.MACD#WEEK"<0,0,"MACD.MACD#WEEK",4,0),COLOR515100;
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLOR0000F2;
STICKLINE(MACD>=0 AND MACD<REF(MACD,1),0,MACD,1,1),COLOR0000F2;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,1,0),COLOR008000;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1,1),COLOR008000;
ES:=REF(EMA(C,26),1);
EP:=REF(EMA(C,12),1);
DI:=REF(DIF,1);
DIF穿零价:((12+1)*(26-1)*ES-(26+1)*(12-1)*EP)/(2*(26+1)-2*(12+1)),NODRAW,COLORWHITE;
DIF拐点价:((12-1)*EP/(12+1)-(26-1)*ES/(26+1)-DI)*(26+1)*(12+1)/(2*(12+1)-2*(26+1)),COLORYELLOW,NODRAW;
IF(1,DIF,DRAWNULL),COLORCYAN;
IF(DIF>=REF(DIF,1),DIF,DRAWNULL),COLORFF00FF;
IF(1,DEA,DRAWNULL),COLOR1AFFFF;】】图片不会弄有个链接https://www.55188.com/blog.php?tid=4321687谢谢!附图如果能加上买入指示最好了
来自 山东省滨州市

举报

使用道具 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2014-1-28 13:53 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省攀枝花市

举报

使用道具 支持 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2013-10-15 15:20 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市

举报

使用道具 支持 扔鸡蛋 回复

2652750
Lv.6

专栏

发表于 2012-11-9 20:19 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江西省吉安市

举报

使用道具 支持 扔鸡蛋 回复

1846687
Lv.4

专栏

发表于 2011-10-19 16:32 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省滨州市

举报

使用道具 支持 扔鸡蛋 回复

1846687
Lv.4

专栏

发表于 2011-10-19 16:32 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省滨州市

举报

使用道具 支持 扔鸡蛋 回复

1846687
Lv.4

专栏

发表于 2011-10-15 17:21 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省滨州市

举报

使用道具 支持 扔鸡蛋 回复

1846687
Lv.4

专栏

发表于 2011-10-15 08:16 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省滨州市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
8楼
7楼
6楼
5楼
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表