请老师帮忙帮(简单买卖)改写成选股公式,谢谢!

[通达信] 3148 2
设置
2459022 Lv.2

专栏

发表于 2011-10-14 20:40 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
请老师帮忙把这个公式改写成选股公式,当指标发出买入信号时入场,如果按照指标发出信号买卖,中间加上高抛低吸,大概率时间是盈利的。谢谢老师
源码如下
VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
A:=(VAR7>VAR6 AND VAR7>25 AND VAR6<25);
B:ZIG(3,50/5)*100,COLORWHITE;
G:MA(B,2),COLORYELLOW;
D:=CROSS(B,G)*1000,COLORRED;
W:=CROSS(G,B)*1000,COLORBLUE;
E:=REF(INDEXC,1);
F:=SMA(MAX(INDEXC-E,0),3,1)/SMA(ABS(INDEXC-E),3,1);
VAR10:=F AND F<8;
VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR12:=SMA(VAR11,3,1);
VAR13:=SMA(VAR12,3,1);
VAR14:=VAR13 AND VAR13<20;
MM:=A AND D AND VAR10 AND VAR14 ;
DRAWTEXT(W=1000,B*1.05,'&Acirc;&ocirc;' ),COLORGREEN;
DRAWTEXT(D=1000,B*1.05,'&Acirc;ò'),COLORRED;

附件

图2.jpg
来自 山东省青岛市

举报

使用道具 扔鸡蛋 回复

2652750
Lv.6

专栏

发表于 2012-11-9 19:40 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江西省吉安市

举报

使用道具 支持 扔鸡蛋 回复

2266543
Lv.6

专栏

发表于 2011-10-14 20:45 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山西省吕梁市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
2楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表