请将通达信组合KDJ+DMI指标改为同花顺(已解决,郑云老师)

[同花顺] 5482 2
设置
1963323 Lv.2

专栏

发表于 2011-10-15 09:00 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
发现一个通达信组合KDJ+DMI指标,请老师改为同花顺的,不胜感谢。
N:=14;
M:=6;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:DMP*100/MTR,LINETHICK0;
MDI:DMM*100/MTR,LINETHICK0;
STICKLINE(PDI>=MDI,50,50+(PDI-MDI),0.5,0),COLORRED;
STICKLINE(PDI<MDI,50,50-(MDI-PDI),0.5,1),COLOR00FF00;
ADX:EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6),COLORRED,LINETHICK0;
ADXR:EXPMEMA(ADX,6),COLORFF00FF,LINETHICK0;
DRAWBAND(ADX,RGB(220,0,0),ADXR,RGB(20,240,240));
STICKLINE(C>0,100,105,3,1),COLORFFFF00;
STICKLINE(ADX>=ADXR,100,105,3,0),COLOR0000FF;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),LINETHICK0;
D:SMA(K,3,1),LINETHICK0;
J:3*K-2*D,COLOR00FF00,LINETHICK1;
DRAWBAND(K,RGB(220,0,220),D,RGB(180,140,140));
STICKLINE(C>0,0,-5,3,1),COLORFFFF00;
STICKLINE(K>=D,0,-5,3,0),COLORFF00FF;
DRAWTEXT(CURRBARSCOUNT=8,100,'ADX金叉ADXR'),COLORFFFF00;
DRAWTEXT(CURRBARSCOUNT=7,-7,'KDJ金叉'),COLORFFFF00;
DRAWTEXT(CURRBARSCOUNT=6,55,'PDI与MDI'),COLORFFFF00;

[ 本帖最后由 同花顺fj 于 2011-10-16 15:05 编辑 ]
来自 福建省龙岩市永定县

举报

使用道具 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2014-3-4 16:25 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市

举报

使用道具 支持 扔鸡蛋 回复

2082709
Lv.3

专栏

发表于 2011-10-15 10:29 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省惠州市惠城区

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
2楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表