请老师帮忙修改公式,谢谢!!!

[飞 狐] 2808 1
设置
1127165 Lv.2

专栏

发表于 2011-10-15 12:34 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
有一K线形态公式主图,感觉画面很花,请老师帮忙修改一下,目标是:K线上不要显示文字,只在鼠标移动到K线时在指定位置(如0,300,50,)显示相应的k线形态说明。
麻烦老师帮忙示范一二即可,在此先行感谢了!!!!!!
1.jpg


原码:
★早晨之星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
DRAWTEXT(★早晨之星,LOW*0.97,'←早晨之星'),COLORRED;
★黄昏之星:=REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND
CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
DRAWTEXT(★黄昏之星,HIGH*1.02,'←黄昏之星' ),COLOR00FF00;
★长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;
DRAWTEXT(★长十字,HIGH*1.02,'←长十字' ),COLORWHITE;
★垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
DRAWTEXT(★垂死十字,HIGH*1.02,'←垂死十字' ),COLORGREEN;
★早晨十字星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
DRAWTEXT(★早晨十字星,LOW*0.97,'←早晨十字星' ),COLORRED;
★黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1) > REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
DRAWTEXT(★黄昏十字星,HIGH*1.02,'←黄昏十字星' ),COLORGREEN;
★射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5);
DRAWTEXT(★射击之星,HIGH*1.02,'←射击之星'),COLORGREEN;
★倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5);
DRAWTEXT(★倒转锤头,LOW*0.97,'←倒转锤头' ),COLORRED;
★锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5);
DRAWTEXT(★锤头,LOW*0.97,'←锤头' ),COLORRED;
★吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
DRAWTEXT(★吊颈,HIGH*1.02,'←吊颈'),COLORGREEN;
★穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1));
DRAWTEXT(★穿头破脚,HIGH*1.01,'←穿头破脚' ),COLOR00FF00;
★乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
DRAWTEXT(★乌云盖顶,HIGH*1.04,'←乌云盖顶' ),COLOR00FF00;
★曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(★曙光初现,LOW*0.99,'←曙光初现'),COLORRED;
★身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1));
DRAWTEXT(★身怀六甲,LOW*0.99,'←身怀六甲'),COLORRED;
★平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
DRAWTEXT(★平顶,LOW*0.99,'←平顶'),COLORWHITE;
★平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 and ABS(REF(LOW,1)-REF(LOW,2))/REF(LOW,1)<=0.001);
DRAWTEXT(★平底,LOW*0.99,'←平底'),COLORWHITE;
★大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018;
DRAWTEXT(★大阳烛,LOW*0.99,'←大阳烛'),COLORRED;
★红三兵:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(★红三兵,LOW*0.99,'←红三兵'),COLORRED;
★双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
DRAWTEXT(★双飞乌鸦 and TJTS,HIGH*1.04,'←双飞乌鸦' ),COLOR00FF00;
★孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100  AND REF(OPEN,1)>=REF(CLOSE,1) AND
(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND CLOSE>=OPEN AND
(CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(CLOSE,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
DRAWTEXT(★孕育线,LOW*0.98,'←孕育线'),COLORRED;
★多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
DRAWTEXT(★多方炮,LOW*0.98,'←多方炮'),COLORRED;
★出水芙蓉:=(OPEN<EMA(CLOSE,20) OR OPEN<EMA(CLOSE,40) OR OPEN<EMA(CLOSE,60)) AND (CLOSE>MAX(EMA(CLOSE,20),MAX(EMA(CLOSE,40),EMA(CLOSE,60))))
AND (VOL/MA(VOL,30)>1.2 AND CLOSE/REF(CLOSE,1)>1.049);
DRAWTEXT(★出水芙蓉,LOW*1.0,'←出水芙蓉'),COLORRED;
★上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND
REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
DRAWTEXT(★上升三部曲,LOW*0.98,'←上升三部曲'),COLORRED;
★下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
DRAWTEXT(★下跌三部曲,HIGH*1.04,'←下跌三部曲' ),COLOR00FF00;
★跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
DRAWTEXT(★跳空缺口,HIGH*1.04,'←跳空缺口' ),COLORWHITE;
★光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
DRAWTEXT(★光脚阴线,HIGH*1.04,'←光脚阴线' ),COLOR00FF00;
★光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
DRAWTEXT(★光头阳线,LOW*0.98,'←光头阳线'),COLORRED;
★分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
DRAWTEXT(★分离,HIGH*1.04,'←分离' ),COLORWHITE;
★长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
DRAWTEXT(★长下影,LOW*1.0,'←长下影'),COLORRED;
★长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
DRAWTEXT(★长上影,HIGH*1.02,'←长上影' ),COLOR00FF00;
★十字星:=CLOSE=OPEN AND HIGH<>LOW;
DRAWTEXT(★十字星,HIGH*1.04,'←十字星' ),COLORWHITE;
★大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;
DRAWTEXT(★大阴烛,HIGH*1.02,'←大阴烛' ),COLOR00FF00;
★好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)
OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);
DRAWTEXT(★好友反攻,LOW*0.98,'←好友反攻'),COLORRED;
★倾盆大雨:=REF(CLOSE,1)/REF(OPEN,1)>=1.03 AND OPEN<REF(CLOSE,1) AND OPEN>REF(OPEN,1) AND CLOSE<REF(OPEN,1);
DRAWTEXT(★倾盆大雨,HIGH*1.04,'←倾盆大雨' ),COLOR00FF00;

[ 本帖最后由 餐厅 于 2011-10-15 23:11 编辑 ]
来自 福建省福州市

举报

使用道具 扔鸡蛋 回复

1127165
Lv.2

专栏

发表于 2011-10-18 10:37 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 福建省福州市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表