请高手把指标中144天线做成与各条均线不同颜色的加粗均线(已解决:狂暴诺基亚)

[通达信] 4272 0
设置
1958431 Lv.2

专栏

发表于 2011-10-15 13:22 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
KK:=INDEXO;HH:=INDEXH;DD:=INDEXL;CC:=INDEXC;
DP:=EMA(INDEXC,500)/EMA(C,500);
STICKLINE(CC>REF(CC,1),(HH+H)/DP,(DD+L)/DP,0,1),COLORRED,LINETHICK3;
STICKLINE(CC>REF(CC,1),(KK+O)/DP,(CC+C)/DP,3,1),COLORRED,LINETHICK3;
STICKLINE(CC<REF(CC,1),(HH+H)/DP,(DD+L)/DP,0,0),COLOR00FF00,LINETHICK3;
STICKLINE(CC<REF(CC,1),(KK+O)/DP,(CC+C)/DP,3,0),COLOR00FF00,LINETHICK3;
一百四四天线:MA(C,144),COLORGRAY;
工作线:(EMA(C,14)),POINTDOT,LINETHICK4,COLORYELLOW;
生命二十五线:(MA(C,25)),LINETHICK2,COLORMAGENTA;
二百三十五天线:MA(C,235),COLORGRAY;
姊妹五十六线:(EMA(C,56)),POINTDOT,COLORWHITE;
A3:=EMA((((SLOPE(C,21)) * 20) + C),68);
A4:=EMA(C,10);
A5:=REF(C,2);
A6:=((SMA((MAX((C - A5),0)),6,1)) / (SMA(ABS((C - A5)),6,1))) * 100;
A7:=IF(((A6 < (REF(A6,1))) AND (A6 > 79)),A6,0);
A8:=LLV(L,21);
A9:=HHV(H,21);
A10:=EMA((((CLOSE - A8) / (A9 - A8)) * 100),5);
A11:=EMA((((CLOSE - A8) / (A9 - A8)) * 50),13);
A12:=EMA(((0.667 * (REF(A10,1))) + (0.333 * A10)),2);
A13:=LLV(L,55);
A14:=HHV(H,34);
A15:=EMA((((C - A13) / (A14 - A13)) * 100),3);
A16:=(A11 + A15) / 2;
A17:=EMA(((0.667 * (REF(A15,1))) + (0.333 * A10)),2);
A18:=EMA(A16,5);
A19:=EMA(((0.667 * (REF(A18,1))) + (0.333 * A18)),2);
A20:=CROSS(A10,A11);
A21:=(CROSS(A10,A19)) AND (A19 < 30);
A22:=A21 * 0.6;
A23:=((C + L) + H) / 3;
A24:=EMA(A23,6);
A25:=EMA(A24,5);
A26:=CROSS(A24,A25);
DRAWICON(A26,(LOW / 1.015),1),LINETHICK2,COLORMAGENTA;
STICKLINE(((C >= 工作线) AND (C >= O)),H,L,0,1),COLORRED;
STICKLINE(((C >= 工作线) AND (C >= O)),O,C,2,1),COLORRED;
STICKLINE(((C >= 工作线) AND (C <= O)),H,L,0,0),COLORRED;
STICKLINE(((C >= 工作线) AND (C <= O)),O,C,2,0),COLORRED;
STICKLINE(((C < 工作线) AND (C >= O)),H,L,0,1),COLORGREEN;
STICKLINE(((C < 工作线) AND (C >= O)),O,C,2,1),COLORGREEN;
STICKLINE(((C < 工作线) AND (C <= O)),H,L,0,0),COLORGREEN;
STICKLINE(((C < 工作线) AND (C <= O)),O,C,2,0),COLORGREEN;

[ 本帖最后由 余北 于 2011-10-15 13:45 编辑 ]
来自 江苏省

举报

使用道具 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表