求助老师把下面的主图指标改成通达信的主图源码。谢谢。

[通达信] 4051 3
设置
2408435 Lv.2

专栏

发表于 2011-10-16 00:19 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
求助老师把下面的主图指标改成通达信的主图源码。谢谢。

DRAWBKBMP(C>REF(C,1),'77');
DRAWBKBMP(C<REF(C,1),'88');
KLINE(O,H,L,C,0);

IF DATATYPE<=6 Then begin
  kd:=19;
  a1:=(ref(hhv(h,20),1)+ref(llv(l,20),1))/2;
  MA1:=MA(h,10);ma2:=MA(l,10);
  Z:=if(STKTYPE=0,1.0191,1.0618);
  jd1:=1.1;jd2:=1.05;jd3:=0.95;jd4:=0.9;
  end;
ELSE IF DATATYPE=7 Then begin
  kd:=14;
  a1:=(ref(hhv(h,15),1)+ref(llv(l,15),1))/2;
  MA1:=MA(h,5);ma2:=MA(l,5);
  Z:=if(STKTYPE=0,1.0382,1.0618);
  jd1:=1.1;jd2:=1.05;jd3:=0.95;jd4:=0.9;
  end;
ELSE IF DATATYPE=8 Then begin
  kd:=2;
  a1:=(hhv(h,3)+llv(l,3))/2;
  MA1:=MA(h,3);ma2:=MA(l,3);
  Z:=if(STKTYPE=0,1.0618,1.0618);
  jd1:=1.35;jd2:=1.2;jd3:=0.85;jd4:=0.75;
  end;
b1:=a1*z;b2:=a1*z*z;c1:=a1/z;c2:=a1/z/z;
P:=SYSPARAM(1);ws:=BARPOS;ws1:=if(ws<kd+5,ws,kd+5);wsp:=p-ws1+1;
疯狂:MA2*jd1,COLORee3300,LINEDOT;
超买:MA2*jd2,COLOR888800,LINEDOT;
超卖:MA1*jd3,COLOR888800,LINEDOT;
恐慌:MA1*jd4,COLOR0000ee,LINEDOT;
DRAWSL(ws=p,b1,0,kd,1),COLOR00ddff,LINEDOT;
DRAWSL(ws=p,b2,0,kd,1),COLOR00FF00;
DRAWSL(ws=p,c1,0,kd,1),COLOR00ddff,LINEDOT;
DRAWSL(ws=p,c2,0,kd,1),COLOR0000FF;
DRAWSL(ws=p,a1,0,kd,1),COLORff00FF,LINEDOT;
STICKLINE(ws=p,b1[p],c1[p],1,0),COLORddddff,LINEDOT;
STICKLINE(ws=wsp,b1[p],c1[p],1,0),SHIFT4,COLORddddff,LINEDOT;
DRAWNUMBER(ws=wsp+7,b2[p],b2[p],2),PXUP25,color00ff00;
DRAWNUMBER(ws=wsp+7,b1[p],b1[p],2),PXUP25,colorCCCCCC;
DRAWNUMBER(ws=wsp+7,c1[p],c1[p],2),PXUP25,colorCCCCCC;
DRAWNUMBER(ws=wsp+7,c2[p],c2[p],2),PXUP25,color00AAff;
DRAWBKBMP(C>REF(C,1),'77');
DRAWBKBMP(C<REF(C,1),'88');
KLINE(O,H,L,C,0);
来自 广东省惠州市

举报

使用道具 扔鸡蛋 回复

2408435
Lv.2

专栏

发表于 2011-10-16 16:16 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省惠州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2095557
Lv.7

专栏

发表于 2011-10-16 13:44 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

2408435
Lv.2

专栏

发表于 2011-10-16 00:59 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省惠州市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
3楼
2楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表