请老师将通达信均线粘合指标公式改为同花顺可用

[其 他] 5752 5
设置
2330733 Lv.3

专栏

发表于 2011-10-16 12:40 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
老师您好!请老师将通达信均线粘合指标公式改为同花顺可用,谢谢!
通达信均线粘合原码如下:
N  2  90  14
     MM  2  60  6
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
AA:=((MA5/MA10<=1.025) AND (MA5/MA10>=0.975)) OR ((MA10/MA5<=1.025) AND (MA10/MA5>=0.975));
BB:=((MA10/MA20<=1.025) AND (MA10/MA20>=0.975)) OR ((MA20/MA10<=1.025) AND (MA20/MA10>=0.975));
CC:=((MA20/MA30<=1.025) AND (MA20/MA30>=0.975)) OR ((MA30/MA20<=1.025) AND (MA30/MA20>=0.975));
DD:=((MA5/MA30<=1.025) AND (MA5/MA30>=0.975)) OR ((MA30/MA5<=1.025) AND (MA30/MA5>=0.975));
EE:=((MA10/MA30<=1.025) AND (MA10/MA30>=0.975)) OR ((MA30/MA10<=1.025) AND (MA30/MA10>=0.975));
FF:=((MA5/MA20<=1.025) AND (MA5/MA20>=0.975)) OR ((MA20/MA5<=1.025) AND (MA20/MA5>=0.975));
GG:=H>=MA5 AND H>=MA10 AND H>=MA20 AND H>=MA30;
A1:=MA(VOL,5);
A2:=MA(VOL,10);
A3:=MA(VOL,20);
A4:=MA(VOL,30);
WW:=VOL>A1;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM);
ADXR:=EXPMEMA(ADX,MM);
AM:=PDI>=MDI;
BM:=ADX>=MDI;
CM:=ADXR>=MDI;
DM:=CROSS(PDI,MDI);
EM:=CROSS(ADX,MDI);
FM:=CROSS(ADXR,MDI);
ZM:=AM AND BM AND CM AND (DM OR EM OR FM);
AA AND BB AND CC AND DD AND EE AND FF AND GG AND WW AND ZM;
来自 浙江省温州市

举报

使用道具 扔鸡蛋 回复

3962298
Lv.1

专栏

发表于 2021-12-12 20:20 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 宁夏银川市

举报

使用道具 支持 扔鸡蛋 回复

3898849
Lv.2

专栏

发表于 2021-6-22 22:07 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省濮阳市

举报

使用道具 支持 扔鸡蛋 回复

1707929
Lv.2

专栏

发表于 2014-6-14 07:16 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 福建省福州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2014-5-18 12:56 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省攀枝花市

举报

使用道具 支持 扔鸡蛋 回复

2095557
Lv.7

专栏

发表于 2011-10-16 15:22 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
5楼
4楼
3楼
2楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表