请老师帮忙改个主图B点选股公式

[通达信] 3301 4
设置
2261832 Lv.4

专栏

发表于 2011-10-17 22:12 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
N:=5;
C增比:=C/REF(C,1);
C均增比:=(C增比+REF(C增比,1)+REF(C增比,2)+REF(C增比,3)+REF(C增比,4))/5;
YC:=C*C均增比;
强弱:=COUNT(YC>REF(YC,1),10)/COUNT(YC<REF(YC,1),10);
A:=EMA(EMA(EMA(EMA(强弱,2),2),2),2);
B:=EMA(EMA(EMA(EMA(强弱,5),5),5),5);
快线红:EMA(EMA(EMA(EMA(YC,2),2),2),2),COLORRED,LINETHICK2;
慢线绿:EMA(EMA(EMA(EMA(YC,5),5),5),5),COLORGREEN,LINETHICK2;
STICKLINE(快线红>慢线绿,快线红,慢线绿,1,0),COLORRED;
STICKLINE(快线红<慢线绿,快线红,慢线绿,1,0),COLOR00CC00;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,L-0.03,L-0.03,15,0),LINETHICK3,COLORMAGENTA;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,H*1.001,H,15,0),COLOR00FF00{98FD};
MTM:=C-REF(C,1);
DX1:=100*EMA(EMA(MTM,N),N)/EMA(EMA(ABS(MTM),N),N);
买1:=IF(LLV(DX1,2)=LLV(DX1,7) AND COUNT(DX1<0,2) AND CROSS(DX1,MA(DX1,2)),1,0);
卖1:=IF(HHV(DX1,2)=HHV(DX1,7) AND COUNT(DX1>50,2) AND CROSS(MA(DX1,2),DX1),1,0);
DRAWTEXT(FILTER(卖1=1,5),HIGH*1.02, ''),COLOR00FF00;
DRAWTEXT(FILTER(买1=1,5),LOW*0.99, ''),COLORRED;
DRAWICON(FILTER(买1=1,5),LOW*0.99,7);
DRAWICON(FILTER(卖1=1,5),HIGH*1.04, 8);

选出B点的选股公式
来自 北京市

举报

使用道具 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2013-12-31 01:01 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省攀枝花市

举报

使用道具 支持 扔鸡蛋 回复

2261832
Lv.4

专栏

发表于 2011-10-17 22:20 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市

举报

使用道具 支持 扔鸡蛋 回复

1800335
Lv.2

专栏

发表于 2011-10-17 22:20 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省绍兴市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2286604
Lv.7

专栏

发表于 2011-10-17 22:17 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
5楼
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表