求助高手老师们把文华指标(量能、动量波段)改成通达信的(已解决,多谢股楚168)

[通达信] 12221 2
设置
2398485 Lv.2

专栏

发表于 2011-10-18 15:29 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
量能指标

VAR1:=(HHV(HIGH,13)-LLV(LOW,13));
VAR2:=(HHV(HIGH,13)-CLOSE);
VAR3:=(CLOSE-LLV(LOW,13));
VAR4:=(((VAR2/VAR1)*100)-70);
VAR5:=(((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*100);
VAR6:=((((2*CLOSE)+HIGH)+LOW)/4);
VAR7:=SMA(((VAR3/VAR1)*100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=(SMA(VAR7,3,1)-SMA(VAR4,9,1));
VAR10:=IFELSE((VAR9>100),(VAR9-100),0);
VAR11:=HHV(HIGH,34);
VAR12:=EMA((((VAR6-VAR8)/(VAR11-VAR8))*100),13);
VAR13:=EMA(((0.667*REF(VAR12,1))+(0.333*VAR12)),2);
STICKLINE(((VAR12-VAR13)>0),VAR12,VAR13,COLORRED,0);
STICKLINE(((VAR12-VAR13)<0),VAR12,VAR13,COLORGREEN,0);
MA11:EMA(VAR13,5),COLORYELLOW ;
A:20,COLORCYAN;
B:80,COLORLIGHTBLUE;

动量波段

VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
M:EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);
STICKLINE(M>=3.2,3.5,3.2,COLORRED,0);
A:3.5;
B:2.8;
G:0.5, COLORYELLOW;
DRAWTEXT(CROSS(M,G),M+0.02 ,'多');
STICKLINE(M<=0.35,0.35,0.01,COLORYELLOW,0);
D:0.2,COLORGREEN;

最好的是能把两指标合二为一.§83§ 多谢各位了

[ 本帖最后由 离期 于 2011-10-19 10:29 编辑 ]
来自 广东省茂名市

举报

使用道具 扔鸡蛋 回复

2148134
Lv.2

专栏

发表于 2011-10-19 18:20 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 辽宁省沈阳市

举报

使用道具 支持 扔鸡蛋 回复

2373735
Lv.3

专栏

发表于 2011-10-18 16:31 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

附件

解答内容.txt [预览]

956 Bytes, 下载次数: 3, 下载积分: 共享币 -10 个

来自 广东省广州市番禺区

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
2楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表